summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-08 02:24:05 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-08 02:24:05 +0000
commit92cff845ae77c5f6db90a819b0b74998688ef8ff (patch)
treed7ad6222b7588bc2fcf57a7043a493790298ba2b /net-nntp
parentFix building with >=glib-2.31 (bug #406249). (diff)
downloadgentoo-2-92cff845ae77c5f6db90a819b0b74998688ef8ff.tar.gz
gentoo-2-92cff845ae77c5f6db90a819b0b74998688ef8ff.tar.bz2
gentoo-2-92cff845ae77c5f6db90a819b0b74998688ef8ff.zip
Fix building with >=glib-2.31 (bug #401437, thanks to Mathias for reporting).
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/ChangeLog6
-rw-r--r--net-nntp/pan/files/pan-0.135-glib-2.31.patch180
-rw-r--r--net-nntp/pan/pan-0.135.ebuild9
3 files changed, 191 insertions, 4 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 97bbf593b5e5..bb47c1d081f3 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/pan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.96 2012/03/25 17:28:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.97 2012/04/08 02:24:05 tetromino Exp $
+
+ 08 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> pan-0.135.ebuild,
+ +files/pan-0.135-glib-2.31.patch:
+ Fix building with >=glib-2.31 (bug #401437, thanks to Mathias for reporting).
25 Mar 2012; Raúl Porcel <armin76@gentoo.org> pan-0.135.ebuild:
alpha/sparc stable wrt #393007
diff --git a/net-nntp/pan/files/pan-0.135-glib-2.31.patch b/net-nntp/pan/files/pan-0.135-glib-2.31.patch
new file mode 100644
index 000000000000..1fd3c352f572
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.135-glib-2.31.patch
@@ -0,0 +1,180 @@
+Author: Dominique Leuenberger <dominique-gnomezilla@leuenberger.net>
+
+glib 2.31 only allows #include'ing glib.h (and a few exceptions to this).
+
+https://bugzilla.gnome.org/show_bug.cgi?id=665289
+
+Index: pan-0.135/pan/data-impl/data-impl.cc
+===================================================================
+--- pan-0.135.orig/pan/data-impl/data-impl.cc
++++ pan-0.135/pan/data-impl/data-impl.cc
+@@ -24,7 +24,7 @@
+ #include <config.h>
+ extern "C" {
+ #include <glib/gi18n.h>
+- #include <glib/gfileutils.h> // for g_build_filename
++ #include <glib.h> // for g_build_filename
+ }
+ #include <pan/general/debug.h>
+ #include <pan/general/file-util.h>
+Index: pan-0.135/pan/data/article-cache.h
+===================================================================
+--- pan-0.135.orig/pan/data/article-cache.h
++++ pan-0.135/pan/data/article-cache.h
+@@ -23,7 +23,7 @@
+ #include <map>
+ #include <vector>
+ extern "C" {
+- #include <glib/gtypes.h> // for guint64
++ #include <glib.h> // for guint64
+ }
+ #include <pan/general/string-view.h>
+ #include <pan/general/quark.h>
+Index: pan-0.135/pan/general/file-util.h
+===================================================================
+--- pan-0.135.orig/pan/general/file-util.h
++++ pan-0.135/pan/general/file-util.h
+@@ -25,7 +25,7 @@
+ extern "C" {
+ #include <stddef.h>
+ #include <stdio.h>
+- #include <glib/gtypes.h>
++ #include <glib.h>
+ #include <glib/gstdio.h>
+ }
+ #include <pan/general/string-view.h>
+Index: pan-0.135/pan/general/locking.h
+===================================================================
+--- pan-0.135.orig/pan/general/locking.h
++++ pan-0.135/pan/general/locking.h
+@@ -22,7 +22,7 @@
+ #ifndef _Mutex_h_
+ #define _Mutex_h_
+
+-#include <glib/gthread.h>
++#include <glib.h>
+
+ namespace pan
+ {
+Index: pan-0.135/pan/general/macros.h
+===================================================================
+--- pan-0.135.orig/pan/general/macros.h
++++ pan-0.135/pan/general/macros.h
+@@ -62,12 +62,11 @@
+
+ extern "C"
+ {
+- #include <glibconfig.h> // get the version
+- #include <glib/gutils.h> // get GLIB_CHECK_VERSION
++ #include <glib.h>
+
+ // pick up g_assert()
+ #if GLIB_CHECK_VERSION(2,16,0)
+- #include <glib/gtestutils.h>
++ #include <glib.h>
+ #else
+ #include <glib/gmessages.h>
+ #endif
+Index: pan-0.135/pan/general/time-elapsed.h
+===================================================================
+--- pan-0.135.orig/pan/general/time-elapsed.h
++++ pan-0.135/pan/general/time-elapsed.h
+@@ -1,9 +1,7 @@
+ #ifndef __Time_Elapsed_h__
+ #define __Time_Elapsed_h__
+
+-#include <glib/gtypes.h> // for GTimeVal
+-#include <glib/gmain.h> // for g_get_current_time
+-#include <glib/gtimer.h> // for GUSEC_PER_SEC
++#include <glib.h>
+
+ namespace pan
+ {
+Index: pan-0.135/pan/general/worker-pool.cc
+===================================================================
+--- pan-0.135.orig/pan/general/worker-pool.cc
++++ pan-0.135/pan/general/worker-pool.cc
+@@ -21,7 +21,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+ #include <cassert>
+-#include <glib/gmain.h> // for g_idle_add
++#include <glib.h> // for g_idle_add
+ #include <pan/general/debug.h>
+ #include <pan/general/macros.h>
+ #include "worker-pool.h"
+Index: pan-0.135/pan/general/worker-pool.h
+===================================================================
+--- pan-0.135.orig/pan/general/worker-pool.h
++++ pan-0.135/pan/general/worker-pool.h
+@@ -24,8 +24,7 @@
+ #define _Worker_Pool_H_
+
+ #include <set>
+-#include <glib/gtypes.h>
+-#include <glib/gthreadpool.h>
++#include <glib.h>
+
+ namespace pan
+ {
+Index: pan-0.135/pan/gui/render-bytes.cc
+===================================================================
+--- pan-0.135.orig/pan/gui/render-bytes.cc
++++ pan-0.135/pan/gui/render-bytes.cc
+@@ -1,4 +1,4 @@
+-#include <glib/gutils.h> // g_snprintf
++#include <glib.h> // g_snprintf
+ #include "render-bytes.h"
+
+ namespace pan
+Index: pan-0.135/pan/gui/render-bytes.h
+===================================================================
+--- pan-0.135.orig/pan/gui/render-bytes.h
++++ pan-0.135/pan/gui/render-bytes.h
+@@ -1,6 +1,6 @@
+ #ifndef RENDER_BYTES_H
+ #define RENDER_BYTES_H
+-#include <glib/gtypes.h>
++#include <glib.h>
+ namespace pan {
+ extern char* render_bytes (guint64);
+ }
+Index: pan-0.135/pan/tasks/socket-impl-gio.h
+===================================================================
+--- pan-0.135.orig/pan/tasks/socket-impl-gio.h
++++ pan-0.135/pan/tasks/socket-impl-gio.h
+@@ -21,8 +21,7 @@
+ #define __SocketGIO_h__
+
+ #include <string>
+-#include <glib/giochannel.h>
+-#include <glib/gstring.h>
++#include <glib.h>
+ #include <pan/tasks/socket.h>
+
+ namespace pan
+Index: pan-0.135/pan/usenet-utils/mime-utils.h
+===================================================================
+--- pan-0.135.orig/pan/usenet-utils/mime-utils.h
++++ pan-0.135/pan/usenet-utils/mime-utils.h
+@@ -21,7 +21,7 @@
+ #define _UtilMime_h_
+
+ #include <vector>
+-#include <glib/gtypes.h>
++#include <glib.h>
+ #include <gmime/gmime-filter.h>
+ #include <gmime/gmime-stream.h>
+ #include <gmime/gmime-message.h>
+Index: pan-0.135/pan/usenet-utils/text-massager.cc
+===================================================================
+--- pan-0.135.orig/pan/usenet-utils/text-massager.cc
++++ pan-0.135/pan/usenet-utils/text-massager.cc
+@@ -25,7 +25,6 @@
+ extern "C" {
+ #include <glib/gi18n.h>
+ }
+-#include <glib/gunicode.h>
+ #include "text-massager.h"
+ #include <pan/general/log.h>
+ using namespace pan;
diff --git a/net-nntp/pan/pan-0.135.ebuild b/net-nntp/pan/pan-0.135.ebuild
index 766dd2787030..9730a6d45b6a 100644
--- a/net-nntp/pan/pan-0.135.ebuild
+++ b/net-nntp/pan/pan-0.135.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.135.ebuild,v 1.8 2012/03/25 17:28:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.135.ebuild,v 1.9 2012/04/08 02:24:05 tetromino Exp $
EAPI="4"
+inherit eutils
+
DESCRIPTION="A newsreader for GNOME"
HOMEPAGE="http://pan.rebelbase.com/"
SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
@@ -23,11 +25,12 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-devel/gettext"
-#src_prepare() {
+src_prepare() {
# XXX: disable the only failing test
#sed '293 s:^\(.*\)$:/*\1*/:' \
# -i pan/usenet-utils/text-massager-test.cc || die "sed failed"
-#}
+ epatch "${FILESDIR}/pan-0.135-glib-2.31.patch" # 401437
+}
src_configure() {
econf --without-gtk3 $(use_with spell gtkspell)