summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-23 11:50:08 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-23 11:50:08 +0000
commit212fdaea76b529fe8e0e176d1206f80b16795154 (patch)
treef92d4c38e901354782659683c01d47f1a5ad9f86 /net-news
parentadding use.defaults file for auto-dep resolution (diff)
downloadgentoo-2-212fdaea76b529fe8e0e176d1206f80b16795154.tar.gz
gentoo-2-212fdaea76b529fe8e0e176d1206f80b16795154.tar.bz2
gentoo-2-212fdaea76b529fe8e0e176d1206f80b16795154.zip
USE dependent nls compilation.
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/files/digest-pan-0.11.2-r11
-rw-r--r--net-news/pan/pan-0.11.2-r1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-news/pan/files/digest-pan-0.11.2-r1 b/net-news/pan/files/digest-pan-0.11.2-r1
new file mode 100644
index 000000000000..3ad43091d5c4
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.11.2-r1
@@ -0,0 +1 @@
+MD5 07e80deb0e1478634b7de71eb3127ccc pan-0.11.2.tar.bz2 1544901
diff --git a/net-news/pan/pan-0.11.2-r1.ebuild b/net-news/pan/pan-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..8f6e650cbcdd
--- /dev/null
+++ b/net-news/pan/pan-0.11.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.11.2-r1.ebuild,v 1.1 2002/03/23 11:50:08 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for GNOME."
+SRC_URI="http://pan.rebelbase.com/download/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com/"
+
+DEPEND="virtual/x11
+ nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=dev-libs/libxml-1.8.11
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.14.0-r1 )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ use gtkhtml && myconf="${myconf} --enable-html"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ # Doesn't work with -j 4 (hallski)
+ make || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}