summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-13 12:39:17 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-13 12:39:17 +0000
commit469bdb3f38c9889722bb90d374c800e8931b1139 (patch)
tree2715d77d2553881b978fad9819590af62d491b7a /net-nds
parentStable for HPPA (bug #476562). (diff)
downloadgentoo-2-469bdb3f38c9889722bb90d374c800e8931b1139.tar.gz
gentoo-2-469bdb3f38c9889722bb90d374c800e8931b1139.tar.bz2
gentoo-2-469bdb3f38c9889722bb90d374c800e8931b1139.zip
Install unit file (#475866)
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog8
-rw-r--r--net-nds/rpcbind/files/rpcbind.service13
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.0-r1.ebuild56
3 files changed, 76 insertions, 1 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index dd163c7b8865..f8592f5d716f 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/rpcbind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.22 2013/04/27 04:15:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.23 2013/07/13 12:39:16 pacho Exp $
+
+*rpcbind-0.2.0-r1 (13 Jul 2013)
+
+ 13 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/rpcbind.service,
+ +rpcbind-0.2.0-r1.ebuild:
+ Install unit file (#475866)
27 Apr 2013; Mike Frysinger <vapier@gentoo.org> rpcbind-0.2.0.ebuild:
Fix build with automake-1.13 (fix is already upstream) #467018 by Alphat-PC.
diff --git a/net-nds/rpcbind/files/rpcbind.service b/net-nds/rpcbind/files/rpcbind.service
new file mode 100644
index 000000000000..305ea9b10b71
--- /dev/null
+++ b/net-nds/rpcbind/files/rpcbind.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=RPC Bind
+After=network.target
+Wants=rpcbind.target
+Before=rpcbind.target
+
+[Service]
+Type=forking
+ExecStart=/sbin/rpcbind
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-nds/rpcbind/rpcbind-0.2.0-r1.ebuild b/net-nds/rpcbind/rpcbind-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..f65c660ded34
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.2.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0-r1.ebuild,v 1.1 2013/07/13 12:39:16 pacho Exp $
+
+EAPI="2"
+
+inherit autotools eutils systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
+ inherit autotools eutils git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://sourceforge.net/projects/rpcbind/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="selinux tcpd"
+
+RDEPEND="net-libs/libtirpc
+ selinux? ( sec-policy/selinux-rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ else
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #467018
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ epatch "${FILESDIR}"/${P}-no-nss.patch
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --bindir=/sbin \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ doman man/rpc{bind,info}.8
+ dodoc AUTHORS ChangeLog NEWS README
+ newinitd "${FILESDIR}"/rpcbind.initd rpcbind || die
+ newconfd "${FILESDIR}"/rpcbind.confd rpcbind || die
+ systemd_dounit "${FILESDIR}"/rpcbind.service
+}