summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-13 07:29:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-13 07:29:01 +0000
commit2325add4405581341877f1dd5c87b45627db185f (patch)
tree7754d9e7d2f4d3ec25d591c577f6a9c822459d21 /net-nds
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2325add4405581341877f1dd5c87b45627db185f.tar.gz
gentoo-2-2325add4405581341877f1dd5c87b45627db185f.tar.bz2
gentoo-2-2325add4405581341877f1dd5c87b45627db185f.zip
Version bump.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/nsscache/ChangeLog9
-rw-r--r--net-nds/nsscache/nsscache-0.19.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/net-nds/nsscache/ChangeLog b/net-nds/nsscache/ChangeLog
index d8fd3b87f17a..fe945de0c73e 100644
--- a/net-nds/nsscache/ChangeLog
+++ b/net-nds/nsscache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/nsscache
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.7 2010/05/04 02:42:38 idl0r Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.8 2011/01/13 07:29:01 robbat2 Exp $
+
+*nsscache-0.19 (13 Jan 2011)
+
+ 13 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> +nsscache-0.19.ebuild:
+ Version bump.
*nsscache-0.8.8 (04 May 2010)
diff --git a/net-nds/nsscache/nsscache-0.19.ebuild b/net-nds/nsscache/nsscache-0.19.ebuild
new file mode 100644
index 000000000000..72952361d3e4
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.19.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/nsscache-0.19.ebuild,v 1.1 2011/01/13 07:29:01 robbat2 Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap
+ dev-python/pycurl"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.8.3-starttls.patch
+}
+
+src_install() {
+ distutils_src_install
+ rm "${ED}"/usr/bin/runtests*
+ insinto /etc
+ doins "${FILESDIR}/nsscache.conf" # overwrite default with working config.
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+ keepdir /var/lib/nsscache
+}
+
+#src_test() {
+ # Needs several modules not in the tree
+ #./runtests.py || die
+#}