summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-07-11 03:59:52 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-07-11 03:59:52 +0000
commitfba0cb1b58f05923d4dff261a3cf96094eeda195 (patch)
treef0432ba7b9064dcea1250655f295f12cfc9a52ad /net-misc
parenthopefully, virtual/linux-sources is real (diff)
downloadgentoo-2-fba0cb1b58f05923d4dff261a3cf96094eeda195.tar.gz
gentoo-2-fba0cb1b58f05923d4dff261a3cf96094eeda195.tar.bz2
gentoo-2-fba0cb1b58f05923d4dff261a3cf96094eeda195.zip
fix preserve_old_lib usage (bug #167991)
(Portage version: 2.1.3_rc7)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/howl/ChangeLog6
-rw-r--r--net-misc/howl/howl-0.9.8.ebuild14
-rw-r--r--net-misc/howl/howl-1.0.0.ebuild16
3 files changed, 21 insertions, 15 deletions
diff --git a/net-misc/howl/ChangeLog b/net-misc/howl/ChangeLog
index 1f2faf48b975..8b6ea1ad6a77 100644
--- a/net-misc/howl/ChangeLog
+++ b/net-misc/howl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/howl
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.48 2007/05/20 17:16:15 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/ChangeLog,v 1.49 2007/07/11 03:59:52 compnerd Exp $
+
+ 11 Jul 2007; Saleem Abdulrasool <compnerd@gentoo.org> howl-0.9.8.ebuild,
+ howl-1.0.0.ebuild:
+ Fix preserve_old_lib usage (bug #167991)
20 May 2007; Timothy Redaelli <drizzt@gentoo.org> howl-1.0.0.ebuild:
Add ~x86-fbsd keyword.
diff --git a/net-misc/howl/howl-0.9.8.ebuild b/net-misc/howl/howl-0.9.8.ebuild
index 430a52cc032e..edc5d177f459 100644
--- a/net-misc/howl/howl-0.9.8.ebuild
+++ b/net-misc/howl/howl-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.19 2007/04/28 23:05:19 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-0.9.8.ebuild,v 1.20 2007/07/11 03:59:52 compnerd Exp $
inherit eutils flag-o-matic
@@ -39,6 +39,13 @@ src_compile() {
emake || die "emake failed"
}
+pkg_preinst() {
+ # howl-0.9.8 introduces a change in library naming,
+ # preserve old libraries to not break things
+ preserve_old_lib /usr/$(get_libdir)/libhowl-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
+ preserve_old_lib /usr/$(get_libdir)/libmDNSResponder-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
+}
+
src_install() {
emake DESTDIR=${D} install || die "emake install failed"
dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
@@ -51,11 +58,6 @@ src_install() {
# Install init scripts
newinitd ${FILESDIR}/nifd.init.d nifd
newinitd ${FILESDIR}/mDNSResponder.init.d mDNSResponder
-
- # howl-0.9.8 introduces a change in library naming,
- # preserve old libraries to not break things
- preserve_old_lib /usr/$(get_libdir)/libhowl-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
- preserve_old_lib /usr/$(get_libdir)/libmDNSResponder-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
}
pkg_postinst() {
diff --git a/net-misc/howl/howl-1.0.0.ebuild b/net-misc/howl/howl-1.0.0.ebuild
index d6da744a12b5..a7dafc95fd1d 100644
--- a/net-misc/howl/howl-1.0.0.ebuild
+++ b/net-misc/howl/howl-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-1.0.0.ebuild,v 1.17 2007/05/20 17:16:15 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-1.0.0.ebuild,v 1.18 2007/07/11 03:59:52 compnerd Exp $
inherit eutils flag-o-matic
@@ -38,6 +38,13 @@ src_compile() {
emake || die "emake failed"
}
+pkg_preinst() {
+ # howl-0.9.8 introduces a change in library naming,
+ # preserve old libraries to not break things
+ preserve_old_lib /usr/$(get_libdir)/libhowl-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
+ preserve_old_lib /usr/$(get_libdir)/libmDNSResponder-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
@@ -52,13 +59,6 @@ src_install() {
newinitd "${FILESDIR}"/mDNSResponder.init.d mDNSResponder
}
-pkg_preinst() {
- # howl-0.9.8 introduces a change in library naming,
- # preserve old libraries to not break things
- preserve_old_lib /usr/$(get_libdir)/libhowl-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
- preserve_old_lib /usr/$(get_libdir)/libmDNSResponder-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]
-}
-
pkg_postinst() {
# inform user about library changes
preserve_old_lib_notify /usr/$(get_libdir)/libhowl-[0-9].[0-9].[0-9].so.[0-9].[0-9].[0-9]