summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-08 18:56:37 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-08 18:56:37 +0000
commitfb97cce231c5b56d3bfd77c24485c57674ce99e6 (patch)
treeb441aa67dbfdca400e01b7f92568a9fd0e756879 /net-misc
parentversion bump, by Arseny Solokha <b0ntrict0r@yandex.ru>, bug #254248 (diff)
downloadgentoo-2-fb97cce231c5b56d3bfd77c24485c57674ce99e6.tar.gz
gentoo-2-fb97cce231c5b56d3bfd77c24485c57674ce99e6.tar.bz2
gentoo-2-fb97cce231c5b56d3bfd77c24485c57674ce99e6.zip
Fix --stdin-stdout option thanks to Israel G. Lugo (bug #182753). Fix quoting.
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/httptunnel/ChangeLog12
-rw-r--r--net-misc/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch12
-rw-r--r--net-misc/httptunnel/httptunnel-3.0.5.ebuild6
-rw-r--r--net-misc/httptunnel/httptunnel-3.3-r1.ebuild33
-rw-r--r--net-misc/httptunnel/httptunnel-3.3.ebuild6
5 files changed, 61 insertions, 8 deletions
diff --git a/net-misc/httptunnel/ChangeLog b/net-misc/httptunnel/ChangeLog
index f33e9867189f..2119a79ea703 100644
--- a/net-misc/httptunnel/ChangeLog
+++ b/net-misc/httptunnel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/httptunnel
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/ChangeLog,v 1.16 2007/07/15 08:48:23 phreak Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/ChangeLog,v 1.17 2009/01/08 18:56:37 jer Exp $
+
+*httptunnel-3.3-r1 (08 Jan 2009)
+
+ 08 Jan 2009; Jeroen Roovers <jer@gentoo.org>
+ +files/httptunnel-3.3-fix_write_stdin.patch, httptunnel-3.0.5.ebuild,
+ httptunnel-3.3.ebuild, +httptunnel-3.3-r1.ebuild:
+ Fix --stdin-stdout option thanks to Israel G. Lugo (bug #182753). Fix
+ quoting.
15 Jul 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Assigning to m-needed, as beu is being retired (#66608).
diff --git a/net-misc/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch b/net-misc/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch
new file mode 100644
index 000000000000..904df6f91159
--- /dev/null
+++ b/net-misc/httptunnel/files/httptunnel-3.3-fix_write_stdin.patch
@@ -0,0 +1,12 @@
+diff -dur httptunnel-3.3/common.c httptunnel-3.3-fix_write_stdin/common.c
+--- httptunnel-3.3/common.c 2001-02-25 12:45:41.000000000 +0100
++++ httptunnel-3.3-fix_write_stdin/common.c 2007-06-20 21:38:54.000000000 +0200
+@@ -314,7 +314,7 @@
+
+ /* If fd == 0, then we are using --stdin-stdout so write to stdout,
+ * not fd. */
+- m = write_all (fd ? fd : 0, buf, (size_t)n);
++ m = write_all (fd ? fd : 1, buf, (size_t)n);
+ log_annoying ("write_all (%d, %p, %d) = %d", fd ? fd : 1, buf, n, m);
+ return m;
+ }
diff --git a/net-misc/httptunnel/httptunnel-3.0.5.ebuild b/net-misc/httptunnel/httptunnel-3.0.5.ebuild
index 1df69c758f69..b5ce5d5cec33 100644
--- a/net-misc/httptunnel/httptunnel-3.0.5.ebuild
+++ b/net-misc/httptunnel/httptunnel-3.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.0.5.ebuild,v 1.10 2005/04/24 02:52:25 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.0.5.ebuild,v 1.11 2009/01/08 18:56:37 jer Exp $
DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
@@ -22,5 +22,5 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
}
diff --git a/net-misc/httptunnel/httptunnel-3.3-r1.ebuild b/net-misc/httptunnel/httptunnel-3.3-r1.ebuild
new file mode 100644
index 000000000000..8b01761fdf1f
--- /dev/null
+++ b/net-misc/httptunnel/httptunnel-3.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.3-r1.ebuild,v 1.1 2009/01/08 18:56:37 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
+HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
+LICENSE="GPL-2"
+DEPEND=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT="0"
+#RDEPEND=""
+SRC_URI="http://www.nocrew.org/software/httptunnel/${P}.tar.gz"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-fix_write_stdin.patch
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+}
diff --git a/net-misc/httptunnel/httptunnel-3.3.ebuild b/net-misc/httptunnel/httptunnel-3.3.ebuild
index edf36221e62d..f7e521b3a131 100644
--- a/net-misc/httptunnel/httptunnel-3.3.ebuild
+++ b/net-misc/httptunnel/httptunnel-3.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.3.ebuild,v 1.7 2007/07/12 02:52:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.3.ebuild,v 1.8 2009/01/08 18:56:37 jer Exp $
DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
@@ -22,5 +22,5 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
}