summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-14 20:10:13 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-14 20:10:13 +0000
commitf00d5fd1f34f1748a09dd83b2aa0228a3e75c856 (patch)
treed5a3135679d51f2db99669008ff1312e3645fb39 /net-misc
parentVersion bumps (diff)
downloadgentoo-2-f00d5fd1f34f1748a09dd83b2aa0228a3e75c856.tar.gz
gentoo-2-f00d5fd1f34f1748a09dd83b2aa0228a3e75c856.tar.bz2
gentoo-2-f00d5fd1f34f1748a09dd83b2aa0228a3e75c856.zip
net-misc/vpnc: Bump to latest upstream rev, fix resolv.conf handling, #406141; fix test, #442174; add myself as maintainer
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vpnc/ChangeLog9
-rw-r--r--net-misc/vpnc/metadata.xml4
-rw-r--r--net-misc/vpnc/vpnc-0.5.3_p527.ebuild64
3 files changed, 76 insertions, 1 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index 1ee1c2b06300..b49f5810c905 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/vpnc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.103 2013/02/06 15:25:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.104 2013/03/14 20:10:13 jlec Exp $
+
+*vpnc-0.5.3_p527 (14 Mar 2013)
+
+ 14 Mar 2013; Justin Lecher <jlec@gentoo.org> +vpnc-0.5.3_p527.ebuild,
+ metadata.xml:
+ Bump to latest upstream rev, fix resolv.conf handling, #406141; fix test,
+ #442174; add myself as maintainer
06 Feb 2013; Justin Lecher <jlec@gentoo.org> vpnc-0.5.3_p514.ebuild,
metadata.xml:
diff --git a/net-misc/vpnc/metadata.xml b/net-misc/vpnc/metadata.xml
index 05c63678ec88..2a2dee5325b7 100644
--- a/net-misc/vpnc/metadata.xml
+++ b/net-misc/vpnc/metadata.xml
@@ -13,6 +13,10 @@
<email>fauli@gentoo.org</email>
<name>Christian Faulhammer</name>
</maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
<use>
<flag name="bindist">Using GnuTLS for SSL support as redistribution with OpenSSL as provider violates GPL</flag>
<flag name="hybrid-auth">Enable hybrid authentication (certificates), only if not redistributed as compiled binary</flag>
diff --git a/net-misc/vpnc/vpnc-0.5.3_p527.ebuild b/net-misc/vpnc/vpnc-0.5.3_p527.ebuild
new file mode 100644
index 000000000000..527240d19fa3
--- /dev/null
+++ b/net-misc/vpnc/vpnc-0.5.3_p527.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.3_p527.ebuild,v 1.1 2013/03/14 20:10:13 jlec Exp $
+
+EAPI=5
+
+inherit eutils linux-info toolchain-funcs
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${PF}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="resolvconf +gnutls bindist"
+
+REQUIRED_USE="bindist? ( gnutls )"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libgcrypt
+ >=sys-apps/iproute2-2.6.19.20061214[-minimal]
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ resolvconf? ( net-dns/openresolv )"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ if ! use gnutls && ! use bindist; then
+ sed -i -e '/^#OPENSSL_GPL_VIOLATION/s:#::g' "${S}"/Makefile || die
+ ewarn "Building SSL support with OpenSSL instead of GnuTLS. This means that"
+ ewarn "you are not allowed to re-distibute the binaries due to conflicts between BSD license and GPL,"
+ ewarn "see the vpnc Makefile and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ else
+ elog "Will build with GnuTLS (default) instead of OpenSSL so you may even redistribute binaries."
+ elog "See the Makefile itself and http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440318"
+ fi
+
+ epatch "${FILESDIR}"/${PN}-0.5.3_p514-as-needed.patch
+
+ sed -e 's:test/cert0.pem::g' -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ dodoc README TODO VERSION
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}/vpnc-3.init" vpnc
+ newconfd "${FILESDIR}/vpnc.confd" vpnc
+ sed -e "s:/usr/local:/usr:" -i "${D}"/etc/vpnc/vpnc-script || die
+ # COPYING file resides here, should not be installed
+ rm -rf "${D}"/usr/share/doc/vpnc/ || die
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available in http://www.gentoo.org/doc/en/vpnc-howto.xml"
+}