summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 03:12:18 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 03:12:18 +0000
commitecbf77905b0e8cfac2a211221d50d932551d3dc0 (patch)
treec3ff906491b08171124331a7ebac83d1f0323f70 /net-misc
parentVersion bump. New HOMEPAGE. Respect LDFLAGS (bug #335420), CFLAGS (and do not... (diff)
downloadgentoo-2-ecbf77905b0e8cfac2a211221d50d932551d3dc0.tar.gz
gentoo-2-ecbf77905b0e8cfac2a211221d50d932551d3dc0.tar.bz2
gentoo-2-ecbf77905b0e8cfac2a211221d50d932551d3dc0.zip
Respect LDFLAGS (bug #335524). Fix compiler warnings.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vtun/ChangeLog8
-rw-r--r--net-misc/vtun/files/vtun-3.0.2-includes.patch72
-rw-r--r--net-misc/vtun/vtun-3.0.2-r1.ebuild53
3 files changed, 132 insertions, 1 deletions
diff --git a/net-misc/vtun/ChangeLog b/net-misc/vtun/ChangeLog
index cea75e32cd9e..2c76fc35cf54 100644
--- a/net-misc/vtun/ChangeLog
+++ b/net-misc/vtun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vtun
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.40 2010/05/18 13:39:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.41 2010/09/18 03:12:18 jer Exp $
+
+*vtun-3.0.2-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org> +vtun-3.0.2-r1.ebuild,
+ +files/vtun-3.0.2-includes.patch:
+ Respect LDFLAGS (bug #335524). Fix compiler warnings.
18 May 2010; Markos Chandras <hwoarang@gentoo.org> vtun-3.0.2.ebuild:
Stable on amd64 wrt bug #317961
diff --git a/net-misc/vtun/files/vtun-3.0.2-includes.patch b/net-misc/vtun/files/vtun-3.0.2-includes.patch
new file mode 100644
index 000000000000..8634a659ca2e
--- /dev/null
+++ b/net-misc/vtun/files/vtun-3.0.2-includes.patch
@@ -0,0 +1,72 @@
+--- a/lfd_encrypt.c 2008-01-07 23:35:32.000000000 +0100
++++ b/lfd_encrypt.c 2010-09-18 04:53:31.000000000 +0200
+@@ -44,6 +44,7 @@
+ #include <strings.h>
+ #include <string.h>
+ #include <time.h>
++#include <arpa/inet.h> /* htonl() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/lib.c 2008-01-07 23:35:40.000000000 +0100
++++ b/lib.c 2010-09-18 04:52:51.000000000 +0200
+@@ -34,6 +34,7 @@
+ #include <sys/wait.h>
+ #include <syslog.h>
+ #include <errno.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/lib.h 2008-01-07 23:35:41.000000000 +0100
++++ b/lib.h 2010-09-18 04:56:50.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <sys/types.h>
+ #include <signal.h>
+ #include <errno.h>
++#include <unistd.h> /* read(), write() */
+
+ #ifdef HAVE_LIBUTIL_H
+ #include <libutil.h>
+--- a/vtun.h 2008-01-07 23:36:07.000000000 +0100
++++ b/vtun.h 2010-09-18 04:56:08.000000000 +0200
+@@ -219,5 +219,9 @@
+ int tunnel(struct vtun_host *host);
+ int read_config(char *file);
+ struct vtun_host * find_host(char *host);
++int send_msg(int len, char *in, char **out);
++int send_ib_mesg(int *len, char **in);
++int recv_msg(int len, char *in, char **out);
++int recv_ib_mesg(int *len, char **in);
+
+ #endif
+--- a/lock.c 2008-01-07 23:35:50.000000000 +0100
++++ b/lock.c 2010-09-18 05:01:21.000000000 +0200
+@@ -32,6 +32,7 @@
+ #include <sys/types.h>
+ #include <signal.h>
+ #include <errno.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
+--- a/server 2008-01-07 23:36:01.000000000 +0100
++++ b/server.c 2010-09-18 05:02:45.000000000 +0200
+@@ -49,6 +49,7 @@
+ #include "auth.h"
+
+ #include "compat.h"
++#include "netlib.h" /* generic_addr() */
+
+ static volatile sig_atomic_t server_term;
+ static void sig_term(int sig)
+--- a/lfd_shaper.c 2008-01-07 23:35:36.000000000 +0100
++++ b/lfd_shaper.c 2010-09-18 05:07:12.000000000 +0200
+@@ -27,6 +27,7 @@
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <syslog.h>
++#include <time.h> /* nanosleep() */
+
+ #include "vtun.h"
+ #include "linkfd.h"
diff --git a/net-misc/vtun/vtun-3.0.2-r1.ebuild b/net-misc/vtun/vtun-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..09f810b53bd1
--- /dev/null
+++ b/net-misc/vtun/vtun-3.0.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-3.0.2-r1.ebuild,v 1.1 2010/09/18 03:12:18 jer Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://vtun.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="lzo socks5 ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )
+ socks5? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_prepare() {
+ sed -i Makefile.in \
+ -e '/^LDFLAGS/s|=|+=|g' \
+ || die "sed Makefile"
+ epatch "${FILESDIR}"/${P}-includes.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable socks5 socks) \
+ --enable-shaper
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog Credits FAQ README README.Setup README.Shaper TODO
+ newinitd "${FILESDIR}"/vtun.rc vtun
+ insinto etc
+ doins "${FILESDIR}"/vtund-start.conf
+}
+
+pkg_postinst() {
+ elog "You will need the Universal TUN/TAP driver compiled into"
+ elog "your kernel or as a module to use the associated tunnel"
+ elog "modes in vtun."
+}