summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-23 01:57:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-23 01:57:30 +0000
commitea1dbe3a4685956f4f1838b720303ca4ff7f7e2f (patch)
tree571c6be16b6a059973947a4fca151d444d4eac7e /net-misc
parentRESTRICT=maketest -> RESTRICT=test (diff)
downloadgentoo-2-ea1dbe3a4685956f4f1838b720303ca4ff7f7e2f.tar.gz
gentoo-2-ea1dbe3a4685956f4f1838b720303ca4ff7f7e2f.tar.bz2
gentoo-2-ea1dbe3a4685956f4f1838b720303ca4ff7f7e2f.zip
Made hylafax multilib-strict safe. Added patch for OpenPAM compatibility (fixed upstream). See bug #95143.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hylafax/ChangeLog7
-rw-r--r--net-misc/hylafax/files/hylafax-4.2.1-openpam.patch40
-rw-r--r--net-misc/hylafax/hylafax-4.2.1-r1.ebuild25
3 files changed, 63 insertions, 9 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index e64cdeee7b2a..1f611e02198d 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.48 2005/02/18 06:50:22 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.49 2005/06/23 01:57:30 flameeyes Exp $
+
+ 23 Jun 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/hylafax-4.2.1-openpam.patch, hylafax-4.2.1-r1.ebuild:
+ Made hylafax multilib-strict safe. Added patch for OpenPAM compatibility
+ (fixed upstream). See bug #95143.
*hylafax-4.2.1 (17 Feb 2005)
diff --git a/net-misc/hylafax/files/hylafax-4.2.1-openpam.patch b/net-misc/hylafax/files/hylafax-4.2.1-openpam.patch
new file mode 100644
index 000000000000..51f211d0d761
--- /dev/null
+++ b/net-misc/hylafax/files/hylafax-4.2.1-openpam.patch
@@ -0,0 +1,40 @@
+diff -ur hylafax-4.2.1/configure hylafax-4.2.1-fbsd/configure
+--- hylafax-4.2.1/configure 2004-12-28 04:45:03 +0000
++++ hylafax-4.2.1-fbsd/configure 2005-06-05 14:45:14 +0000
+@@ -1578,11 +1578,9 @@
+ if [ "$DISABLE_PAM" != "yes" ]; then
+ Note "Checking for PAM (Pluggable Authentication Module) support"
+ CheckForLibrary pam_authenticate -lpam &&
+- CheckForLibrary misc_conv -lpam_misc -lpam &&
+- CheckForIncludeFile security/pam_appl.h &&
+- CheckForIncludeFile security/pam_misc.h && {
++ CheckForIncludeFile security/pam_appl.h && {
+ HAVE_PAM="#define HAVE_PAM 1"
+- PAMLIBS="-lpam -lpam_misc"
++ PAMLIBS="-lpam"
+ }
+ if [ "x$PAMLIBS" = "x" ]; then
+ Note "... not found. Disabling PAM support"
+diff -ur hylafax-4.2.1/hfaxd/HylaFAXServer.h hylafax-4.2.1-fbsd/hfaxd/HylaFAXServer.h
+--- hylafax-4.2.1/hfaxd/HylaFAXServer.h 2004-11-23 18:05:02 +0000
++++ hylafax-4.2.1-fbsd/hfaxd/HylaFAXServer.h 2005-06-05 14:45:35 +0000
+@@ -43,7 +43,6 @@
+ #ifdef HAVE_PAM
+ extern "C" {
+ #include <security/pam_appl.h>
+-#include <security/pam_misc.h>
+ #include <grp.h>
+ }
+ #endif // HAVE_PAM
+diff -ur hylafax-4.2.1/hfaxd/Login.c++ hylafax-4.2.1-fbsd/hfaxd/Login.c++
+--- hylafax-4.2.1/hfaxd/Login.c++ 2004-04-27 20:16:15 +0000
++++ hylafax-4.2.1-fbsd/hfaxd/Login.c++ 2005-06-05 15:15:01 +0000
+@@ -109,7 +109,7 @@
+ for (i=0; i<num_msg; i++) {
+ switch(msg[i]->msg_style) {
+ case PAM_PROMPT_ECHO_OFF:
+- replies[i].resp = x_strdup(password);
++ replies[i].resp = password ? strdup(password) : NULL;
+ replies[i].resp_retcode = 0;
+ retval = PAM_SUCCESS;
+ break;
diff --git a/net-misc/hylafax/hylafax-4.2.1-r1.ebuild b/net-misc/hylafax/hylafax-4.2.1-r1.ebuild
index 9190cfe9fc7b..f61a4d972b15 100644
--- a/net-misc/hylafax/hylafax-4.2.1-r1.ebuild
+++ b/net-misc/hylafax/hylafax-4.2.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.1-r1.ebuild,v 1.1 2005/05/07 00:55:00 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.1-r1.ebuild,v 1.2 2005/06/23 01:57:30 flameeyes Exp $
-inherit eutils
+inherit eutils multilib pam
IUSE="faxonly jpeg pam mgetty"
@@ -20,7 +20,7 @@ DEPEND="!faxonly? ( net-dialup/mgetty )
>=media-libs/tiff-3.7.0
jpeg? ( media-libs/jpeg )
sys-apps/gawk
- pam? ( sys-libs/pam )
+ pam? ( virtual/pam )
mgetty? ( net-dialup/mgetty )"
RDEPEND="${DEPEND}
@@ -28,6 +28,13 @@ RDEPEND="${DEPEND}
export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-openpam.patch
+}
+
src_compile() {
if use faxonly; then
if use mgetty; then
@@ -37,7 +44,7 @@ src_compile() {
local my_conf="
--with-DIR_BIN=/usr/bin
--with-DIR_SBIN=/usr/sbin
- --with-DIR_LIB=/usr/lib
+ --with-DIR_LIB=/usr/$(get_libdir)
--with-DIR_LIBEXEC=/usr/sbin
--with-DIR_LIBDATA=/usr/lib/fax
--with-DIR_LOCKS=/var/lock
@@ -83,13 +90,13 @@ src_compile() {
src_install() {
dodir /usr/{bin,sbin} /usr/lib/fax /usr/share/man /var/spool /var/spool/recvq
- dodir /usr/share/doc/${P}/html
+ dodir /usr/share/doc/${P}/html /usr/$(get_libdir)
make \
BIN=${D}/usr/bin \
SBIN=${D}/usr/sbin \
- LIBDIR=${D}/usr/lib \
- LIB=${D}/usr/lib \
+ LIBDIR=${D}/usr/$(get_libdir) \
+ LIB=${D}/usr/$(get_libdir) \
LIBEXEC=${D}/usr/sbin \
LIBDATA=${D}/usr/lib/fax \
MAN=${D}/usr/share/man \
@@ -109,6 +116,8 @@ src_install() {
insopts -m 755
newins ${FILESDIR}/hylafax-4.2 hylafax
+ pamd_mimic_system hylafax auth account session
+
dodoc COPYRIGHT README TODO VERSION
}
@@ -122,4 +131,4 @@ pkg_postinst() {
echo
einfo "Now run faxsetup and (if necessary) faxaddmodem."
echo
-} \ No newline at end of file
+}