summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-01-14 13:10:28 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-01-14 13:10:28 +0000
commitda0ce34926a747525aee88a2d067df0b0864d575 (patch)
tree0d5f1f2caa10bfa72733d13de7b2a9e2dc2f014d /net-misc
parentnew upstream version (diff)
downloadgentoo-2-da0ce34926a747525aee88a2d067df0b0864d575.tar.gz
gentoo-2-da0ce34926a747525aee88a2d067df0b0864d575.tar.bz2
gentoo-2-da0ce34926a747525aee88a2d067df0b0864d575.zip
Allow compiling with USE=-gsm, bug #118885.
(Portage version: 2.0.53)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/xsupplicant/ChangeLog6
-rw-r--r--net-misc/xsupplicant/xsupplicant-1.2.2.ebuild16
2 files changed, 17 insertions, 5 deletions
diff --git a/net-misc/xsupplicant/ChangeLog b/net-misc/xsupplicant/ChangeLog
index 00b45f54de81..90f12b2efc12 100644
--- a/net-misc/xsupplicant/ChangeLog
+++ b/net-misc/xsupplicant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/xsupplicant
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/ChangeLog,v 1.8 2006/01/13 14:47:59 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/ChangeLog,v 1.9 2006/01/14 13:10:28 brix Exp $
+
+ 14 Jan 2006; Henrik Brix Andersen <brix@gentoo.org>
+ xsupplicant-1.2.2.ebuild:
+ Allow compiling with USE=-gsm, bug #118885.
*xsupplicant-1.2.2 (13 Jan 2006)
diff --git a/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild b/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild
index 4e180ba9439e..373763dc5d79 100644
--- a/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild
+++ b/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild,v 1.1 2006/01/13 14:47:59 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/xsupplicant-1.2.2.ebuild,v 1.2 2006/01/14 13:10:28 brix Exp $
inherit flag-o-matic
@@ -22,12 +22,20 @@ DEPEND="sys-devel/bison
${RDEPEND}"
src_compile() {
+ local conf
+
# fix compilation with recent kernels
- # fix compilation with pcsc-lite-1.2.9_beta9 (bug #81338)
- append-flags -DHEADERS_KERNEL -I/usr/include/PCSC
+ append-flags -DHEADERS_KERNEL
+
+ if use gsm; then
+ # fix USE=-gsm (bug #118885)
+ conf="--enable-eap-sim"
+ # fix compilation with pcsc-lite-1.2.9_beta9 (bug #81338)
+ append-flags -I/usr/include/PCSC
+ fi
econf \
- $(use_enable gsm eap-sim) \
+ ${conf} \
|| die "econf failed"
emake || die "emake failed"