summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-26 14:57:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-26 14:57:28 +0000
commitaa3ce2c47de9e75294324c3677f6fbbe5e3cf5d0 (patch)
tree74341403c7e1a359cd3ed35780ead9baba046e6c /net-misc
parentFix #128028, #130508, #130521, #130933, #131609. (diff)
downloadgentoo-2-aa3ce2c47de9e75294324c3677f6fbbe5e3cf5d0.tar.gz
gentoo-2-aa3ce2c47de9e75294324c3677f6fbbe5e3cf5d0.tar.bz2
gentoo-2-aa3ce2c47de9e75294324c3677f6fbbe5e3cf5d0.zip
touchups
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/htpdate/files/htpdate.init15
-rw-r--r--net-misc/htpdate/htpdate-0.9.1-r1.ebuild17
2 files changed, 17 insertions, 15 deletions
diff --git a/net-misc/htpdate/files/htpdate.init b/net-misc/htpdate/files/htpdate.init
index b40e83596b2e..c4b0418fe6c6 100644
--- a/net-misc/htpdate/files/htpdate.init
+++ b/net-misc/htpdate/files/htpdate.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/files/htpdate.init,v 1.1 2006/04/09 05:50:24 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/files/htpdate.init,v 1.2 2006/05/26 14:57:28 vapier Exp $
depend() {
need net
@@ -9,23 +9,24 @@ depend() {
}
checkconfig() {
- if [ ! -n "${SERVERS}" ] ; then
- eerror "You need to set at least one http server to use in /etc/conf.d/htpdate"
+ if [[ -z ${SERVERS} ]] ; then
+ eerror "You need to set at least one http server to use in /etc/conf.d/htpdate"
return 1
- fi
+ fi
}
start() {
checkconfig || return 1
ebegin "Starting htpdate"
- start-stop-daemon --quiet --start --pidfile /var/run/htpdate.pid --exec /usr/sbin/htpdate \
- -- -D ${HTPDATE_OPTS} ${PROXY} ${SERVERS}
+ start-stop-daemon \
+ --quiet --start --pidfile /var/run/htpdate.pid \
+ --exec /usr/sbin/htpdate \
+ -- -D ${HTPDATE_OPTS} ${PROXY} ${SERVERS}
eend $?
}
stop() {
ebegin "Stopping htpdate"
start-stop-daemon --stop --quiet --pidfile /var/run/htpdate.pid
- rm -f /var/run/htpdate.pid
eend $?
}
diff --git a/net-misc/htpdate/htpdate-0.9.1-r1.ebuild b/net-misc/htpdate/htpdate-0.9.1-r1.ebuild
index f38dee159e10..b8acf1f4a295 100644
--- a/net-misc/htpdate/htpdate-0.9.1-r1.ebuild
+++ b/net-misc/htpdate/htpdate-0.9.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/htpdate-0.9.1-r1.ebuild,v 1.1 2006/04/09 05:50:24 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/htpdate-0.9.1-r1.ebuild,v 1.2 2006/05/26 14:57:28 vapier Exp $
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
HOMEPAGE="http://www.clevervest.com/htp/"
@@ -19,19 +19,20 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
+ gunzip htpdate.8.gz || die
}
src_compile() {
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
}
-src_install () {
+src_install() {
dosbin htpdate || die
- doman htpdate.8.gz || die
- dodoc README Changelog || die
+ doman htpdate.8
+ dodoc README Changelog
- newconfd ${FILESDIR}/htpdate.conf htpdate
- newinitd ${FILESDIR}/htpdate.init htpdate
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init htpdate
}
pkg_postinst() {