summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2008-09-11 11:14:58 +0000
committerAlistair Bush <ali_bush@gentoo.org>2008-09-11 11:14:58 +0000
commita48ba4d1fe18bd76d58295d0035a3c5679bdbdb1 (patch)
tree7f8ca5ec199cee49b2f5380e1b2c7d189a69c81b /net-misc
parentStable for HPPA (bug #225465). (diff)
downloadgentoo-2-a48ba4d1fe18bd76d58295d0035a3c5679bdbdb1.tar.gz
gentoo-2-a48ba4d1fe18bd76d58295d0035a3c5679bdbdb1.tar.bz2
gentoo-2-a48ba4d1fe18bd76d58295d0035a3c5679bdbdb1.zip
Bump tightvnc to fix java support.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tightvnc/ChangeLog8
-rw-r--r--net-misc/tightvnc/files/tightvnc-1.3.9-java-build.patch19
-rw-r--r--net-misc/tightvnc/tightvnc-1.3.9-r2.ebuild123
3 files changed, 149 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index b130256be40f..4accdd2ef4a4 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.122 2008/07/14 17:38:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.123 2008/09/11 11:14:57 ali_bush Exp $
+
+*tightvnc-1.3.9-r2 (11 Sep 2008)
+
+ 11 Sep 2008; Alistair Bush <ali_bush@gentoo.org>
+ +files/tightvnc-1.3.9-java-build.patch, +tightvnc-1.3.9-r2.ebuild:
+ Bump tightvnc to fix java support.
14 Jul 2008; Raúl Porcel <armin76@gentoo.org> files/tightvnc.initd:
Fix init script, bug #231492
diff --git a/net-misc/tightvnc/files/tightvnc-1.3.9-java-build.patch b/net-misc/tightvnc/files/tightvnc-1.3.9-java-build.patch
new file mode 100644
index 000000000000..8503a30c50cf
--- /dev/null
+++ b/net-misc/tightvnc/files/tightvnc-1.3.9-java-build.patch
@@ -0,0 +1,19 @@
+--- vnc_javasrc/Makefile.bak 2008-09-11 21:17:37.000000000 +1200
++++ vnc_javasrc/Makefile 2008-09-11 21:18:30.000000000 +1200
+@@ -4,7 +4,6 @@
+
+ CP = cp
+ JC = javac
+-JCFLAGS = -target 1.1
+ JAR = jar
+ ARCHIVE = VncViewer.jar
+ MANIFEST = MANIFEST.MF
+@@ -32,7 +31,7 @@
+ all: $(CLASSES) $(ARCHIVE)
+
+ $(CLASSES): $(SOURCES)
+- $(JC) $(JCFLAGS) -O $(SOURCES)
++ $(JC) $(JAVACFLAGS) -O $(SOURCES)
+
+ $(ARCHIVE): $(CLASSES) $(MANIFEST)
+ $(JAR) cfm $(ARCHIVE) $(MANIFEST) $(CLASSES)
diff --git a/net-misc/tightvnc/tightvnc-1.3.9-r2.ebuild b/net-misc/tightvnc/tightvnc-1.3.9-r2.ebuild
new file mode 100644
index 000000000000..a0227d9a38e3
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.3.9-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3.9-r2.ebuild,v 1.1 2008/09/11 11:14:57 ali_bush Exp $
+
+inherit eutils toolchain-funcs java-pkg-opt-2
+
+IUSE="java tcpd server"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2
+ java? ( mirror://sourceforge/vnc-tight/${P}_javasrc.tar.gz )"
+HOMEPAGE="http://www.tightvnc.com/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+CDEPEND="~media-libs/jpeg-6b
+ server? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-apps/rgb
+ x11-apps/xauth
+ x11-apps/xsetroot
+ )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ x11-proto/xextproto
+ x11-proto/xproto
+ server? (
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/printproto
+ )
+ >=x11-misc/imake-1
+ x11-misc/gccmakedep
+ x11-misc/makedepend
+ !net-misc/vnc"
+
+src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
+ unpack ${A} && cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.3.8-pathfixes.patch" # fixes bug 78385 and 146099
+ epatch "${FILESDIR}/${PN}-1.3.8-imake-tmpdir.patch" # fixes bug 23483
+ epatch "${FILESDIR}/${PN}-1.3.8-darwin.patch" # fixes bug 89908
+ use mips && epatch "${FILESDIR}/${PN}-1.3.8-mips.patch"
+ epatch "${FILESDIR}"/server-CVE-2007-1003.patch
+ epatch "${FILESDIR}"/server-CVE-2007-1351-1352.patch
+ epatch "${FILESDIR}"/${PV}-fbsd.patch
+
+ if use java; then
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${P}-java-build.patch"
+ fi
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CFLAGS}" World || die
+
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
+ fi
+ if use java; then
+ cd "${WORKDIR}/vnc_javasrc" || die
+ make JAVACFLAGS="$(java-pkg_javac-args)" all || die
+ fi
+
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ if use java; then
+ java-pkg_newjar "${WORKDIR}/vnc_javasrc/VncViewer.jar"
+ java-pkg_dolauncher "${PN}-java"
+ fi
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall "${D}"/usr/bin "${D}"/usr/share/man || die "vncinstall failed"
+
+ if use server; then
+ newconfd "${FILESDIR}"/tightvnc.confd vnc
+ newinitd "${FILESDIR}"/tightvnc.initd vnc
+ else
+ rm -f "${D}"/usr/bin/vncserver
+ rm -f "${D}"/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
+ doicon "${FILESDIR}"/vncviewer.png
+ make_desktop_entry vncviewer vncviewer vncviewer Network
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc "${FILESDIR}"/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}