summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-06-03 06:38:35 +0000
committerPreston A. Elder <prez@gentoo.org>2002-06-03 06:38:35 +0000
commit88c6b5398edb4b5442a7913210e39d40a53c1d94 (patch)
treee88aa0b3eb0e11dcf3fe39b8d53940cbe45aa743 /net-misc
parentdoh... this doesn't fix gcc 3.1/ncurses problems (diff)
downloadgentoo-2-88c6b5398edb4b5442a7913210e39d40a53c1d94.tar.gz
gentoo-2-88c6b5398edb4b5442a7913210e39d40a53c1d94.tar.bz2
gentoo-2-88c6b5398edb4b5442a7913210e39d40a53c1d94.zip
Fixed to work with gcc 3.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nt/ChangeLog6
-rw-r--r--net-misc/nt/files/nt-2.0-gcc31.patch48
-rw-r--r--net-misc/nt/nt-2.0.ebuild4
3 files changed, 56 insertions, 2 deletions
diff --git a/net-misc/nt/ChangeLog b/net-misc/nt/ChangeLog
index 7d12bed83b0b..1e59061f2b8e 100644
--- a/net-misc/nt/ChangeLog
+++ b/net-misc/nt/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-misc/nt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/ChangeLog,v 1.3 2002/04/30 19:06:53 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/ChangeLog,v 1.4 2002/06/03 06:38:35 prez Exp $
*nt-2.0 (30 Apr 2002)
+ 3 Jun 2002: Preston A. Elder <prez@gentoo.org> files/nt-2.0-gcc31.patch :
+
+ Added patch to make compile with gcc 3.1
+
*nt-2.0_rc2 (28 Apr 2002)
*nt-1.30 (1 Feb 2002)
diff --git a/net-misc/nt/files/nt-2.0-gcc31.patch b/net-misc/nt/files/nt-2.0-gcc31.patch
new file mode 100644
index 000000000000..a7ce23befe17
--- /dev/null
+++ b/net-misc/nt/files/nt-2.0-gcc31.patch
@@ -0,0 +1,48 @@
+diff -urNd d4x-2.0/main/client.cc d4x-2.0-new/main/client.cc
+--- d4x-2.0/main/client.cc Thu Mar 28 09:40:38 2002
++++ d4x-2.0-new/main/client.cc Mon Jun 3 06:46:34 2002
+@@ -324,7 +324,7 @@
+ CtrlSocket=new tSocket;
+ };
+
+-tClient::tClient(tCfg *cfg,tSocket *ctrl=NULL){
++tClient::tClient(tCfg *cfg,tSocket *ctrl){
+ hostname=username=userword=buffer=NULL;
+ FileLoaded=0;
+ if (ctrl)
+diff -urNd d4x-2.0/main/dqueue.cc d4x-2.0-new/main/dqueue.cc
+--- d4x-2.0/main/dqueue.cc Thu Apr 4 02:03:16 2002
++++ d4x-2.0-new/main/dqueue.cc Mon Jun 3 06:46:34 2002
+@@ -125,7 +125,7 @@
+ };
+ };
+
+-void d4xDownloadQueue::add(tDownload *what,int where=DL_WAIT){
++void d4xDownloadQueue::add(tDownload *what,int where){
+ if (where==DL_WAIT || where==DL_RUN)
+ RUN_OR_WAIT_DOWNLOADS+=1;
+ queues[where]->insert(what);
+diff -urNd d4x-2.0/main/hproxy.cc d4x-2.0-new/main/hproxy.cc
+--- d4x-2.0/main/hproxy.cc Thu Apr 4 02:03:16 2002
++++ d4x-2.0-new/main/hproxy.cc Mon Jun 3 06:46:34 2002
+@@ -95,7 +95,7 @@
+ tProxyDownload::tProxyDownload(tWriterLoger *log):tHttpDownload(log){
+ };
+
+-int tProxyDownload::init(tAddr *hostinfo,tCfg *cfg,tSocket *s=NULL) {
++int tProxyDownload::init(tAddr *hostinfo,tCfg *cfg,tSocket *s) {
+ DBC_RETVAL_IF_FAIL(hostinfo!=NULL,-1);
+ DBC_RETVAL_IF_FAIL(cfg!=NULL,-1);
+ HTTP=new tHProxyClient(cfg);
+diff -urNd d4x-2.0/main/httpd.cc d4x-2.0-new/main/httpd.cc
+--- d4x-2.0/main/httpd.cc Thu Mar 28 09:40:38 2002
++++ d4x-2.0-new/main/httpd.cc Mon Jun 3 06:46:34 2002
+@@ -179,7 +179,7 @@
+ };
+ };
+
+-int tHttpDownload::init(tAddr *hostinfo,tCfg *cfg,tSocket *s=NULL) {
++int tHttpDownload::init(tAddr *hostinfo,tCfg *cfg,tSocket *s) {
+ Persistent=0;
+ HTTP=new tHttpClient(cfg);
+ RetrNum=0;
diff --git a/net-misc/nt/nt-2.0.ebuild b/net-misc/nt/nt-2.0.ebuild
index 23d4cf83162c..0b4f0ef66b2f 100644
--- a/net-misc/nt/nt-2.0.ebuild
+++ b/net-misc/nt/nt-2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/nt-2.0.ebuild,v 1.2 2002/05/23 06:50:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nt/nt-2.0.ebuild,v 1.3 2002/06/03 06:38:35 prez Exp $
#name of tarball changed
MY_P="${P/nt/d4x}"
@@ -29,6 +29,8 @@ src_unpack() {
cp configure configure.orig
sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g" \
configure.orig >configure
+
+ patch -p1 <${FILESDIR}/nt-2.0-gcc31.patch
}
src_compile() {