summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 23:33:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 23:33:00 +0000
commit5d0143ef3a3838f4a62c57645058ecc42daaf6a1 (patch)
tree71e8172872a1c543b1c53aa228430c535d3a5d0c /net-misc
parentVersion bump for Gnome 3.16. Clean up old revision. (diff)
downloadgentoo-2-5d0143ef3a3838f4a62c57645058ecc42daaf6a1.tar.gz
gentoo-2-5d0143ef3a3838f4a62c57645058ecc42daaf6a1.tar.bz2
gentoo-2-5d0143ef3a3838f4a62c57645058ecc42daaf6a1.zip
Version bump for Gnome 3.16, bug #551112.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/spice-gtk/ChangeLog8
-rw-r--r--net-misc/spice-gtk/metadata.xml7
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.28.ebuild159
3 files changed, 170 insertions, 4 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index f6f64161c54b..dbfe868f1a17 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.97 2015/06/08 22:05:24 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.98 2015/06/09 23:33:00 eva Exp $
+
+*spice-gtk-0.28 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +spice-gtk-0.28.ebuild,
+ metadata.xml:
+ Version bump for Gnome 3.16, bug #551112.
08 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> spice-gtk-0.25-r1.ebuild:
Pin phodav to 1.0 slot, bug #551460.
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
index eed50c4677ce..fe9d14acb5bc 100644
--- a/net-misc/spice-gtk/metadata.xml
+++ b/net-misc/spice-gtk/metadata.xml
@@ -7,16 +7,17 @@
<name>Tiziano Müller</name>
</maintainer>
<use>
+ <flag name="dbus">Support for desktop integration such as
+ automounting and other APIs exposed by your DE via D-Bus</flag>
<flag name="gtk3">Link against <pkg>x11-libs/gtk+:3</pkg> instead of
- <pkg>x11-libs/gtk+:2</pkg></flag>
+ <pkg>x11-libs/gtk+:2</pkg></flag>
+ <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
<flag name="policykit">Enable <pkg>sys-auth/polkit</pkg> support for the
usbredir acl helper</flag>
<flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
devices to another machine over TCP</flag>
<flag name="vala">Generate <pkg>dev-lang/vala</pkg> bindings using
vapigen and regenerate .vala files using valac</flag>
- <flag name="dbus">Support for desktop integration such as
- automounting and other APIs exposed by your DE via D-Bus</flag>
<flag name="webdav">Support for folder-sharing between guest and client
using <pkg>net-libs/phodav</pkg></flag>
</use>
diff --git a/net-misc/spice-gtk/spice-gtk-0.28.ebuild b/net-misc/spice-gtk/spice-gtk-0.28.ebuild
new file mode 100644
index 000000000000..829b51748670
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.28.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.28.ebuild,v 1.1 2015/06/09 23:33:00 eva Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+WANT_AUTOMAKE="1.12"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multibuild python-single-r1 vala
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="dbus gstreamer gtk3 +introspection lz4 policykit pulseaudio python sasl smartcard static-libs usbredir vala webdav"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ?? ( pulseaudio gstreamer )
+"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ ${PYTHON_DEPS}
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ media-libs/opus
+ dev-libs/openssl:=
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ x11-libs/gtk+:2[introspection?]
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg:=
+ sys-libs/zlib
+ introspection? ( dev-libs/gobject-introspection )
+ lz4? ( app-arch/lz4 )
+ python? ( dev-python/pygtk:2 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/libgudev:=
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ !~sys-auth/polkit-0.111 )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=dev-libs/glib-2.43.90:2
+ >=net-libs/libsoup-2.49.91 )
+"
+DEPEND="${RDEPEND}
+ dev-lang/python
+ dev-python/pyparsing
+ dev-perl/Text-CSV
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+
+src_prepare() {
+ epatch_user
+
+ AT_NO_RECURSIVE="yes" eautoreconf
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local myconf
+ local audio="no"
+
+ use gstreamer && audio="gstreamer"
+ use pulseaudio && audio="pulse"
+
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
+
+ myconf="
+ --disable-maintainer-mode \
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ --with-audio=${audio} \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ $(use_enable usbredir) \
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
+ $(use_enable policykit polkit) \
+ $(use_enable vala) \
+ $(use_enable webdav) \
+ $(use_enable dbus) \
+ --disable-gtk-doc \
+ --disable-werror \
+ --enable-pie"
+
+ # Parameter of --with-gtk
+ MULTIBUILD_VARIANTS=( 2.0 )
+ use gtk3 && MULTIBUILD_VARIANTS+=( 3.0 )
+
+ configure() {
+ local myconf=()
+ myconf+=( --with-gtk=${MULTIBUILD_VARIANT} )
+
+ if [[ ${MULTIBUILD_ID} =~ "2.0" ]] ; then
+ myconf+=( $(use_with python) )
+ else
+ myconf+=( --without-python )
+ fi
+
+ ECONF_SOURCE="${S}" econf $@ ${myconf[@]}
+ }
+ multibuild_foreach_variant run_in_build_dir configure ${myconf}
+}
+
+src_compile() {
+ multibuild_foreach_variant run_in_build_dir default
+}
+
+src_test() {
+ multibuild_foreach_variant run_in_build_dir default
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ multibuild_foreach_variant run_in_build_dir default
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ use python && rm -rf "${ED}"/usr/lib*/python*/site-packages/*.la
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+}