summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2007-01-27 23:58:36 +0000
committerGustavo Felisberto <humpback@gentoo.org>2007-01-27 23:58:36 +0000
commit573813fe0f738a50899f2ceaa51529a04389228d (patch)
tree6ac648630d3191c1cc3cf57c317cd54f4966a55d /net-misc
parentadded alpha net-misc/tor (diff)
downloadgentoo-2-573813fe0f738a50899f2ceaa51529a04389228d.tar.gz
gentoo-2-573813fe0f738a50899f2ceaa51529a04389228d.tar.bz2
gentoo-2-573813fe0f738a50899f2ceaa51529a04389228d.zip
1.2.6_alpha at request from flameeyes
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/ChangeLog12
-rw-r--r--net-misc/tor/files/digest-tor-0.1.2.6_alpha3
-rw-r--r--net-misc/tor/files/torrc.sample-0.1.2.6.patch30
-rw-r--r--net-misc/tor/tor-0.1.2.6_alpha.ebuild56
4 files changed, 99 insertions, 2 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 771926401dc9..a8ff6c32dc16 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/tor
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.75 2006/12/18 02:12:21 humpback Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.76 2007/01/27 23:58:36 humpback Exp $
+
+*tor-0.1.2.6_alpha (27 Jan 2007)
+
+ 27 Jan 2007; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/torrc.sample-0.1.2.6.patch, +tor-0.1.2.6_alpha.ebuild:
+ Added alpha release of tor at request from Flameeyes. It seems tork needs
+ it. As always, if it is masked and you install and destroy your system dont
+ come complain alot.
*tor-0.1.1.26 (18 Dec 2006)
diff --git a/net-misc/tor/files/digest-tor-0.1.2.6_alpha b/net-misc/tor/files/digest-tor-0.1.2.6_alpha
new file mode 100644
index 000000000000..6c6650819207
--- /dev/null
+++ b/net-misc/tor/files/digest-tor-0.1.2.6_alpha
@@ -0,0 +1,3 @@
+MD5 62d3fb8a96937d7d5de653a653acb671 tor-0.1.2.6-alpha.tar.gz 1078819
+RMD160 7686d576cecfee166a1c303b87bb56b4ebb420df tor-0.1.2.6-alpha.tar.gz 1078819
+SHA256 617e154bef5a9e6aa76a0c0cad64a7002e440711e24dec54115960f72bfbff76 tor-0.1.2.6-alpha.tar.gz 1078819
diff --git a/net-misc/tor/files/torrc.sample-0.1.2.6.patch b/net-misc/tor/files/torrc.sample-0.1.2.6.patch
new file mode 100644
index 000000000000..7317552c237f
--- /dev/null
+++ b/net-misc/tor/files/torrc.sample-0.1.2.6.patch
@@ -0,0 +1,30 @@
+--- src/config/torrc.sample.in.orig 2007-01-27 23:41:23.000000000 +0000
++++ src/config/torrc.sample.in 2007-01-27 23:43:47.000000000 +0000
+@@ -18,6 +18,11 @@
+ ## With the default Mac OS X installer, Tor will look in ~/.tor/torrc or
+ ## /Library/Tor/torrc
+
++## Default username and group the server will run as
++User tor
++Group tor
++
++PIDFile /var/run/tor/tor.pid
+
+ ## Replace this with "SocksPort 0" if you plan to run Tor only as a
+ ## server, and not make any local application connections yourself.
+@@ -46,6 +51,7 @@
+ #Log notice syslog
+ ## To send all messages to stderr:
+ #Log debug stderr
++Log notice file /var/log/tor/tor.log
+
+ ## Uncomment this to start the process in the background... or use
+ ## --runasdaemon 1 on the command line. This is ignored on Windows;
+@@ -55,6 +61,7 @@
+ ## The directory for keeping all the keys/etc. By default, we store
+ ## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
+ #DataDirectory @LOCALSTATEDIR@/lib/tor
++DataDirectory /var/lib/tor/data
+
+ ## The port on which Tor will listen for local connections from Tor
+ ## controller applications, as documented in control-spec.txt.
diff --git a/net-misc/tor/tor-0.1.2.6_alpha.ebuild b/net-misc/tor/tor-0.1.2.6_alpha.ebuild
new file mode 100644
index 000000000000..56a8fe23588d
--- /dev/null
+++ b/net-misc/tor/tor-0.1.2.6_alpha.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.1.2.6_alpha.ebuild,v 1.1 2007/01/27 23:58:36 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://tor.eff.org"
+MY_PV=${PV/_/-}
+SRC_URI="http://tor.eff.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ dev-libs/libevent"
+RDEPEND="net-proxy/tsocks"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_unpack() {
+ unpack ${A}
+ echo ${P}
+ cd ${S}
+ epatch ${FILESDIR}/torrc.sample-0.1.2.6.patch
+}
+
+src_install() {
+ exeinto /etc/init.d ; newexe ${FILESDIR}/tor.initd tor
+ make DESTDIR=${D} install || die
+
+ dodoc README ChangeLog AUTHORS INSTALL \
+ doc/{HACKING,TODO} \
+ doc/{control-spec.txt,dir-spec.txt,rend-spec.txt,socks-extensions.txt,tor-spec.txt}
+
+ dodir /var/lib/tor
+ dodir /var/log/tor
+ dodir /var/run/tor
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+}
+
+pkg_postinst() {
+ einfo "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ einfo "To have privoxy and tor working together you must add:"
+ einfo "forward-socks4a / localhost:9050 ."
+ ewarn "(notice the . at the end of the line)"
+ einfo "to /etc/privoxy/config"
+}