summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-02 07:09:35 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-02 07:09:35 +0000
commit4b58963a7d9a52fb2823fd9874d512e694e521ed (patch)
tree37ac0018adc3c9bc2cc37ff1f591e4076af9c9f1 /net-misc
parentupdate gcc-3.4 patch #49241 (diff)
downloadgentoo-2-4b58963a7d9a52fb2823fd9874d512e694e521ed.tar.gz
gentoo-2-4b58963a7d9a52fb2823fd9874d512e694e521ed.tar.bz2
gentoo-2-4b58963a7d9a52fb2823fd9874d512e694e521ed.zip
ver bump #49473
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/entropy/ChangeLog7
-rw-r--r--net-misc/entropy/entropy-0.8.2.415.ebuild65
-rw-r--r--net-misc/entropy/files/digest-entropy-0.8.2.4151
-rw-r--r--net-misc/entropy/files/entropy.conf.d6
-rw-r--r--net-misc/entropy/files/entropy.rc31
5 files changed, 109 insertions, 1 deletions
diff --git a/net-misc/entropy/ChangeLog b/net-misc/entropy/ChangeLog
index 1407a1bb9a97..23872a80a6b1 100644
--- a/net-misc/entropy/ChangeLog
+++ b/net-misc/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/entropy
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/ChangeLog,v 1.2 2003/12/12 00:16:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/ChangeLog,v 1.3 2004/05/02 07:09:35 vapier Exp $
+
+*entropy-0.8.2.415 (02 May 2004)
+
+ 02 May 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage + init.d script #49473 by michael.
*entropy-0.7.1.384 (11 Dec 2003)
diff --git a/net-misc/entropy/entropy-0.8.2.415.ebuild b/net-misc/entropy/entropy-0.8.2.415.ebuild
new file mode 100644
index 000000000000..1c6d37c2721c
--- /dev/null
+++ b/net-misc/entropy/entropy-0.8.2.415.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/entropy-0.8.2.415.ebuild,v 1.1 2004/05/02 07:09:35 vapier Exp $
+
+inherit eutils
+
+MY_PV_BUILD=${PV/*.}
+MY_PV=${PV/.${MY_PV_BUILD}}
+DESCRIPTION="A p2p-node to share your files, infos, philosophy ... anonymously"
+HOMEPAGE="http://entropy.stop1984.com/"
+SRC_URI="http://entropy.stop1984.com/files/entropy-${MY_PV}-${MY_PV_BUILD}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="mysql"
+
+DEPEND="sys-libs/zlib
+ dev-libs/expat
+ mysql? ( dev-db/mysql )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ local myconf=""
+ use mysql && myconf="--with-mysql=/usr"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin entropy monoopt storechg || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/entropy.rc entropy
+ insinto /etc/conf.d
+ newins ${FILESDIR}/entropy.conf.d entropy
+
+ pkg_preinst
+ diropts -o entropy -g entropy
+ insopts -o entropy -g entropy -m0644
+ dodir /var/entropy/{de,node,store,tmp}
+ insinto /var/entropy/de
+ doins de/*
+ insinto /var/entropy/node
+ doins node/*
+
+ sed -e "3,$ s:#::g" seed.txt-dist > seed.txt
+ sed \
+ -e "s:seednodes=seed.txt:seednodes=/var/entropy/seed.txt:g" \
+ -e "s:logfile=entropy.log:logfile=/var/entropy/entropy.log:g" \
+ -e "s:storepath=store:storepath=/var/entropy/store:g" \
+ -e "s:temppath=tmp:temppath=/var/entropy/tmp:g" \
+ entropy.conf-dist > entropy.conf
+ insinto /var/entropy
+ doins entropy.conf seed.txt
+
+ dodoc README TODO entropy.conf-dist seed.txt-dist
+ dohtml ENTROPY.html
+ use mysql && dodoc README.MySQL
+}
+
+pkg_preinst() {
+ enewgroup entropy
+ enewuser entropy -1 /bin/false /var/entropy entropy
+}
diff --git a/net-misc/entropy/files/digest-entropy-0.8.2.415 b/net-misc/entropy/files/digest-entropy-0.8.2.415
new file mode 100644
index 000000000000..779568c297ff
--- /dev/null
+++ b/net-misc/entropy/files/digest-entropy-0.8.2.415
@@ -0,0 +1 @@
+MD5 85e3601708ef343f4ab006aba85cdead entropy-0.8.2-415.tgz 794623
diff --git a/net-misc/entropy/files/entropy.conf.d b/net-misc/entropy/files/entropy.conf.d
new file mode 100644
index 000000000000..82f25385f9ea
--- /dev/null
+++ b/net-misc/entropy/files/entropy.conf.d
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/files/entropy.conf.d,v 1.1 2004/05/02 07:09:35 vapier Exp $
+
+# The user to run entropy as
+ENTROPY_USER="entropy"
diff --git a/net-misc/entropy/files/entropy.rc b/net-misc/entropy/files/entropy.rc
new file mode 100644
index 000000000000..62ca56b874d9
--- /dev/null
+++ b/net-misc/entropy/files/entropy.rc
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/files/entropy.rc,v 1.1 2004/05/02 07:09:35 vapier Exp $
+
+depend() {
+ need net
+ use mysql
+}
+
+checkconfig() {
+ local HOME="`getent passwd ${ENTROPY_USER} | cut -d: -f 6`"
+ if [ ! -d ${HOME} ] ; then
+ mkdir -p ${HOME}
+ chown ${ENTROPY_USER} ${HOME}
+ fi
+ cd ${HOME}
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting entropy"
+ su - ${ENTROPY_USER} -c entropy
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping entropy"
+ entropy --kill
+ eend $?
+}