summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2001-02-08 03:56:17 +0000
committerJerry Alexandratos <jerry@gentoo.org>2001-02-08 03:56:17 +0000
commit34fe077a7e81ceef4e564df8b496e2be10c56054 (patch)
treefe40a21a4e4a8e6c47ead26c8468b842f04ff417 /net-misc
parent*** empty log message *** (diff)
downloadgentoo-2-34fe077a7e81ceef4e564df8b496e2be10c56054.tar.gz
gentoo-2-34fe077a7e81ceef4e564df8b496e2be10c56054.tar.bz2
gentoo-2-34fe077a7e81ceef4e564df8b496e2be10c56054.zip
Security update.
Older version zapped due to major security exploits...
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/bind/bind-9.1.0.ebuild53
-rw-r--r--net-misc/bind/files/digest-bind-9.1.01
2 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/bind/bind-9.1.0.ebuild b/net-misc/bind/bind-9.1.0.ebuild
new file mode 100644
index 000000000000..1fe83eb10d41
--- /dev/null
+++ b/net-misc/bind/bind-9.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bind/bind-9.1.0.ebuild,v 1.1 2001/02/08 03:56:17 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/"${A}
+HOMEPAGE="http://www.isc.org/products/BIND"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-devel/libtool-1.3.5
+ >=sys-libs/glibc-2.1.3"
+
+#this service should be upgraded to offer optional supervise support
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/doc/man
+ #fix man pages to reflect Gentoo Linux file locations (drobbins)
+ local x
+ for x in */*
+ do
+ cp ${x} ${x}.orig
+ sed -e 's:/etc/named.conf:/etc/bind/named.conf:g' -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' ${x}.orig > ${x}
+ rm ${x}.orig
+ done
+}
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST} --sysconfdir=/etc/bind --localstatedir=/var --with-libtool
+ try make all
+}
+
+src_install() {
+ dodir /usr/bin
+ try make DESTDIR=${D} install
+ doman doc/man/*/*.[1-8]
+ dodir /etc/rc.d/init.d
+ cp ${FILESDIR}/named ${D}/etc/rc.d/init.d
+ dodir /etc/bind
+ cp ${FILESDIR}/named.conf ${D}/etc/bind/named.conf
+ cd ${S}/doc/arm
+ dodoc *.html
+}
+
+#bind needs config files set up correctly before it should be enabled.
+#pkg_config() {
+# . ${ROOT}/etc/rc.d/config/functions
+#
+# echo "BIND enabled."
+#}
diff --git a/net-misc/bind/files/digest-bind-9.1.0 b/net-misc/bind/files/digest-bind-9.1.0
new file mode 100644
index 000000000000..ecc6340f8654
--- /dev/null
+++ b/net-misc/bind/files/digest-bind-9.1.0
@@ -0,0 +1 @@
+MD5 28f30cfbe60b91c6ec1a0e51c24db889 bind-9.1.0.tar.gz