summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-02 03:15:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-02 03:15:09 +0000
commitb109eab65cd1cf2c945e861d1fcd3df465aa366b (patch)
treec909cc3eafe36e83d599b01f773a4f140e6e7ae2 /net-misc/wicd/wicd-1.7.0_alpha2.ebuild
parentVersion bump (diff)
downloadgentoo-2-b109eab65cd1cf2c945e861d1fcd3df465aa366b.tar.gz
gentoo-2-b109eab65cd1cf2c945e861d1fcd3df465aa366b.tar.bz2
gentoo-2-b109eab65cd1cf2c945e861d1fcd3df465aa366b.zip
Version bump to fix bugs with the first alpha release
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wicd/wicd-1.7.0_alpha2.ebuild')
-rw-r--r--net-misc/wicd/wicd-1.7.0_alpha2.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/wicd/wicd-1.7.0_alpha2.ebuild b/net-misc/wicd/wicd-1.7.0_alpha2.ebuild
new file mode 100644
index 000000000000..7f1ea2911366
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.0_alpha2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.0_alpha2.ebuild,v 1.1 2009/12/02 03:15:09 darkside Exp $
+
+EAPI=2
+
+MY_P=${P/_alpha/a}
+inherit distutils
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="http://downloads.wicd.net/src/testing/1.7.x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk ioctl libnotify ncurses +pm-utils"
+
+DEPEND=""
+# Maybe virtual/dhcp would work, but there are enough problems with
+# net-misc/dhcp that I want net-misc/dhcpcd to be guarenteed to be considered
+# first if none are installed.
+RDEPEND="
+ dev-python/dbus-python
+ gtk? ( dev-python/pygtk )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ || (
+ x11-misc/ktsuss
+ x11-libs/gksu
+ kde-base/kdesu
+ )
+ ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
+ libnotify? ( dev-python/notify-python )
+ ncurses? ( dev-python/urwid )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ ${python} ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES NEWS AUTHORS README"
+ distutils_src_install
+ keepdir /var/lib/wicd/configurations \
+ || die "keepdir failed, critical for this app"
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect} \
+ || die "keepdir failed, critical for this app"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if has_version sys-auth/pambase; then
+ if ! built_with_use sys-auth/pambase consolekit; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+ fi
+}