summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-28 04:01:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-28 04:01:57 +0000
commit4b921ccc422c73e555d2423439f6c8eb61cd24a7 (patch)
tree1f2ef53e45a43ab4335466ebf5f6a618801f2104 /net-misc/suite3270
parentinitial commit (diff)
downloadgentoo-2-4b921ccc422c73e555d2423439f6c8eb61cd24a7.tar.gz
gentoo-2-4b921ccc422c73e555d2423439f6c8eb61cd24a7.tar.bz2
gentoo-2-4b921ccc422c73e555d2423439f6c8eb61cd24a7.zip
initial commit
Diffstat (limited to 'net-misc/suite3270')
-rw-r--r--net-misc/suite3270/ChangeLog9
-rw-r--r--net-misc/suite3270/Manifest3
-rw-r--r--net-misc/suite3270/files/digest-suite3270-3.2.201
-rw-r--r--net-misc/suite3270/suite3270-3.2.20.ebuild95
4 files changed, 107 insertions, 1 deletions
diff --git a/net-misc/suite3270/ChangeLog b/net-misc/suite3270/ChangeLog
new file mode 100644
index 000000000000..f61db45152e4
--- /dev/null
+++ b/net-misc/suite3270/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/suite3270
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.1 2003/07/28 04:01:54 robbat2 Exp $
+
+*suite3270-3.2.20 (27 Jul 2003)
+
+ 27 Jul 2003; Robin H. Johnson <robbat2@gentoo.org> suite3270-3.2.20.ebuild:
+ Initial Commit.
+
diff --git a/net-misc/suite3270/Manifest b/net-misc/suite3270/Manifest
index 60d3e69ba017..1381b0ae7194 100644
--- a/net-misc/suite3270/Manifest
+++ b/net-misc/suite3270/Manifest
@@ -1,2 +1,3 @@
-MD5 390b2d0b82fb0734d859d799d295cdff suite3270-3.2.20.ebuild 884
+MD5 0431a54df1a5d1d787f5abc02a908a6f suite3270-3.2.20.ebuild 2218
+MD5 bdd8506b60398251b903fab881aac1f1 ChangeLog 349
MD5 35f92984c78401de3fdbc722e61d0e73 files/digest-suite3270-3.2.20 64
diff --git a/net-misc/suite3270/files/digest-suite3270-3.2.20 b/net-misc/suite3270/files/digest-suite3270-3.2.20
new file mode 100644
index 000000000000..1cbbd90ce615
--- /dev/null
+++ b/net-misc/suite3270/files/digest-suite3270-3.2.20
@@ -0,0 +1 @@
+MD5 9036269775a0a14078958e30a0ed4ee6 suite3270-3220.tgz 1608609
diff --git a/net-misc/suite3270/suite3270-3.2.20.ebuild b/net-misc/suite3270/suite3270-3.2.20.ebuild
new file mode 100644
index 000000000000..2c4b63163ff0
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.2.20.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.2.20.ebuild,v 1.1 2003/07/28 04:01:54 robbat2 Exp $
+
+IUSE="tcltk X"
+
+S="${WORKDIR}"
+DESCRIPTION="Complete 3270 access package"
+SRC_URI="http://x3270.bgp.nu/download/${PN}-${PV//.}.tgz"
+HOMEPAGE="http://www.geocities.com/SiliconValley/Peaks/7814/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl )
+ sys-libs/ncurses
+ sys-libs/readline"
+
+suite3270_src_compile() {
+ [ -z "${1}" ] && die "Need a parameter of the item to build!"
+ local MY_P="${1}"
+ shift
+ cd ${S}/${MY_P}-3.2
+ local myconf_tmp="${*}"
+ local myconf=""
+ for i in ${myconf_tmp}; do
+ grep -q -- "${i/=*}" configure
+ [ "$?" -eq "0" ] && myconf="${myconf} ${i}"
+ done
+ einfo "Compiling ${MY_P} with ${myconf}"
+ econf ${myconf} || die
+ emake || die
+ cd ${S}
+}
+
+suite3270_src_install() {
+ [ -z "${1}" ] && die "Need a parameter of the item to build!"
+ local MY_P="${1}"
+ shift
+ cd ${S}/${MY_P}-3.2
+ local myconf="${*}"
+ make DESTDIR=${D} ${myconf} install || die
+ cd ${S}
+}
+
+suite3270_makelist() {
+ MY_PLIST="c3270 pr3287 s3270"
+ use X && MY_PLIST="${MY_PLIST} x3270"
+ use tcltk && MY_PLIST="${MY_PLIST} tcl3270"
+}
+
+src_compile() {
+ suite3270_makelist
+ local myconf_common
+ myconf_common="--without-pr3287 --cache-file=${S}/config.cache"
+ use X && myconf_common="${myconf_common} --with-x"
+ if use tcltk; then
+ for j in `seq 9 1`; do
+ has_version "=dev-lang/tcl-8.${j}*"
+ if [ "$?" -eq "0" ]; then
+ einfo "Found TCL-8.${j}"
+ myconf_common="${myconf_common} --with-tcl=8.${j}"
+ break
+ fi
+ done
+ fi
+ for i in ${MY_PLIST}; do
+ suite3270_src_compile ${i} "${myconf_common}"
+ done
+}
+
+src_install () {
+ suite3270_makelist
+ for i in ${MY_PLIST}; do
+ suite3270_src_install ${i}
+ done
+
+ use X && rm ${D}/usr/X11R6/lib/X11/fonts/misc/fonts.dir
+}
+
+pkg_postinst() {
+ if use X; then
+ einfo ">>> Running mkfontdir on /usr/X11R6/lib/X11/fonts/misc"
+ mkfontdir /usr/lib/X11/fonts/misc
+ fi
+}
+
+pkg_postrm() {
+ if use X; then
+ einfo ">>> Running mkfontdir on /usr/X11R6/lib/X11/fonts/misc"
+ mkfontdir /usr/lib/X11/fonts/misc
+ fi
+}