summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-22 09:29:27 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-22 09:29:27 +0000
commit9732750435c35d5a8aed8c0e196e54aaa4bfbeac (patch)
treefaf0fd295bc53cb9d931ae51b8e630987fcdea15 /net-misc/stunnel
parentupdate dep under test?, update test phase (diff)
downloadgentoo-2-9732750435c35d5a8aed8c0e196e54aaa4bfbeac.tar.gz
gentoo-2-9732750435c35d5a8aed8c0e196e54aaa4bfbeac.tar.bz2
gentoo-2-9732750435c35d5a8aed8c0e196e54aaa4bfbeac.zip
Add unit file (#493978)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog8
-rw-r--r--net-misc/stunnel/files/stunnel.tmpfiles.conf1
-rw-r--r--net-misc/stunnel/stunnel-4.56-r2.ebuild77
3 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 8bdc7594d7d4..55ef0156bb1d 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/stunnel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.149 2013/08/06 12:35:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.150 2013/12/22 09:29:27 pacho Exp $
+
+*stunnel-4.56-r2 (22 Dec 2013)
+
+ 22 Dec 2013; Pacho Ramos <pacho@gentoo.org> +files/stunnel.tmpfiles.conf,
+ +stunnel-4.56-r2.ebuild:
+ Add unit file (#493978)
06 Aug 2013; Agostino Sarubbo <ago@gentoo.org> stunnel-4.56-r1.ebuild:
Stable for s390, wrt bug #460278
diff --git a/net-misc/stunnel/files/stunnel.tmpfiles.conf b/net-misc/stunnel/files/stunnel.tmpfiles.conf
new file mode 100644
index 000000000000..f118e68a0be0
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel.tmpfiles.conf
@@ -0,0 +1 @@
+d /var/run/stunnel 0770 stunnel stunnel -
diff --git a/net-misc/stunnel/stunnel-4.56-r2.ebuild b/net-misc/stunnel/stunnel-4.56-r2.ebuild
new file mode 100644
index 000000000000..f4e0d6aaf158
--- /dev/null
+++ b/net-misc/stunnel/stunnel-4.56-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.56-r2.ebuild,v 1.1 2013/12/22 09:29:27 pacho Exp $
+
+EAPI="5"
+
+inherit ssl-cert eutils systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://stunnel.mirt.net/"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 selinux tcpd xforward listen-queue"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ >=dev-libs/openssl-0.9.8k"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-stunnel )"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ use xforward && epatch "${FILESDIR}/${P}-xforwarded-for.patch"
+ use listen-queue && epatch "${FILESDIR}/${P}-listen-queue.patch"
+
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample "${ED}"/usr/bin/stunnel3 \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ newinitd "${FILESDIR}"/stunnel.initd-start-stop-daemon stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}