summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-09-13 18:05:48 +0000
committerIan Leitch <port001@gentoo.org>2003-09-13 18:05:48 +0000
commit4a7bbda212456ae2ab40e397dc3d52ef8bb26024 (patch)
tree88a9d527ee685d105aac4b6c04cc756a760b21a5 /net-misc/socat
parentVersion bump and more flags for AC (diff)
downloadgentoo-2-4a7bbda212456ae2ab40e397dc3d52ef8bb26024.tar.gz
gentoo-2-4a7bbda212456ae2ab40e397dc3d52ef8bb26024.tar.bz2
gentoo-2-4a7bbda212456ae2ab40e397dc3d52ef8bb26024.zip
Version bump and more flags for AC
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/ChangeLog8
-rw-r--r--net-misc/socat/Manifest4
-rw-r--r--net-misc/socat/files/digest-socat-1.3.2.11
-rw-r--r--net-misc/socat/socat-1.3.2.1.ebuild66
4 files changed, 76 insertions, 3 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index a98ee6fe8547..9a733c8203d7 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/socat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.6 2003/08/02 13:27:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.7 2003/09/13 18:05:43 port001 Exp $
+
+*socat-1.3.2.1 (13 Sep 2003)
+
+ 13 Sep 2003; Ian Leitch <port001@gentoo.org> socat-1.3.2.1.ebuild:
+ Version bump to 1.3.2.1 and added ~ppc ~hppa ~amd64 ~sparc ~mips ~arm flags.
+ Closes bug #28627
02 Aug 2003; Aron Griffis <agriffis@gentoo.org> socat-1.3.2.0.ebuild:
Add ~alpha to KEYWORDS
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index d0b12bb7ada8..62124e392ae7 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,7 +1,7 @@
MD5 ed0ae89e582e9582f4d0260ed7938d7a socat-1.3.0.1.ebuild 1621
-MD5 6e5199089d66356ba5c309fb762268b7 socat-1.3.2.1.ebuild 1581
+MD5 17dd3734de1e1e36ada63e855fba06ca socat-1.3.2.1.ebuild 1580
MD5 bb5b065dac63f06ef6d6e6aa60a10f4a socat-1.3.1.0.ebuild 1622
-MD5 a389cca3b4d665b33f274a8ad32437f3 ChangeLog 964
+MD5 6cf52b50a501eaa34bb90a239c8a1ae2 ChangeLog 963
MD5 c9b4d194315a0a7c55c1476ddb5f66b4 socat-1.3.2.0.ebuild 1545
MD5 506ab9d342949b2589479d2c61ff4038 files/digest-socat-1.3.0.1 66
MD5 3716109facbed0db26250a872dd6eda1 files/digest-socat-1.3.1.0 66
diff --git a/net-misc/socat/files/digest-socat-1.3.2.1 b/net-misc/socat/files/digest-socat-1.3.2.1
new file mode 100644
index 000000000000..e7ba764849a3
--- /dev/null
+++ b/net-misc/socat/files/digest-socat-1.3.2.1
@@ -0,0 +1 @@
+MD5 860fe417ea5e9ca2d2b2225192b85b87 socat-1.3.2.1.tar.bz2 226156
diff --git a/net-misc/socat/socat-1.3.2.1.ebuild b/net-misc/socat/socat-1.3.2.1.ebuild
new file mode 100644
index 000000000000..19b70616d0ec
--- /dev/null
+++ b/net-misc/socat/socat-1.3.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.3.2.1.ebuild,v 1.1 2003/09/13 18:05:43 port001 Exp $
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/${PN}/download/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~hppa ~amd64 ~sparc ~mips ~arm"
+
+IUSE="ssl readline ipv6"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ virtual/glibc"
+RDEPEND="virtual/glibc"
+
+S="${WORKDIR}/socat-1.3"
+
+src_compile() {
+
+ # Construct the config options for the optional features.
+ local myconf
+ use ssl || myconf="--disable-openssl"
+ use readline || myconf="${myconf} --disable-readline"
+ use ipv6 || myconf="${myconf} --disable-ip6"
+
+ sed -i "s:-Wall:${CFLAGS} -Wall:" Makefile.in
+ econf ${myconf}
+
+ # Calculating dependencies
+ # (this seems to error out (due to gcc3?) but compiles work
+ # nonetheless)
+ make depend
+
+ # Starting the compile
+ emake || die
+}
+
+src_install() {
+ # The original install target is a bit broken when installing
+ # into temporary roots.
+
+ # The docs.
+ dodoc BUGREPORTS CHANGES COPYING* DEVELOPMENT
+ dodoc EXAMPLES FAQ FILES PORTING README
+ dodoc SECURITY VERSION
+ dodoc xio.help
+
+ # The example scripts
+ dodoc daemon.sh ftp.sh mail.sh
+
+ # The html docs
+ dohtml socat.html
+
+ # The manpage
+ doman socat.1
+
+ # And the executables
+ exeinto /usr/bin
+ doexe socat
+ doexe procan
+ doexe filan
+}