summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-29 19:47:26 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-29 19:47:26 +0000
commit5fe3a0885fae90f32f92300f0f1676ee7c53c376 (patch)
treea47a878db8273918f1e997c7302b1b96862a7166 /net-misc/socat/socat-1.3.2.0.ebuild
parentVersion bumped (diff)
downloadgentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.tar.gz
gentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.tar.bz2
gentoo-2-5fe3a0885fae90f32f92300f0f1676ee7c53c376.zip
Version bumped
Diffstat (limited to 'net-misc/socat/socat-1.3.2.0.ebuild')
-rw-r--r--net-misc/socat/socat-1.3.2.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/socat/socat-1.3.2.0.ebuild b/net-misc/socat/socat-1.3.2.0.ebuild
new file mode 100644
index 000000000000..9c1e2e297346
--- /dev/null
+++ b/net-misc/socat/socat-1.3.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.3.2.0.ebuild,v 1.1 2003/07/29 19:47:10 mholzer Exp $
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/${PN}/download/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="ssl readline ipv6"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ virtual/glibc"
+RDEPEND="virtual/glibc"
+
+S="${WORKDIR}/socat-1.3"
+
+src_compile() {
+
+ # Construct the config options for the optional features.
+ local myconf
+ use ssl || myconf="--disable-openssl"
+ use readline || myconf="${myconf} --disable-readline"
+ use ipv6 || myconf="${myconf} --disable-ip6"
+
+ sed -i "s:-Wall:${CFLAGS} -Wall:" Makefile.in
+ econf ${myconf}
+
+ # Calculating dependencies
+ # (this seems to error out (due to gcc3?) but compiles work
+ # nonetheless)
+ make depend
+
+ # Starting the compile
+ emake || die
+}
+
+src_install() {
+ # The original install target is a bit broken when installing
+ # into temporary roots.
+
+ # The docs.
+ dodoc BUGREPORTS CHANGES COPYING* DEVELOPMENT
+ dodoc EXAMPLES FAQ FILES PORTING README
+ dodoc SECURITY VERSION
+ dodoc xio.help
+
+ # The example scripts
+ dodoc daemon.sh ftp.sh mail.sh
+
+ # The html docs
+ dohtml socat.html
+
+ # The manpage
+ doman socat.1
+
+ # And the executables
+ exeinto /usr/bin
+ doexe socat
+ doexe procan
+ doexe filan
+}