summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-11-04 14:51:51 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-11-04 14:51:51 +0000
commitbeddd8ce0e6e0128cb7e12a3e079362e93f66d61 (patch)
tree09fcbcd87c0d0876823161d0296fe01bf9962ce9 /net-misc/rdist
parentFix some QA problems in the ebuild and add a patch by Keef Aragon to fix bug ... (diff)
downloadgentoo-2-beddd8ce0e6e0128cb7e12a3e079362e93f66d61.tar.gz
gentoo-2-beddd8ce0e6e0128cb7e12a3e079362e93f66d61.tar.bz2
gentoo-2-beddd8ce0e6e0128cb7e12a3e079362e93f66d61.zip
Add patch from splite to fix Bug 66774. The patch makes ssh the default transport if the "crypt" flag is used. It also fixes the yacc grammer so that bison can again be used. It changes the output format of the noexec option. Finally, it installs the files as group root instead of bin and man.
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-misc/rdist')
-rw-r--r--net-misc/rdist/ChangeLog11
-rw-r--r--net-misc/rdist/files/digest-rdist-6.1.5-r23
-rw-r--r--net-misc/rdist/files/rdist-6.1.5-mkstemp.patch26
-rw-r--r--net-misc/rdist/rdist-6.1.5-r2.ebuild56
4 files changed, 95 insertions, 1 deletions
diff --git a/net-misc/rdist/ChangeLog b/net-misc/rdist/ChangeLog
index 5c46cbae9960..4c70e7822fa0 100644
--- a/net-misc/rdist/ChangeLog
+++ b/net-misc/rdist/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/rdist
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rdist/ChangeLog,v 1.12 2007/05/14 19:45:45 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdist/ChangeLog,v 1.13 2007/11/04 14:51:50 masterdriverz Exp $
+
+*rdist-6.1.5-r2 (04 Nov 2007)
+
+ 04 Nov 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+ +files/rdist-6.1.5-mkstemp.patch, +rdist-6.1.5-r2.ebuild:
+ Add patch from splite to fix Bug 66774. The patch makes ssh the default
+ transport if the "crypt" flag is used. It also fixes the yacc grammer so
+ that bison can again be used. It changes the output format of the noexec
+ option. Finally, it installs the files as group root instead of bin and man.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/net-misc/rdist/files/digest-rdist-6.1.5-r2 b/net-misc/rdist/files/digest-rdist-6.1.5-r2
new file mode 100644
index 000000000000..9b298744880f
--- /dev/null
+++ b/net-misc/rdist/files/digest-rdist-6.1.5-r2
@@ -0,0 +1,3 @@
+MD5 546779700af70aa5f9103e08782cdcac rdist-6.1.5.tar.gz 117861
+RMD160 7344e137ab74192aeb2517fd63b4bbed0f70e039 rdist-6.1.5.tar.gz 117861
+SHA256 2bb0d0f5904eadc9e7fe3d60c15389d6897fcf884211070e289a6c710ff37f96 rdist-6.1.5.tar.gz 117861
diff --git a/net-misc/rdist/files/rdist-6.1.5-mkstemp.patch b/net-misc/rdist/files/rdist-6.1.5-mkstemp.patch
new file mode 100644
index 000000000000..642f69b1ff80
--- /dev/null
+++ b/net-misc/rdist/files/rdist-6.1.5-mkstemp.patch
@@ -0,0 +1,26 @@
+--- src/message.c.orig 1998-11-09 23:13:30.000000000 -0500
++++ src/message.c 2005-01-20 11:39:48.156866817 -0500
+@@ -455,6 +455,8 @@
+ int flags;
+ char *msgbuf;
+ {
++ int fd;
++
+ if (IS_ON(flags, MT_DEBUG))
+ return;
+
+@@ -475,10 +477,12 @@
+ (void) sprintf(tempfile, "%s/%s", cp, _RDIST_TMP);
+
+ msgfac->mf_filename = tempfile;
+- (void) mktemp(msgfac->mf_filename);
+- if ((msgfac->mf_fptr = fopen(msgfac->mf_filename, "w"))==NULL)
++ if ((fd = mkstemp(msgfac->mf_filename)) == -1)
+ fatalerr("Cannot open notify file for writing: %s: %s.",
+ msgfac->mf_filename, SYSERR);
++ if ((msgfac->mf_fptr = fdopen(fd, "w")) == NULL)
++ fatalerr("Cannot associate stream with file %s: %s.",
++ msgfac->mf_filename, SYSERR);
+ debugmsg(DM_MISC, "Created notify temp file '%s'",
+ msgfac->mf_filename);
+ }
diff --git a/net-misc/rdist/rdist-6.1.5-r2.ebuild b/net-misc/rdist/rdist-6.1.5-r2.ebuild
new file mode 100644
index 000000000000..a366402088b4
--- /dev/null
+++ b/net-misc/rdist/rdist-6.1.5-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdist/rdist-6.1.5-r2.ebuild,v 1.1 2007/11/04 14:51:50 masterdriverz Exp $
+
+DESCRIPTION="Remote software distribution system"
+HOMEPAGE="http://www.magnicomp.com/rdist/rdist.shtml"
+SRC_URI="http://www.magnicomp.com/download/rdist/${P}.tar.gz"
+
+LICENSE="RDist"
+SLOT="1"
+KEYWORDS="~alpha ~ia64 ~ppc ~sparc ~x86"
+IUSE="crypt"
+
+DEPEND="sys-devel/bison"
+RDEPEND="crypt? ( virtual/ssh )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Change the following #define (10 Mar 2004 agriffis)
+ sed -i -e 's/^\(#define ARG_TYPE\).*/\1 ARG_STDARG/' config/os-linux.h \
+ || die "sed ARG_TYPE failed"
+ # Linux switched from a.out to ELF years ago...
+ sed -i -e 's/^\(#define EXE_TYPE\).*/\1 EXE_ELF/' config/os-linux.h \
+ || die "sed EXE_TYPE failed"
+ sed -i -e 's/a\.out/ELF/g' doc/rdist.man || die "sed a.out failed"
+
+ # crypto lovers prefer ssh to rsh
+ if use crypt; then
+ sed -i -e 's,^\(#define _PATH_REMSH\).*,\1 "/usr/bin/ssh",' \
+ config/os-linux.h || die "sed _PATH_REMSH failed"
+ fi
+
+ # remove yacc-isms eshewed by modern bisons
+ sed -i -e '/^%type/ s/,//g' -e 's/= {/{/g' src/gram.y || die "fixup of gram.y failed"
+
+ # use mkstemp(3) instead of mktemp(3)
+ epatch "${FILESDIR}/rdist_mkstemp.patch"
+}
+
+src_compile() {
+ # pull in <string.h> so strerror() is defined properly (64-bit bug)
+ emake DEFS_LOCAL=-DNEED_STRING_H YACC='bison -y' || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man{1,8}
+ make install \
+ BIN_GROUP=root \
+ BIN_DIR="${D}/usr/bin" || die "make install failed"
+ make install.man \
+ MAN_GROUP=root \
+ MAN_1_DIR=${D}/usr/share/man/man1 MAN_8_DIR=${D}/usr/share/man/man8 \
+ || die "make install.man failed"
+}