summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-08-18 20:13:22 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-08-18 20:13:22 +0000
commit7429ecfb9284b8659e1b48a0e2ece51a53d6c3e0 (patch)
tree02952791e2787c16260a884934c99f6d1520e645 /net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild
parentMark stable on all arches, trim old versions (Manifest recommit) (diff)
downloadgentoo-2-7429ecfb9284b8659e1b48a0e2ece51a53d6c3e0.tar.gz
gentoo-2-7429ecfb9284b8659e1b48a0e2ece51a53d6c3e0.tar.bz2
gentoo-2-7429ecfb9284b8659e1b48a0e2ece51a53d6c3e0.zip
Adding KDE integration patch and closing bug #58312.
Diffstat (limited to 'net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild')
-rw-r--r--net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild b/net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..151f69fbb37e
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.3.1-r1.ebuild,v 1.1 2004/08/18 20:13:22 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ia64 ~ppc64"
+IUSE="kde ssl debug"
+
+DEPEND="virtual/x11
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Apply KDE 3.3.0 compatibility patch from KDE CVS submitted to bug #58312
+ # by Ronald Moesbergen <r.moesbergen@hccnet.nl>
+ use kde && epatch ${FILESDIR}/${P}-kde.patch
+}
+
+src_compile() {
+ local myconf
+ use ssl \
+ && myconf="--with-openssl=/usr/include/openssl" \
+ || myconf="--without-openssl"
+
+ sed -i -e '/-O2/c\' -e 'cflags="$cflags ${CFLAGS}"' configure
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sharedir=/usr/share/${PN} \
+ `use_with debug` \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc COPYING doc/HACKING doc/TODO doc/keymapping.txt
+}