summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:03:03 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:03:03 +0000
commita9ce64f9e82d1090e6c9c41fd2637ebeb7a2694c (patch)
treeaed182398743842ab602f878906b48efebe31f7e /net-misc/radvd
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-a9ce64f9e82d1090e6c9c41fd2637ebeb7a2694c.tar.gz
gentoo-2-a9ce64f9e82d1090e6c9c41fd2637ebeb7a2694c.tar.bz2
gentoo-2-a9ce64f9e82d1090e6c9c41fd2637ebeb7a2694c.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-misc/radvd')
-rw-r--r--net-misc/radvd/radvd-0.7.1.ebuild17
-rw-r--r--net-misc/radvd/radvd-0.7.2.ebuild17
2 files changed, 18 insertions, 16 deletions
diff --git a/net-misc/radvd/radvd-0.7.1.ebuild b/net-misc/radvd/radvd-0.7.1.ebuild
index 65b8da33fbda..7c393ee7eca5 100644
--- a/net-misc/radvd/radvd-0.7.1.ebuild
+++ b/net-misc/radvd/radvd-0.7.1.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.1.ebuild,v 1.2 2002/11/02 13:53:55 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.1.ebuild,v 1.3 2002/11/30 21:02:23 vapier Exp $
-IUSE=""
DESCRIPTION="Linux IPv6 Router Advertisement Daemon (radvd)"
HOMEPAGE="http://v6web.litech.org/radvd/"
SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
-DEPEND="virtual/glibc
- virtual/kernel"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
+DEPEND="virtual/glibc
+ virtual/kernel"
+
pkg_preinst() {
if ! groupmod radvd; then
groupadd -g 75 radvd || die "problem adding group radvd"
@@ -27,11 +28,11 @@ pkg_preinst() {
src_compile() {
econf --libexecdir=/usr/lib/radvd \
--with-pidfile=/var/run/radvd/radvd.pid \
- --sysconfdir=/etc/radvd || die "./configure failed"
+ --sysconfdir=/etc/radvd
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc CHANGES COPYRIGHT INTRO.html README TODO
@@ -41,12 +42,12 @@ src_install () {
exeinto /etc/init.d
doexe ${FILESDIR}/radvd
- mkdir -p ${D}/var/run/radvd
+ dodir /var/run/radvd
fowners radvd.radvd /var/run/radvd
fperms 755 /var/run/radvd
}
-pkg_postinst () {
+pkg_postinst() {
einfo To make it work you have to configure /etc/radvd/radvd.conf and put
einfo the line net.ipv6.conf.all.forwarding = 1 in sysctl.conf or just run
einfo sysctl -w net.ipv6.conf.all.forwarding=1 in your firewallscripts before
diff --git a/net-misc/radvd/radvd-0.7.2.ebuild b/net-misc/radvd/radvd-0.7.2.ebuild
index a9f020042270..3fb73c684f4d 100644
--- a/net-misc/radvd/radvd-0.7.2.ebuild
+++ b/net-misc/radvd/radvd-0.7.2.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.2.ebuild,v 1.1 2002/11/26 00:52:47 edolnx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/radvd/radvd-0.7.2.ebuild,v 1.2 2002/11/30 21:03:03 vapier Exp $
-IUSE=""
DESCRIPTION="Linux IPv6 Router Advertisement Daemon (radvd)"
HOMEPAGE="http://v6web.litech.org/radvd/"
SRC_URI="http://v6web.litech.org/radvd/dist/${P}.tar.gz"
-DEPEND="virtual/glibc
- virtual/kernel"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
+DEPEND="virtual/glibc
+ virtual/kernel"
+
pkg_preinst() {
if ! groupmod radvd; then
groupadd -g 75 radvd || die "problem adding group radvd"
@@ -27,11 +28,11 @@ pkg_preinst() {
src_compile() {
econf --libexecdir=/usr/lib/radvd \
--with-pidfile=/var/run/radvd/radvd.pid \
- --sysconfdir=/etc/radvd || die "./configure failed"
+ --sysconfdir=/etc/radvd
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc CHANGES COPYRIGHT INTRO.html README TODO
@@ -41,12 +42,12 @@ src_install () {
exeinto /etc/init.d
doexe ${FILESDIR}/radvd
- mkdir -p ${D}/var/run/radvd
+ dodir /var/run/radvd
fowners radvd.radvd /var/run/radvd
fperms 755 /var/run/radvd
}
-pkg_postinst () {
+pkg_postinst() {
einfo To make it work you have to configure /etc/radvd/radvd.conf and put
einfo the line net.ipv6.conf.all.forwarding = 1 in sysctl.conf or just run
einfo sysctl -w net.ipv6.conf.all.forwarding=1 in your firewallscripts before