summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-07-18 08:41:29 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-07-18 08:41:29 +0000
commitff3fe68c49ca79e90a2fb1712c1e5881858e0175 (patch)
tree3e9fb9a501ba0f757757ffe9eccda140177595f6 /net-misc/openvswitch
parentInitial import (diff)
downloadgentoo-2-ff3fe68c49ca79e90a2fb1712c1e5881858e0175.tar.gz
gentoo-2-ff3fe68c49ca79e90a2fb1712c1e5881858e0175.tar.bz2
gentoo-2-ff3fe68c49ca79e90a2fb1712c1e5881858e0175.zip
Add init.d-script for ovs-controller
(Portage version: 2.1.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/ChangeLog9
-rw-r--r--net-misc/openvswitch/files/ovs-controller24
-rw-r--r--net-misc/openvswitch/files/ovs-controller_conf7
-rw-r--r--net-misc/openvswitch/files/ovs-vswitchd4
-rw-r--r--net-misc/openvswitch/openvswitch-1.6.1-r2.ebuild (renamed from net-misc/openvswitch/openvswitch-1.6.1-r1.ebuild)4
5 files changed, 44 insertions, 4 deletions
diff --git a/net-misc/openvswitch/ChangeLog b/net-misc/openvswitch/ChangeLog
index 9e2fccc48d68..6ac7345aa1cb 100644
--- a/net-misc/openvswitch/ChangeLog
+++ b/net-misc/openvswitch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openvswitch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.3 2012/07/18 07:53:05 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/ChangeLog,v 1.4 2012/07/18 08:41:29 dev-zero Exp $
+
+*openvswitch-1.6.1-r2 (18 Jul 2012)
+
+ 18 Jul 2012; Tiziano Müller <dev-zero@gentoo.org> +files/ovs-controller,
+ +files/ovs-controller_conf, +openvswitch-1.6.1-r2.ebuild,
+ -openvswitch-1.6.1-r1.ebuild, files/ovs-vswitchd:
+ Add init.d-script for ovs-controller
18 Jul 2012; Tiziano Müller <dev-zero@gentoo.org> openvswitch-1.6.1-r1.ebuild:
Add GPL-2 to LICENSE for init.d files (bug #426086).
diff --git a/net-misc/openvswitch/files/ovs-controller b/net-misc/openvswitch/files/ovs-controller
new file mode 100644
index 000000000000..554aebe3f2bc
--- /dev/null
+++ b/net-misc/openvswitch/files/ovs-controller
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/files/ovs-controller,v 1.1 2012/07/18 08:41:29 dev-zero Exp $
+
+depend() {
+ need lo
+}
+
+start() {
+ checkpath -d "/var/run/openvswitch" -m 0750
+
+ ebegin "Starting Open vSwitch OpenFlow controller"
+ start-stop-daemon \
+ --start --quiet --pidfile "/var/run/openvswitch/ovs-controller.pid" \
+ --exec /usr/bin/ovs-controller -- --pidfile --detach --monitor ${OPTIONS} ${METHODS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Open vSwitch OpenFlow controller"
+ start-stop-daemon --stop --quiet --pidfile "/var/run/openvswitch/ovs-controller.pid"
+ eend $?
+}
diff --git a/net-misc/openvswitch/files/ovs-controller_conf b/net-misc/openvswitch/files/ovs-controller_conf
new file mode 100644
index 000000000000..1756c9b98bc4
--- /dev/null
+++ b/net-misc/openvswitch/files/ovs-controller_conf
@@ -0,0 +1,7 @@
+
+# Space separated list of methods to listen for OpenFlow connections from switches
+# The default ist "ptcp:" which starts ovs-controller listening on port 6633 on all interfaces.
+METHODS="ptcp:"
+
+# Additional options
+# OPTIONS=""
diff --git a/net-misc/openvswitch/files/ovs-vswitchd b/net-misc/openvswitch/files/ovs-vswitchd
index 4fd1758a8f26..eea20db5406e 100644
--- a/net-misc/openvswitch/files/ovs-vswitchd
+++ b/net-misc/openvswitch/files/ovs-vswitchd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/files/ovs-vswitchd,v 1.1 2012/06/27 08:49:34 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/files/ovs-vswitchd,v 1.2 2012/07/18 08:41:29 dev-zero Exp $
depend() {
use ovsdb-server
@@ -13,7 +13,7 @@ start() {
ebegin "Starting Open vSwitch daemon"
start-stop-daemon \
--start --quiet --pidfile "/var/run/openvswitch/ovs-vswitchd.pid" \
- --exec /usr/sbin/ovs-vswitchd -- --pidfile --detach --monitor ${OPTIONS} ${DB_SOCKET}
+ --exec /usr/sbin/ovs-vswitchd -- --pidfile --detach --monitor ${OPTIONS} ${DATABASE}
eend $?
}
diff --git a/net-misc/openvswitch/openvswitch-1.6.1-r1.ebuild b/net-misc/openvswitch/openvswitch-1.6.1-r2.ebuild
index ffe067415d3c..6bffd35ab526 100644
--- a/net-misc/openvswitch/openvswitch-1.6.1-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-1.6.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.6.1-r1.ebuild,v 1.2 2012/07/18 07:53:05 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvswitch/openvswitch-1.6.1-r2.ebuild,v 1.1 2012/07/18 08:41:29 dev-zero Exp $
EAPI=4
@@ -79,8 +79,10 @@ src_install() {
newconfd "${FILESDIR}/ovsdb-server_conf" ovsdb-server
newconfd "${FILESDIR}/ovs-vswitchd_conf" ovs-vswitchd
+ newconfd "${FILESDIR}/ovs-controller_conf" ovs-controller
doinitd "${FILESDIR}/ovsdb-server"
doinitd "${FILESDIR}/ovs-vswitchd"
+ doinitd "${FILESDIR}/ovs-controller"
insinto /etc/logrotate.d
newins rhel/etc_logrotate.d_openvswitch openvswitch