summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-12-21 16:07:21 +0000
committerStuart Herbert <stuart@gentoo.org>2003-12-21 16:07:21 +0000
commit5587145c617f3c88e12a14da8065751bb8cfa5b5 (patch)
tree39fafd2812670947b2cbcdabfd680ca87eeccec5 /net-misc/nxssh
parentVersion bump (diff)
downloadgentoo-2-5587145c617f3c88e12a14da8065751bb8cfa5b5.tar.gz
gentoo-2-5587145c617f3c88e12a14da8065751bb8cfa5b5.tar.bz2
gentoo-2-5587145c617f3c88e12a14da8065751bb8cfa5b5.zip
Version bump
Diffstat (limited to 'net-misc/nxssh')
-rw-r--r--net-misc/nxssh/ChangeLog5
-rw-r--r--net-misc/nxssh/Manifest4
-rw-r--r--net-misc/nxssh/files/digest-nxssh-1.3.01
-rw-r--r--net-misc/nxssh/nxssh-1.3.0.ebuild49
4 files changed, 56 insertions, 3 deletions
diff --git a/net-misc/nxssh/ChangeLog b/net-misc/nxssh/ChangeLog
index 5da52ebf8a1a..9570e39d3752 100644
--- a/net-misc/nxssh/ChangeLog
+++ b/net-misc/nxssh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/nxssh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/ChangeLog,v 1.4 2003/11/13 21:08:27 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/ChangeLog,v 1.5 2003/12/21 16:05:29 stuart Exp $
+
+ 21 Dec 2003; Stuart Herbert <stuart@gentoo.org> :
+ Version bump
*nxssh-1.3.0_beta2 (13 Nov 2003)
diff --git a/net-misc/nxssh/Manifest b/net-misc/nxssh/Manifest
index d827f71122cd..8a6791ef04e4 100644
--- a/net-misc/nxssh/Manifest
+++ b/net-misc/nxssh/Manifest
@@ -1,8 +1,8 @@
MD5 2efca95cb96408fa104941c779481fbf nxssh-1.2.2.ebuild 1367
-MD5 be492060372dcddb45e4a4868dd674e0 nxssh-1.3.0.ebuild 1380
+MD5 86d30985a825c64833085b133247c925 nxssh-1.3.0.ebuild 1374
MD5 df865a146fd43896711c079363970b28 nxssh-1.3.0_beta2.ebuild 1394
MD5 3ac8346a284f12bc14098433f37a2ad5 nxssh-1.2.2-r1.ebuild 1370
-MD5 00dcc19bc61fd51e07d209ba8b37af76 ChangeLog 739
+MD5 5b274be21d0be2e8f25ae949b6621224 ChangeLog 739
MD5 0d90a3579c4f3a0310c775b71e87fb2a metadata.xml 370
MD5 86260dbef1a3c70e78196bb5b196a922 files/digest-nxssh-1.3.0_beta2 65
MD5 f6305e9a9358e4b8a76fc81c45775fce files/digest-nxssh-1.2.2 65
diff --git a/net-misc/nxssh/files/digest-nxssh-1.3.0 b/net-misc/nxssh/files/digest-nxssh-1.3.0
new file mode 100644
index 000000000000..336dc71f3d78
--- /dev/null
+++ b/net-misc/nxssh/files/digest-nxssh-1.3.0
@@ -0,0 +1 @@
+MD5 b01616aeeed597261c358eb65851966a nxssh-1.3.0-4.tar.gz 873914
diff --git a/net-misc/nxssh/nxssh-1.3.0.ebuild b/net-misc/nxssh/nxssh-1.3.0.ebuild
new file mode 100644
index 000000000000..b20d61379967
--- /dev/null
+++ b/net-misc/nxssh/nxssh-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/nxssh-1.3.0.ebuild,v 1.1 2003/12/21 16:05:29 stuart Exp $
+
+MY_P="${PN}-1.3.0-4"
+DESCRIPTION="Modified openssh client, used by nxclient"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="http://www.nomachine.com/download/nxsources/nxssh/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -mips -alpha"
+DEPEND=""
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+IUSE="tcpd pam kerberos"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ # app-crypt/mit-krb5
+ use kerberos && myconf="${myconf} --with-kerberos5"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/NX/bin
+ doexe nxssh
+}