summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-01-16 10:12:16 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-01-16 10:12:16 +0000
commitb1bb003275df5eb3251c6804c9a1c098c167487e (patch)
treec6eeb4247667e680a88112fef684a5f860a02ef5 /net-misc/nxclient
parentRe-add ~arm/~s390/~sh wrt #199368 (diff)
downloadgentoo-2-b1bb003275df5eb3251c6804c9a1c098c167487e.tar.gz
gentoo-2-b1bb003275df5eb3251c6804c9a1c098c167487e.tar.bz2
gentoo-2-b1bb003275df5eb3251c6804c9a1c098c167487e.zip
Maintenance release version bump
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'net-misc/nxclient')
-rw-r--r--net-misc/nxclient/ChangeLog10
-rw-r--r--net-misc/nxclient/nxclient-3.3.0.6.ebuild69
2 files changed, 77 insertions, 2 deletions
diff --git a/net-misc/nxclient/ChangeLog b/net-misc/nxclient/ChangeLog
index 1c5bdc36c5f3..1e869b0e82a8 100644
--- a/net-misc/nxclient/ChangeLog
+++ b/net-misc/nxclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/nxclient
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.72 2008/11/21 10:37:40 voyageur Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/ChangeLog,v 1.73 2009/01/16 10:12:16 voyageur Exp $
+
+*nxclient-3.3.0.6 (16 Jan 2009)
+
+ 16 Jan 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +nxclient-3.3.0.6.ebuild:
+ Maintenance release version bump
*nxclient-3.3.0.3 (21 Nov 2008)
diff --git a/net-misc/nxclient/nxclient-3.3.0.6.ebuild b/net-misc/nxclient/nxclient-3.3.0.6.ebuild
new file mode 100644
index 000000000000..d0e797a93dff
--- /dev/null
+++ b/net-misc/nxclient/nxclient-3.3.0.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/nxclient-3.3.0.6.ebuild,v 1.1 2009/01/16 10:12:16 voyageur Exp $
+
+inherit eutils versionator
+
+MAJOR_PV="$(get_version_component_range 1-3)"
+FULL_PV="${MAJOR_PV}-$(get_version_component_range 4)"
+DESCRIPTION="X11/VNC/NXServer client (remote desktops over low-bandwidth links)"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="amd64? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxclient-${FULL_PV}.x86_64.tar.gz )
+ x86? ( http://64.34.161.181/download/${MAJOR_PV}/Linux/nxclient-${FULL_PV}.i386.tar.gz )"
+LICENSE="nomachine"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="dev-libs/expat
+ >=dev-libs/openssl-0.9.8e
+ media-libs/audiofile
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/freetype
+ media-libs/fontconfig
+ net-print/cups
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXrender
+ x11-libs/libXau
+ x11-libs/libXext
+ sys-libs/zlib
+ !net-misc/nxclient-2xterminalserver"
+
+S=${WORKDIR}/NX
+
+src_install()
+{
+ # we install nxclient into /usr/NX, to make sure it doesn't clash
+ # with libraries installed for FreeNX
+
+ for x in nxclient nxesd nxkill nxprint nxservice nxssh ; do
+ into /usr/NX
+ dobin bin/$x
+ into /usr
+ make_wrapper $x ./$x /usr/NX/bin /usr/NX/lib || die
+ done
+
+ dodir /usr/NX/lib
+ cp -P lib/libXcompsh.so* lib/libXcomp.so* "${D}"/usr/NX/lib
+
+ dodir /usr/NX/share
+ cp -R share "${D}"/usr/NX
+
+ # Add icons/desktop entries (missing in the tarball)
+ cd share/icons
+ for size in *; do
+ dodir /usr/share/icons/hicolor/${size}/apps
+ for icon in admin desktop icon wizard; do
+ dosym /usr/NX/share/icons/${size}/nxclient-${icon}.png \
+ /usr/share/icons/hicolor/${size}/apps
+ done
+ done
+ make_desktop_entry "nxclient" "NX Client" nxclient-icon
+ make_desktop_entry "nxclient -admin" "NX Session Administrator" nxclient-admin
+ make_desktop_entry "nxclient -wizard" "NX Connection Wizard" nxclient-wizard
+}