summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-12-15 17:20:04 +0000
committerAron Griffis <agriffis@gentoo.org>2005-12-15 17:20:04 +0000
commit91529eb1b935296250d0ab0eb9947654feef1ec4 (patch)
treef99f7313d9dd2d5767db688a74c5e4196f294a53 /net-misc/nxclient/nxclient-1.5.0-r1.ebuild
parentMarked stable on x86. (diff)
downloadgentoo-2-91529eb1b935296250d0ab0eb9947654feef1ec4.tar.gz
gentoo-2-91529eb1b935296250d0ab0eb9947654feef1ec4.tar.bz2
gentoo-2-91529eb1b935296250d0ab0eb9947654feef1ec4.zip
Bump upstream sources from 1.5.0-113 to 1.5.0-135
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'net-misc/nxclient/nxclient-1.5.0-r1.ebuild')
-rw-r--r--net-misc/nxclient/nxclient-1.5.0-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/nxclient/nxclient-1.5.0-r1.ebuild b/net-misc/nxclient/nxclient-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..748c8170c80f
--- /dev/null
+++ b/net-misc/nxclient/nxclient-1.5.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxclient/nxclient-1.5.0-r1.ebuild,v 1.1 2005/12/15 17:20:04 agriffis Exp $
+
+inherit rpm
+
+DESCRIPTION="NXClient is a X11/VNC/NXServer client especially tuned for using remote desktops over low-bandwidth links such as the Internet"
+HOMEPAGE="http://www.nomachine.com"
+
+IUSE=""
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 -mips -ppc -sparc ~x86"
+RESTRICT="nostrip"
+
+SRC_URI="
+ amd64? ( http://web04.nomachine.com/download/1.5.0/client/nxclient-1.5.0-135.i386.tar.gz )
+ x86? ( http://web04.nomachine.com/download/1.5.0/client/nxclient-1.5.0-135.i386.rpm )"
+
+DEPEND="
+ =net-misc/nxssh-1.5*
+ net-analyzer/gnu-netcat
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-2.1.4
+ )
+ x86? (
+ media-libs/jpeg
+ sys-libs/glibc
+ sys-libs/zlib
+ virtual/x11
+ dev-libs/expat
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/jpeg
+ x11-libs/qt
+ )"
+
+S=${WORKDIR}
+
+src_install() {
+ # rpm has usr/NX/; tarball has only NX/
+ if [[ ! -d usr ]]; then
+ mkdir usr
+ mv NX usr || die
+ fi
+
+ cp -dPR usr ${D}
+
+ # All of the libraries delivered by nxclient are available in our deps.
+ # Additionally a couple of the binaries are better installed as deps.
+ # Remove those now...
+
+ # delivered by net-misc/nxcomp
+ rm -f ${D}/usr/NX/lib/libXcomp.so*
+
+ # delivered by net-misc/nx-x11 (at some point)
+ rm -f ${D}/usr/NX/bin/nxesd
+
+ # delivered by net-misc/nxssh
+ rm -f ${D}/usr/NX/bin/nxssh
+
+ # delivered by other deps (emul-linux-x86-baselibs on amd64)
+ rm -f ${D}/usr/NX/lib/lib{crypto,jpeg,png,z}*
+
+ # make sure there are no libs left (this is to catch problems when this
+ # package is updated)
+ rmdir ${D}/usr/NX/lib || die "leftover libraries in ${D}/usr/NX/lib"
+
+ # FIXME: amd64 should deliver the desktop files too, but they don't come in
+ # the tarball, only the rpm
+ if [[ -d ${D}/usr/NX/share/applink ]]; then
+ dodir /usr/share/applnk/Internet
+ mv ${D}/usr/NX/share/applnk/"NX Client for Linux"
+ ${D}/usr/share/applnk/Internet
+ fi
+
+ # Install env.d snippet to add /usr/NX/bin to the PATH
+ insinto /etc/env.d
+ doins ${FILESDIR}/1.5.0/50nxclient
+}