summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-11 10:01:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-11 10:01:26 +0000
commit57b73597cabc6589dc0d182248a7cfc0ed168ff9 (patch)
tree344b099714a5e464d1dcf20e4ffb5091ce280f56 /net-misc/hamachi
parentadd net-nds/389-admin as post dependency (diff)
downloadgentoo-2-57b73597cabc6589dc0d182248a7cfc0ed168ff9.tar.gz
gentoo-2-57b73597cabc6589dc0d182248a7cfc0ed168ff9.tar.bz2
gentoo-2-57b73597cabc6589dc0d182248a7cfc0ed168ff9.zip
Revbump. Fixes multiple issues. Bug #261745. Thanks to René Kjellerup <rk.katana.steel@gmail.com>
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/hamachi')
-rw-r--r--net-misc/hamachi/ChangeLog12
-rw-r--r--net-misc/hamachi/files/tuncfg-forcebuild.patch23
-rw-r--r--net-misc/hamachi/hamachi-0.9.9.9_p20-r5.ebuild (renamed from net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild)43
3 files changed, 60 insertions, 18 deletions
diff --git a/net-misc/hamachi/ChangeLog b/net-misc/hamachi/ChangeLog
index c162a9f59a4c..b87ea26582a4 100644
--- a/net-misc/hamachi/ChangeLog
+++ b/net-misc/hamachi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/hamachi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/ChangeLog,v 1.15 2009/09/08 17:11:21 ikelos Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/ChangeLog,v 1.16 2010/07/11 10:01:26 hwoarang Exp $
+
+*hamachi-0.9.9.9_p20-r5 (11 Jul 2010)
+
+ 11 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ -hamachi-0.9.9.9_p20-r4.ebuild, +hamachi-0.9.9.9_p20-r5.ebuild,
+ +files/tuncfg-forcebuild.patch:
+ Revbump. Fixes multiple issues. Bug #261745. Thanks to René Kjellerup
+ <rk.katana.steel@gmail.com> for the patches and all the ebuild QA fixes
08 Sep 2009; Mike Auty <ikelos@gentoo.org> hamachi-0.9.9.9_p20-r4.ebuild:
Making CONFIG_CHECK non-fatal for userland ebuilds, see bug 283320.
diff --git a/net-misc/hamachi/files/tuncfg-forcebuild.patch b/net-misc/hamachi/files/tuncfg-forcebuild.patch
new file mode 100644
index 000000000000..992885e1bac6
--- /dev/null
+++ b/net-misc/hamachi/files/tuncfg-forcebuild.patch
@@ -0,0 +1,23 @@
+diff -u --unidirectional-new-file tuncfg-old/Makefile tuncfg/Makefile
+--- tuncfg-old/Makefile 2006-06-20 21:47:28.000000000 +0200
++++ tuncfg/Makefile 2010-06-19 17:03:25.000000000 +0200
+@@ -1,5 +1,5 @@
+ tuncfg:
+-
++ ${CC} ${CFLAGS} -O0 -o tuncfg tuncfg.c
+ clean:
+ rm -f tuncfg
+
+Only in tuncfg-old/: tuncfg
+diff -u --unidirectional-new-file tuncfg-old/tuncfg.c tuncfg/tuncfg.c
+--- tuncfg-old/tuncfg.c 2006-06-20 21:47:28.000000000 +0200
++++ tuncfg/tuncfg.c 2010-06-19 17:03:25.000000000 +0200
+@@ -272,7 +272,7 @@
+ skip:
+ for (i=0; i<ctx_n; i++)
+ {
+- unsigned long v[2];
++ unsigned int v[2];
+ char cmd[256];
+
+ if (! FD_ISSET(ctx[i].fd, &fdr))
diff --git a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild b/net-misc/hamachi/hamachi-0.9.9.9_p20-r5.ebuild
index c43080469b10..f686dee3dfb8 100644
--- a/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild
+++ b/net-misc/hamachi/hamachi-0.9.9.9_p20-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r4.ebuild,v 1.3 2009/09/08 17:11:21 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hamachi/hamachi-0.9.9.9_p20-r5.ebuild,v 1.1 2010/07/11 10:01:26 hwoarang Exp $
inherit eutils linux-info
@@ -17,14 +17,9 @@ SRC_URI="sse? ( http://files.hamachi.cc/linux/${MY_P}.tar.gz )
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="sse"
-RESTRICT="strip mirror"
+RESTRICT="mirror"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachi"
-# Set workdir for both hamachi versions
-if use sse; then
- S=${WORKDIR}/${MY_P}
-else
- S=${WORKDIR}/${MY_P}-pentium
-fi
pkg_preinst() {
# Add group "hamachi" & user "hamachi"
@@ -36,26 +31,38 @@ pkg_setup() {
einfo "Checking your kernel configuration for TUN/TAP support."
CONFIG_CHECK="~TUN"
check_extra_config
+# Set workdir for both hamachi versions
+ if use sse; then
+ S=${WORKDIR}/${MY_P}
+ else
+ S=${WORKDIR}/${MY_P}-pentium
+ fi
}
src_compile() {
+ # Patching Makefile and tuncfg source code
+ epatch ${FILESDIR}/tuncfg-forcebuild.patch
+ # forcing compile of tuncfg
+ rm -f ${S}/tuncfg/tuncfg
# Compile Tuncfg
- make -sC "${S}"/tuncfg || die "Compiling of tunecfg failed"
+ emake -sC ${S}/tuncfg || die "Compiling of tunecfg failed"
}
src_install() {
# Hamachi
einfo "Installing Hamachi"
- insinto /usr/bin
+ dodir /opt/${PN}/bin
+ insinto /opt/${PN}/bin
insopts -m0755
- doins hamachi
- dosym /usr/bin/hamachi /usr/bin/hamachi-init
+ doins hamachi || die "Couldn't Install hamachi"
+ dosym /opt/${PN}/bin/hamachi /usr/bin/hamachi || die "Couldn't create hamachi symlinks"
+ dosym /opt/${PN}/bin/hamachi /usr/bin/hamachi-init || die "Couldn't create hamachi symlinks"
# Tuncfg
einfo "Installing Tuncfg"
- insinto /usr/sbin
insopts -m0700
doins tuncfg/tuncfg
+ dosym /opt/${PN}/bin/tuncfg /usr/sbin/tuncfg
# Create log directory
dodir /var/log/${PN}
@@ -67,7 +74,11 @@ src_install() {
newinitd "${FILESDIR}"/hamachi.initd.2 hamachi
# Docs
- dodoc CHANGES README LICENSE LICENSE.openssh LICENSE.openssl LICENSE.tuncfg
+ dodir /opt/${PN}/licenses
+ insinto /opt/${PN}/licenses
+ insopts -m0644
+ doins LICENSE LICENSE.openssh LICENSE.openssl LICENSE.tuncfg
+ dodoc CHANGES README
}
@@ -79,5 +90,5 @@ pkg_postinst() {
einfo "If the 'hamachi' command shows no output, use the following command"
einfo "to extract the hamachi executable either with app-arch/upx or"
einfo "app-arch/upx-ucl:"
- einfo "/opt/bin/upx -d /usr/bin/hamachi"
+ einfo "/opt/bin/upx -d /opt/${PN}/bin/hamachi"
}