summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-09-12 08:16:12 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-09-12 08:16:12 +0000
commit088eda0429bccdad7257a52c3525fd43e4cadb7d (patch)
tree08e84e8bcd811e0412fac6de76768fbc70dc8c27 /net-misc/freeswan
parentUpdated x509 patch + fix for #7585. (diff)
downloadgentoo-2-088eda0429bccdad7257a52c3525fd43e4cadb7d.tar.gz
gentoo-2-088eda0429bccdad7257a52c3525fd43e4cadb7d.tar.bz2
gentoo-2-088eda0429bccdad7257a52c3525fd43e4cadb7d.zip
Fixed smart handling of x509 patch
Diffstat (limited to 'net-misc/freeswan')
-rw-r--r--net-misc/freeswan/freeswan-1.98b-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-misc/freeswan/freeswan-1.98b-r1.ebuild b/net-misc/freeswan/freeswan-1.98b-r1.ebuild
index 080b6f60c052..e0edf4e2e202 100644
--- a/net-misc/freeswan/freeswan-1.98b-r1.ebuild
+++ b/net-misc/freeswan/freeswan-1.98b-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-1.98b-r1.ebuild,v 1.1 2002/09/12 08:04:37 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freeswan/freeswan-1.98b-r1.ebuild,v 1.2 2002/09/12 08:16:12 aliz Exp $
+X509_PATCH=0.9.15
S=${WORKDIR}/${P}
DESCRIPTION="FreeS/WAN IPSec Userspace Utilities with X.509 Patches"
SRC_URI="ftp://ftp.xs4all.nl/pub/crypto/freeswan/${P}.tar.gz
- http://www.strongsec.com/freeswan/x509patch-0.9.15-${P}.tar.gz"
+ http://www.strongsec.com/freeswan/x509patch-${X509_PATCH}-${P}.tar.gz"
HOMEPAGE="http://www.freeswan.org"
DEPEND="virtual/glibc
@@ -31,7 +32,7 @@ src_unpack() {
cd ${S}
patch -p1 < ${FILESDIR}/freeswan-gentoo-cflags.patch || die
- sed 's:/etc/ipsec.d:/etc/ipsec/ipsec.d:g' ${WORKDIR}/x509patch-0.9.13-${P}/freeswan.diff | patch -p1 || die
+ sed 's:/etc/ipsec.d:/etc/ipsec/ipsec.d:g' ${WORKDIR}/x509patch-${X509_PATCH}-${P}/freeswan.diff | patch -p1 || die
}
src_compile() {
@@ -59,9 +60,9 @@ src_install () {
INC_MANDIR=share/man \
install || die
- newdoc ${WORKDIR}/x509patch-0.9.12-${P}/README README.x509
- newdoc ${WORKDIR}/x509patch-0.9.12-${P}/CHANGES CHANGES.x509
- newdoc ${WORKDIR}/x509patch-0.9.12-${P}/ipsec.secrets.template ipsec.secrets.x509
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/README README.x509
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/CHANGES CHANGES.x509
+ newdoc ${WORKDIR}/x509patch-${X509_PATCH}-${P}/ipsec.secrets.template ipsec.secrets.x509
dodoc INSTALL COPYING CREDITS BUGS CHANGES README doc/*
}