summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-10-28 11:25:13 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-10-28 11:25:13 +0000
commit09d5ddbf5c76e46e50cb46d79eea43068b8dda5a (patch)
tree8cee196534bdb6f045065825568a1b06b81ca703 /net-misc/dahdi-tools
parentRemove old (diff)
downloadgentoo-2-09d5ddbf5c76e46e50cb46d79eea43068b8dda5a.tar.gz
gentoo-2-09d5ddbf5c76e46e50cb46d79eea43068b8dda5a.tar.bz2
gentoo-2-09d5ddbf5c76e46e50cb46d79eea43068b8dda5a.zip
Version bump. Change libusb dependency as requested by Mounir "volkmar" Lamouri in bug #270160. Header & modprobe.d fixups by Csaba Tóth in bug #270283. Run fxotune from the init script, from Jaco Kroon in bug #273390.
(Portage version: 2.1.7.1/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/dahdi-tools')
-rw-r--r--net-misc/dahdi-tools/ChangeLog11
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-2.2.0.ebuild35
-rw-r--r--net-misc/dahdi-tools/files/dahdi-tools-2.2.0-ifreq.patch12
-rw-r--r--net-misc/dahdi-tools/files/dahdi-tools-2.2.0-modprobe-suffix.patch14
-rw-r--r--net-misc/dahdi-tools/files/dahdi.init237
5 files changed, 108 insertions, 1 deletions
diff --git a/net-misc/dahdi-tools/ChangeLog b/net-misc/dahdi-tools/ChangeLog
index 71ff7487a126..c59fcd067b71 100644
--- a/net-misc/dahdi-tools/ChangeLog
+++ b/net-misc/dahdi-tools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/dahdi-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/ChangeLog,v 1.1 2009/03/10 17:08:00 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/ChangeLog,v 1.2 2009/10/28 11:25:13 chainsaw Exp $
+
+*dahdi-tools-2.2.0 (28 Oct 2009)
+
+ 28 Oct 2009; <chainsaw@gentoo.org> +dahdi-tools-2.2.0.ebuild,
+ +files/dahdi-tools-2.2.0-ifreq.patch,
+ +files/dahdi-tools-2.2.0-modprobe-suffix.patch, +files/dahdi.init2:
+ Version bump. Change libusb dependency as requested by Mounir "volkmar"
+ Lamouri in bug #270160. Header & modprobe.d fixups by Csaba Tóth in bug
+ #270283. Run fxotune from the init script, from Jaco Kroon in bug #273390.
*dahdi-tools-2.1.0.2 (10 Mar 2009)
diff --git a/net-misc/dahdi-tools/dahdi-tools-2.2.0.ebuild b/net-misc/dahdi-tools/dahdi-tools-2.2.0.ebuild
new file mode 100644
index 000000000000..a42e68ab3127
--- /dev/null
+++ b/net-misc/dahdi-tools/dahdi-tools-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/dahdi-tools-2.2.0.ebuild,v 1.1 2009/10/28 11:25:13 chainsaw Exp $
+
+EAPI=1
+inherit eutils
+
+DESCRIPTION="Userspace tools to configure the kernel modules from net-misc/dahdi"
+HOMEPAGE="http://www.asterisk.org"
+SRC_URI="http://downloads.digium.com/pub/telephony/dahdi-tools/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/dahdi
+ virtual/libusb:0"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ifreq.patch"
+ epatch "${FILESDIR}/${P}-modprobe-suffix.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install binaries"
+ emake DESTDIR="${D}" config || die "Failed to install configuration files"
+
+ # install init script
+ newinitd "${FILESDIR}"/dahdi.init2 dahdi
+}
diff --git a/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-ifreq.patch b/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-ifreq.patch
new file mode 100644
index 000000000000..98ce2db7973b
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-ifreq.patch
@@ -0,0 +1,12 @@
+diff -uNr dahdi-tools-2.2.0.ORIG/sethdlc.c dahdi-tools-2.2.0/sethdlc.c
+--- dahdi-tools-2.2.0.ORIG/sethdlc.c 2009-10-28 11:07:37.000000000 +0000
++++ dahdi-tools-2.2.0/sethdlc.c 2009-10-28 11:08:10.000000000 +0000
+@@ -43,6 +43,8 @@
+ #warning "No kernel support for Ethernet over Frame Relay / HDLC, skipping it"
+ #endif
+
++#define ifreq __kernel_ifreq
++
+
+ static struct ifreq req; /* for ioctl */
+ static int argc;
diff --git a/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-modprobe-suffix.patch b/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-modprobe-suffix.patch
new file mode 100644
index 000000000000..eea4a7a9948a
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi-tools-2.2.0-modprobe-suffix.patch
@@ -0,0 +1,14 @@
+diff -urN dahdi-tools-2.2.0.orig/Makefile dahdi-tools-2.2.0/Makefile
+--- dahdi-tools-2.2.0.orig/Makefile 2009-06-08 19:02:48.000000000 +0200
++++ dahdi-tools-2.2.0/Makefile 2009-07-19 14:32:44.246071785 +0200
+@@ -70,8 +70,8 @@
+ RCCONF_FILE = /etc/dahdi/init.conf
+ MODULES_FILE = /etc/dahdi/modules
+ GENCONF_FILE = /etc/dahdi/genconf_parameters
+-MODPROBE_FILE = /etc/modprobe.d/dahdi
+-BLACKLIST_FILE = /etc/modprobe.d/dahdi.blacklist
++MODPROBE_FILE = /etc/modprobe.d/dahdi.conf
++BLACKLIST_FILE = /etc/modprobe.d/dahdi.blacklist.conf
+
+ NETSCR_DIR := $(firstword $(wildcard $(DESTDIR)/etc/sysconfig/network-scripts ))
+ ifneq (,$(NETSCR_DIR))
diff --git a/net-misc/dahdi-tools/files/dahdi.init2 b/net-misc/dahdi-tools/files/dahdi.init2
new file mode 100644
index 000000000000..8260e7014b80
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi.init2
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dahdi-tools/files/dahdi.init2,v 1.1 2009/10/28 11:25:12 chainsaw Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/dahdi/system.conf ]; then
+ eerror "/etc/dahdi/system.conf not found. Nothing to do."
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting DAHDI"
+ /usr/sbin/dahdi_cfg
+ eend $?
+
+ if [ $? -eq 0 -a -r /etc/fxotune.conf ]; then
+ ebegin "Loading DAHDI fxotune.conf"
+ /usr/sbin/fxotune -s
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Stopping DAHDI"
+ /usr/sbin/dahdi_cfg -s
+ eend
+}