summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-12-09 03:30:39 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-12-09 03:30:39 +0000
commit8d7c155977695d77ec1a456ac18e89088b04a43c (patch)
tree808fe8e11f6c90845c086bd65ebb245e7b621a88 /net-misc/curl
parentadded >=net-misc/curl-7.16.0 (diff)
downloadgentoo-2-8d7c155977695d77ec1a456ac18e89088b04a43c.tar.gz
gentoo-2-8d7c155977695d77ec1a456ac18e89088b04a43c.tar.bz2
gentoo-2-8d7c155977695d77ec1a456ac18e89088b04a43c.zip
Fixed bug #157539 thanks to Timothy - attempted installtion of non-existant files. Fixed type that ment USE=kerberos disabled the effect of other USE flags (thanks me). Version bump as per bug #154575 thanks Gerry - still masked as no compatible pycurl and all other programs not tested for compatibility
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog13
-rw-r--r--net-misc/curl/curl-7.15.1-r1.ebuild6
-rw-r--r--net-misc/curl/curl-7.15.5.ebuild6
-rw-r--r--net-misc/curl/curl-7.16.0.ebuild104
-rw-r--r--net-misc/curl/files/digest-curl-7.16.03
5 files changed, 125 insertions, 7 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index 2d2ef97ce560..f5326b462bd6 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.78 2006/10/22 16:22:11 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.79 2006/12/09 03:30:39 dragonheart Exp $
+
+*curl-7.16.0 (09 Dec 2006)
+
+ 09 Dec 2006; Daniel Black <dragonheart@gentoo.org> curl-7.15.1-r1.ebuild,
+ -curl-7.15.3.ebuild, -curl-7.15.4.ebuild, curl-7.15.5.ebuild,
+ +curl-7.16.0.ebuild:
+ Fixed bug #157539 thanks to Timothy - attempted installtion of non-existant
+ files. Fixed type that ment USE=kerberos disabled the effect of other USE
+ flags (thanks me). Version bump as per bug #154575 thanks Gerry - still
+ masked as no compatible pycurl and all other programs not tested for
+ compatibility
*curl-7.15.5 (22 Oct 2006)
diff --git a/net-misc/curl/curl-7.15.1-r1.ebuild b/net-misc/curl/curl-7.15.1-r1.ebuild
index fcc8cfe7c5e8..a95b541306bc 100644
--- a/net-misc/curl/curl-7.15.1-r1.ebuild
+++ b/net-misc/curl/curl-7.15.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.1-r1.ebuild,v 1.8 2006/10/04 17:45:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.1-r1.ebuild,v 1.9 2006/12/09 03:30:39 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -76,7 +76,7 @@ src_compile() {
fi
if use kerberos; then
- myconf="${myconfg} --with-gssapi=/usr"
+ myconf="${myconf} --with-gssapi=/usr"
fi
econf ${myconf} || die 'configure failed'
@@ -93,6 +93,6 @@ src_install() {
#doins libcurl.pc
dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS docs/LIBCURL
+ dodoc docs/FEATURES docs/INTERNALS
dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
}
diff --git a/net-misc/curl/curl-7.15.5.ebuild b/net-misc/curl/curl-7.15.5.ebuild
index 87056a3ed31a..e090d8762643 100644
--- a/net-misc/curl/curl-7.15.5.ebuild
+++ b/net-misc/curl/curl-7.15.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.5.ebuild,v 1.1 2006/10/22 16:22:11 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.5.ebuild,v 1.2 2006/12/09 03:30:39 dragonheart Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -76,7 +76,7 @@ src_compile() {
fi
if use kerberos; then
- myconf="${myconfg} --with-gssapi=/usr"
+ myconf="${myconf} --with-gssapi=/usr"
fi
econf ${myconf} || die 'configure failed'
@@ -90,6 +90,6 @@ src_install() {
doins docs/libcurl/libcurl.m4
dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS docs/LIBCURL
+ dodoc docs/FEATURES docs/INTERNALS
dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
}
diff --git a/net-misc/curl/curl-7.16.0.ebuild b/net-misc/curl/curl-7.16.0.ebuild
new file mode 100644
index 000000000000..5b5d9f0b6606
--- /dev/null
+++ b/net-misc/curl/curl-7.16.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.0.ebuild,v 1.1 2006/12/09 03:30:39 dragonheart Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit libtool eutils
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ipv6 ldap ares gnutls idn kerberos krb4 test"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ ssl? ( !gnutls? ( dev-libs/openssl ) )
+ ldap? ( net-nds/openldap )
+ idn? ( net-dns/libidn )
+ ares? ( net-dns/c-ares )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )"
+
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ dev-lang/perl
+ )"
+# used - but can do without in self test: net-misc/stunnel
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-7.15-strip-ldflags.patch
+ elibtoolize
+}
+
+src_compile() {
+
+ myconf="$(use_enable ldap)
+ $(use_with idn libidn)
+ $(use_enable kerberos gssapi)
+ $(use_enable ipv6)
+ --enable-http
+ --enable-ftp
+ --enable-gopher
+ --enable-file
+ --enable-dict
+ --enable-manual
+ --enable-telnet
+ --enable-nonblocking
+ --enable-largefile
+ --enable-maintainer-mode"
+
+ if use ipv6 && use ares; then
+ ewarn "c-ares support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-ares"
+ else
+ myconf="${myconf} $(use_enable ares)"
+ fi
+
+ if use ipv6 && use krb4; then
+ ewarn "kerberos-4 support disabled because it is incompatible with ipv6."
+ myconf="${myconf} --disable-krb4"
+ else
+ myconf="${myconf} $(use_enable krb4)"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --without-ssl --with-gnutls=/usr"
+ elif use ssl; then
+ myconf="${myconf} --without-gnutls --with-ssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl"
+ fi
+
+ if use kerberos; then
+ myconf="${myconf} --with-gssapi=/usr"
+ fi
+
+ econf ${myconf} || die 'configure failed'
+ emake || die "install failed for current version"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "installed failed for current version"
+
+ insinto /usr/share/aclocal
+ doins docs/libcurl/libcurl.m4
+
+ dodoc CHANGES README
+ dodoc docs/FEATURES docs/INTERNALS
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
+ ewarn "You must re-compile all packages that are linked against"
+ ewarn "curl-7.15.* by using revdep-rebuild from gentoolkit:"
+ ewarn "# revdep-rebuild --library libcurl.so.3"
+ fi
+}
diff --git a/net-misc/curl/files/digest-curl-7.16.0 b/net-misc/curl/files/digest-curl-7.16.0
new file mode 100644
index 000000000000..45dac32cac3e
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.16.0
@@ -0,0 +1,3 @@
+MD5 5819f56e93d04cde2992fe88b54cbfad curl-7.16.0.tar.bz2 1566391
+RMD160 1be2153a7a19ac6ec070a6923bc518bcc2c83c08 curl-7.16.0.tar.bz2 1566391
+SHA256 fc8dcda5a933c370c15c832bf1e7316a0690f473fdd6000454d233edaa33bc23 curl-7.16.0.tar.bz2 1566391