summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-08-26 01:13:21 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-08-26 01:13:21 +0000
commit304b9902d674380a447c77df2fb263ac6cc50de7 (patch)
tree831632469fd1e5332561800d0e89bf1fbc3ba6ce /net-misc/curl
parentMake sure we force linking with ssl dynamically #184419. (diff)
downloadgentoo-2-304b9902d674380a447c77df2fb263ac6cc50de7.tar.gz
gentoo-2-304b9902d674380a447c77df2fb263ac6cc50de7.tar.bz2
gentoo-2-304b9902d674380a447c77df2fb263ac6cc50de7.zip
purge vulnerable versions (sec bug #184934)
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog7
-rw-r--r--net-misc/curl/curl-7.15.1-r1.ebuild91
-rw-r--r--net-misc/curl/files/curl-7.15-libtftp.patch12
-rw-r--r--net-misc/curl/files/curl-7.15.1-test46.patch25
-rw-r--r--net-misc/curl/files/digest-curl-7.15.1-r13
5 files changed, 6 insertions, 132 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index cfe0645b238f..7e46d89bb894 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.101 2007/08/10 12:42:13 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.102 2007/08/26 01:13:21 dragonheart Exp $
+
+ 26 Aug 2007; Daniel Black <dragonheart@gentoo.org>
+ -files/curl-7.15.1-test46.patch, -files/curl-7.15-libtftp.patch,
+ -curl-7.15.1-r1.ebuild:
+ purge vulnerable versions (sec bug #184934)
10 Aug 2007; Christoph Mende <angelos@gentoo.org> curl-7.16.4.ebuild:
Stable on amd64 wrt bug #187731
diff --git a/net-misc/curl/curl-7.15.1-r1.ebuild b/net-misc/curl/curl-7.15.1-r1.ebuild
deleted file mode 100644
index 302020958951..000000000000
--- a/net-misc/curl/curl-7.15.1-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.15.1-r1.ebuild,v 1.11 2007/04/14 00:35:26 dragonheart Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit eutils
-
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="ssl ipv6 ldap ares gnutls idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls )
- ssl? ( !gnutls? ( dev-libs/openssl ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( net-dns/c-ares )
- kerberos? ( virtual/krb5 )"
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch ${FILESDIR}/curl-7.15-libtftp.patch
- epatch ${FILESDIR}/curl-7.15.1-test46.patch
- epatch ${FILESDIR}/curl-7.15.1-test62.patch
-}
-
-src_compile() {
- local myconf
- myconf="$(use_enable ldap)
- $(use_with idn libidn)
- $(use_enable kerberos gssapi)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile"
-
- if use ipv6 && use ares; then
- ewarn "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls=/usr"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --with-ssl=/usr"
- else
- myconf="${myconf} --without-gnutls --without-ssl"
- fi
-
- if use kerberos; then
- myconf="${myconf} --with-gssapi=/usr"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "installed failed for current version"
-
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- #insinto /usr/lib/pkgconfig
- #doins libcurl.pc
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
diff --git a/net-misc/curl/files/curl-7.15-libtftp.patch b/net-misc/curl/files/curl-7.15-libtftp.patch
deleted file mode 100644
index c92c66417f2e..000000000000
--- a/net-misc/curl/files/curl-7.15-libtftp.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nrup curl-7.15.1/lib/tftp.c curl-7.15.1/lib/tftp.c
---- curl-7.15.1/lib/tftp.c 2005-12-05 15:10:37.000000000 -0500
-+++ curl-7.15.1/lib/tftp.c 2006-03-18 20:16:02.000000000 -0500
-@@ -271,7 +271,7 @@ static void tftp_send_first(tftp_state_d
- /* If we are downloading, send an RRQ */
- state->spacket.event = htons(TFTP_EVENT_RRQ);
- }
-- sprintf((char *)state->spacket.u.request.data, "%s%c%s%c",
-+ snprintf((char *)state->spacket.u.request.data, 512, "%s%c%s%c",
- filename, '\0', mode, '\0');
- sbytes = 4 + (int)strlen(filename) + (int)strlen(mode);
- sbytes = sendto(state->sockfd, (void *)&state->spacket,
diff --git a/net-misc/curl/files/curl-7.15.1-test46.patch b/net-misc/curl/files/curl-7.15.1-test46.patch
deleted file mode 100644
index ee443d956341..000000000000
--- a/net-misc/curl/files/curl-7.15.1-test46.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-===================================================================
-RCS file: /cvsroot/curl/curl/tests/data/test46,v
-retrieving revision 1.13
-retrieving revision 1.14
-diff -u -r1.13 -r1.14
---- curl/tests/data/test46 2005/05/24 10:03:13 1.13
-+++ curl/tests/data/test46 2006/02/06 20:02:14 1.14
-@@ -43,7 +43,7 @@
-
- www.fake.come FALSE / FALSE 1022144953 cookiecliente si
- www.loser.com FALSE / FALSE 1139150993 UID 99
--127.0.0.1 FALSE / FALSE 1139150993 mooo indeed
-+127.0.0.1 FALSE / FALSE 1439150993 mooo indeed
- 127.0.0.1 FALSE / FALSE 0 empty
- </file>
- </client>
-@@ -67,7 +67,7 @@
-
- www.fake.come FALSE / FALSE 1022144953 cookiecliente si
- www.loser.com FALSE / FALSE 1139150993 UID 99
--127.0.0.1 FALSE / FALSE 1139150993 mooo indeed
-+127.0.0.1 FALSE / FALSE 1439150993 mooo indeed
- 127.0.0.1 FALSE / FALSE 0 empty
- 127.0.0.1 FALSE / FALSE 1262322000 ckyPersistent permanent
- 127.0.0.1 FALSE / FALSE 0 ckySession temporary
diff --git a/net-misc/curl/files/digest-curl-7.15.1-r1 b/net-misc/curl/files/digest-curl-7.15.1-r1
deleted file mode 100644
index b801ba19eb94..000000000000
--- a/net-misc/curl/files/digest-curl-7.15.1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d330d48580bfade58c82d4f295f171f0 curl-7.15.1.tar.bz2 1437950
-RMD160 c733937754b579d45de8c26cf4dfa6c5cec82fae curl-7.15.1.tar.bz2 1437950
-SHA256 8b1ea75a91ef7d1e00086865eba9a4cf8baefcb212ce451a61348e00b8756324 curl-7.15.1.tar.bz2 1437950