summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-03-01 08:28:47 +0000
committerHans de Graaff <graaff@gentoo.org>2008-03-01 08:28:47 +0000
commitefdc198e418884fdfc244e14a54c664667dfccdb (patch)
tree9bdf37a353c4e83b36983def59dad0d4085b94fc /net-misc/cadaver
parentStable on amd64, bug 211696. (diff)
downloadgentoo-2-efdc198e418884fdfc244e14a54c664667dfccdb.tar.gz
gentoo-2-efdc198e418884fdfc244e14a54c664667dfccdb.tar.bz2
gentoo-2-efdc198e418884fdfc244e14a54c664667dfccdb.zip
Use built_with_use to check for proper SSL support
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/cadaver')
-rw-r--r--net-misc/cadaver/ChangeLog9
-rw-r--r--net-misc/cadaver/cadaver-0.22.5-r1.ebuild37
2 files changed, 45 insertions, 1 deletions
diff --git a/net-misc/cadaver/ChangeLog b/net-misc/cadaver/ChangeLog
index a3a4a9163c34..1c82ed19d5d2 100644
--- a/net-misc/cadaver/ChangeLog
+++ b/net-misc/cadaver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/cadaver
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cadaver/ChangeLog,v 1.22 2008/02/03 19:04:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cadaver/ChangeLog,v 1.23 2008/03/01 08:28:47 graaff Exp $
+
+*cadaver-0.22.5-r1 (01 Mar 2008)
+
+ 01 Mar 2008; Hans de Graaff <graaff@gentoo.org> +cadaver-0.22.5-r1.ebuild:
+ Use built_with_use to ensure that proper SSL support is available if requested
+ instead of solving this with warning that is easily overlooked. Thanks to
+ Opfer for the suggestion.
03 Feb 2008; Brent Baude <ranger@gentoo.org> cadaver-0.22.5.ebuild:
Marking cadaver-0.22.5 ppc64 for bug 208697
diff --git a/net-misc/cadaver/cadaver-0.22.5-r1.ebuild b/net-misc/cadaver/cadaver-0.22.5-r1.ebuild
new file mode 100644
index 000000000000..cc714f0f13ce
--- /dev/null
+++ b/net-misc/cadaver/cadaver-0.22.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cadaver/cadaver-0.22.5-r1.ebuild,v 1.1 2008/03/01 08:28:47 graaff Exp $
+
+inherit eutils
+
+DESCRIPTION="Command-line WebDAV client."
+HOMEPAGE="http://www.webdav.org/cadaver"
+SRC_URI="http://www.webdav.org/cadaver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls ssl"
+
+DEPEND="virtual/libc
+ >=net-misc/neon-0.26.3"
+
+pkg_setup() {
+ if use ssl && ! built_with_use net-misc/neon ssl ; then
+ ewarn "SSL support in cadaver requires SSL support in net-misc/neon."
+ ewarn "Please rebuild net-misc/neon with the ssl USE flag if you want to use"
+ ewarn "cadaver with SSL support."
+ die "SSL support in cadaver requires SSL support in net-misc/neon"
+ fi
+}
+
+src_compile() {
+ myconf="--with-libs=/usr $(use_enable nls)"
+ econf $myconf || die "econf failed"
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc BUGS ChangeLog FAQ NEWS README THANKS TODO
+}