summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-27 16:30:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-27 16:30:15 +0000
commit6a6e3ef8e1aa2047cb4b1ee05e3bb95e6ff51fb8 (patch)
treed148bea203d4f6c7d73c21cd74129f4cd48a62a0 /net-misc/bfgminer
parentStable for x86, wrt bug #489566 (diff)
downloadgentoo-2-6a6e3ef8e1aa2047cb4b1ee05e3bb95e6ff51fb8.tar.gz
gentoo-2-6a6e3ef8e1aa2047cb4b1ee05e3bb95e6ff51fb8.tar.bz2
gentoo-2-6a6e3ef8e1aa2047cb4b1ee05e3bb95e6ff51fb8.zip
Version bumps
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/bfgminer')
-rw-r--r--net-misc/bfgminer/ChangeLog12
-rw-r--r--net-misc/bfgminer/bfgminer-3.0.10.ebuild134
-rw-r--r--net-misc/bfgminer/bfgminer-3.2.3.ebuild107
-rw-r--r--net-misc/bfgminer/bfgminer-3.3.0-r1.ebuild123
-rw-r--r--net-misc/bfgminer/bfgminer-3.4.0.ebuild132
-rw-r--r--net-misc/bfgminer/metadata.xml6
6 files changed, 513 insertions, 1 deletions
diff --git a/net-misc/bfgminer/ChangeLog b/net-misc/bfgminer/ChangeLog
index ab6cfa5b86c2..77c202be7746 100644
--- a/net-misc/bfgminer/ChangeLog
+++ b/net-misc/bfgminer/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-misc/bfgminer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.49 2013/10/22 16:25:24 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.50 2013/10/27 16:30:15 blueness Exp $
+
+*bfgminer-3.3.0-r1 (27 Oct 2013)
+*bfgminer-3.4.0 (27 Oct 2013)
+*bfgminer-3.0.10 (27 Oct 2013)
+*bfgminer-3.2.3 (27 Oct 2013)
+
+ 27 Oct 2013; Anthony G. Basile <blueness@gentoo.org> +bfgminer-3.0.10.ebuild,
+ +bfgminer-3.2.3.ebuild, +bfgminer-3.3.0-r1.ebuild, +bfgminer-3.4.0.ebuild,
+ metadata.xml:
+ Version bumps
*bfgminer-3.3.0 (22 Oct 2013)
*bfgminer-3.0.9 (22 Oct 2013)
diff --git a/net-misc/bfgminer/bfgminer-3.0.10.ebuild b/net-misc/bfgminer/bfgminer-3.0.10.ebuild
new file mode 100644
index 000000000000..dccb8d5c6563
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.0.10.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.0.10.ebuild,v 1.1 2013/10/27 16:30:15 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl altivec avalon bitforce +cpumining examples hardened icarus modminer ncurses +opencl padlock scrypt sse2 sse2_4way sse4 +udev x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl x6500 ztex )
+ adl? ( opencl )
+ altivec? ( cpumining ppc ppc64 )
+ padlock? ( cpumining || ( amd64 x86 ) )
+ scrypt? ( || ( cpumining opencl ) )
+ sse2? ( cpumining || ( amd64 x86 ) )
+ sse4? ( cpumining amd64 )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ sys-apps/sed
+ sse2? (
+ >=dev-lang/yasm-1.0.1
+ )
+ sse4? (
+ >=dev-lang/yasm-1.0.1
+ )
+"
+
+src_prepare() {
+ sed -i 's/\(^\#define WANT_.*\(SSE\|PADLOCK\|ALTIVEC\)\)/\/\/ \1/' miner.h
+}
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ if ! use altivec; then
+ sed -i 's/-faltivec//g' configure
+ else
+ CFLAGS="${CFLAGS} -DWANT_ALTIVEC=1"
+ fi
+ use padlock && CFLAGS="${CFLAGS} -DWANT_VIA_PADLOCK=1"
+ if use sse2; then
+ if use amd64; then
+ CFLAGS="${CFLAGS} -DWANT_X8664_SSE2=1"
+ else
+ CFLAGS="${CFLAGS} -DWANT_X8632_SSE2=1"
+ fi
+ fi
+ use sse2_4way && CFLAGS="${CFLAGS} -DWANT_SSE2_4WAY=1"
+ use sse4 && CFLAGS="${CFLAGS} -DWANT_X8664_SSE4=1"
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $(use_with udev libudev) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+ # sanitize directories
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/bfgminer"'"~' config.h
+}
+
+src_install() {
+ dobin bfgminer
+ dobin bfgminer-rpc
+ dodoc AUTHORS HACKING NEWS README README.RPC
+ if use scrypt; then
+ dodoc README.scrypt
+ fi
+ if use icarus || use bitforce; then
+ dodoc README.FPGA
+ fi
+ if use bitforce; then
+ dobin bitforce-firmware-flash
+ fi
+ if use modminer || use x6500; then
+ insinto /usr/lib/bfgminer/bitstreams
+ doins bitstreams/fpgaminer*.bit
+ dodoc bitstreams/COPYING_fpgaminer
+ fi
+ if use opencl; then
+ insinto /usr/lib/bfgminer
+ doins *.cl
+ fi
+ if use ztex; then
+ insinto /usr/lib/bfgminer/ztex
+ doins bitstreams/ztex*.bit
+ dodoc bitstreams/COPYING_ztex
+ fi
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php api-example.c api-example.py
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.2.3.ebuild b/net-misc/bfgminer/bfgminer-3.2.3.ebuild
new file mode 100644
index 000000000000..09bb8ec48a9d
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.2.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.2.3.ebuild,v 1.1 2013/10/27 16:30:15 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl avalon bitforce cpumining examples hardened icarus lm_sensors modminer ncurses +opencl proxy scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ lm_sensors? ( opencl )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ proxy? (
+ net-libs/libmicrohttpd
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy libmicrohttpd) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.3.0-r1.ebuild b/net-misc/bfgminer/bfgminer-3.3.0-r1.ebuild
new file mode 100644
index 000000000000..d94581fab303
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.3.0-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.3.0-r1.ebuild,v 1.1 2013/10/27 16:30:15 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl avalon bitforce bfsb bigpic bitfury cpumining examples hardened icarus littlefury lm_sensors metabank modminer ncurses +opencl proxy proxy_getwork proxy_stratum scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ bfsb? ( bitfury )
+ bigpic? ( bitfury )
+ littlefury? ( bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( bitfury )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.4.0.ebuild b/net-misc/bfgminer/bfgminer-3.4.0.ebuild
new file mode 100644
index 000000000000..ce2267d1252c
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.4.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.4.0.ebuild,v 1.1 2013/10/27 16:30:15 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Waiting for dev-libs/hidapi to be keyworded
+#KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+IUSE="+adl avalon bitforce bfsb bigpic bitfury cpumining examples hardened icarus littlefury lm_sensors metabank modminer nanofury ncurses +opencl proxy proxy_getwork proxy_stratum scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ bfsb? ( bitfury )
+ bigpic? ( bitfury )
+ littlefury? ( bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( bitfury )
+ nanofury? ( bitfury )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/metadata.xml b/net-misc/bfgminer/metadata.xml
index 8e46caf263f2..436393482cd2 100644
--- a/net-misc/bfgminer/metadata.xml
+++ b/net-misc/bfgminer/metadata.xml
@@ -14,9 +14,15 @@
<flag name='adl'>Enable support for controlling fans and overclocking on AMD cards with AMD Display Library</flag>
<flag name='avalon'>Enable support for mining with Avalon ASIC modules</flag>
<flag name='bitforce'>Enable support for mining with ButterFly Labs BitFORCE ASICs and/or FPGAs</flag>
+ <flag name='bfsb'>Enable support for mining on BFSB host Raspberry Pi</flag>
+ <flag name='bigpic'>Enable support for mining with Big Picture Mining USB sticks (Red/BlueFury, BF1, etc)</flag>
+ <flag name='bitfury'>Enable support for mining with 55nm Bitfury-based devices</flag>
<flag name='cpumining'>Enable support for mining with CPUs</flag>
<flag name='icarus'>Enable support for mining with Icarus-compatible devices (including Block Erupter Sapphire ASICs)</flag>
+ <flag name='littlefury'>Enable support for mining with LittleFury USB sticks</flag>
+ <flag name='metabank'>Enable support for mining on Metabank host Raspberry Pi</flag>
<flag name='modminer'>Enable support for mining with ModMiner FPGAs</flag>
+ <flag name='nanofury'>Enable support for mining with NanoFury USB sticks</flag>
<flag name='opencl'>Enable support for mining with OpenCL-capable devices (GPUs)</flag>
<flag name='padlock'>Enable support for mining with VIA Padlock CPUs</flag>
<flag name='proxy'>Enable support for virtual proxy device</flag>