summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-22 16:25:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-22 16:25:24 +0000
commit18c84ce6f2302a5b64bf44b403f9a685b5d071b0 (patch)
tree90bcfa1e885df001c71a2e51db4329e4b38cfa78 /net-misc/bfgminer
parentVersion bump (diff)
downloadgentoo-2-18c84ce6f2302a5b64bf44b403f9a685b5d071b0.tar.gz
gentoo-2-18c84ce6f2302a5b64bf44b403f9a685b5d071b0.tar.bz2
gentoo-2-18c84ce6f2302a5b64bf44b403f9a685b5d071b0.zip
Version bumps
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/bfgminer')
-rw-r--r--net-misc/bfgminer/ChangeLog10
-rw-r--r--net-misc/bfgminer/bfgminer-3.0.9.ebuild134
-rw-r--r--net-misc/bfgminer/bfgminer-3.2.2.ebuild107
-rw-r--r--net-misc/bfgminer/bfgminer-3.3.0.ebuild114
-rw-r--r--net-misc/bfgminer/metadata.xml4
5 files changed, 367 insertions, 2 deletions
diff --git a/net-misc/bfgminer/ChangeLog b/net-misc/bfgminer/ChangeLog
index 18ebcd6d6da3..ab6cfa5b86c2 100644
--- a/net-misc/bfgminer/ChangeLog
+++ b/net-misc/bfgminer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/bfgminer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.48 2013/09/19 16:25:45 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/ChangeLog,v 1.49 2013/10/22 16:25:24 blueness Exp $
+
+*bfgminer-3.3.0 (22 Oct 2013)
+*bfgminer-3.0.9 (22 Oct 2013)
+*bfgminer-3.2.2 (22 Oct 2013)
+
+ 22 Oct 2013; Anthony G. Basile <blueness@gentoo.org> +bfgminer-3.0.9.ebuild,
+ +bfgminer-3.2.2.ebuild, +bfgminer-3.3.0.ebuild, metadata.xml:
+ Version bumps
*bfgminer-2.10.14 (19 Sep 2013)
*bfgminer-3.2.1 (19 Sep 2013)
diff --git a/net-misc/bfgminer/bfgminer-3.0.9.ebuild b/net-misc/bfgminer/bfgminer-3.0.9.ebuild
new file mode 100644
index 000000000000..d956e78ac417
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.0.9.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.0.9.ebuild,v 1.1 2013/10/22 16:25:24 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl altivec avalon bitforce +cpumining examples hardened icarus modminer ncurses +opencl padlock scrypt sse2 sse2_4way sse4 +udev x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl x6500 ztex )
+ adl? ( opencl )
+ altivec? ( cpumining ppc ppc64 )
+ padlock? ( cpumining || ( amd64 x86 ) )
+ scrypt? ( || ( cpumining opencl ) )
+ sse2? ( cpumining || ( amd64 x86 ) )
+ sse4? ( cpumining amd64 )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ sys-apps/sed
+ sse2? (
+ >=dev-lang/yasm-1.0.1
+ )
+ sse4? (
+ >=dev-lang/yasm-1.0.1
+ )
+"
+
+src_prepare() {
+ sed -i 's/\(^\#define WANT_.*\(SSE\|PADLOCK\|ALTIVEC\)\)/\/\/ \1/' miner.h
+}
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ if ! use altivec; then
+ sed -i 's/-faltivec//g' configure
+ else
+ CFLAGS="${CFLAGS} -DWANT_ALTIVEC=1"
+ fi
+ use padlock && CFLAGS="${CFLAGS} -DWANT_VIA_PADLOCK=1"
+ if use sse2; then
+ if use amd64; then
+ CFLAGS="${CFLAGS} -DWANT_X8664_SSE2=1"
+ else
+ CFLAGS="${CFLAGS} -DWANT_X8632_SSE2=1"
+ fi
+ fi
+ use sse2_4way && CFLAGS="${CFLAGS} -DWANT_SSE2_4WAY=1"
+ use sse4 && CFLAGS="${CFLAGS} -DWANT_X8664_SSE4=1"
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $(use_with udev libudev) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+ # sanitize directories
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/bfgminer"'"~' config.h
+}
+
+src_install() {
+ dobin bfgminer
+ dobin bfgminer-rpc
+ dodoc AUTHORS HACKING NEWS README README.RPC
+ if use scrypt; then
+ dodoc README.scrypt
+ fi
+ if use icarus || use bitforce; then
+ dodoc README.FPGA
+ fi
+ if use bitforce; then
+ dobin bitforce-firmware-flash
+ fi
+ if use modminer || use x6500; then
+ insinto /usr/lib/bfgminer/bitstreams
+ doins bitstreams/fpgaminer*.bit
+ dodoc bitstreams/COPYING_fpgaminer
+ fi
+ if use opencl; then
+ insinto /usr/lib/bfgminer
+ doins *.cl
+ fi
+ if use ztex; then
+ insinto /usr/lib/bfgminer/ztex
+ doins bitstreams/ztex*.bit
+ dodoc bitstreams/COPYING_ztex
+ fi
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php api-example.c api-example.py
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.2.2.ebuild b/net-misc/bfgminer/bfgminer-3.2.2.ebuild
new file mode 100644
index 000000000000..625e7fb230e7
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.2.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.2.2.ebuild,v 1.1 2013/10/22 16:25:24 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl avalon bitforce cpumining examples hardened icarus lm_sensors modminer ncurses +opencl proxy scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ lm_sensors? ( opencl )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ proxy? (
+ net-libs/libmicrohttpd
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy libmicrohttpd) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/bfgminer-3.3.0.ebuild b/net-misc/bfgminer/bfgminer-3.3.0.ebuild
new file mode 100644
index 000000000000..66ce35a6ff30
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-3.3.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bfgminer/bfgminer-3.3.0.ebuild,v 1.1 2013/10/22 16:25:24 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.tbz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+IUSE="+adl avalon bitforce cpumining examples hardened icarus lm_sensors modminer ncurses +opencl proxy proxy_getwork proxy_stratum scrypt +udev unicode x6500 ztex"
+REQUIRED_USE="
+ || ( avalon bitforce cpumining icarus modminer opencl proxy x6500 ztex )
+ adl? ( opencl )
+ lm_sensors? ( opencl )
+ scrypt? ( || ( cpumining opencl ) )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+"
+
+DEPEND="
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses[unicode?]
+ )
+ >=dev-libs/jansson-2
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ x6500? (
+ virtual/libusb:1
+ )
+ ztex? (
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}
+ opencl? (
+ virtual/opencl
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.2
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable avalon) \
+ $(use_enable bitforce) \
+ $(use_enable cpumining) \
+ $(use_enable icarus) \
+ $(use_enable modminer) \
+ $(use_with ncurses curses) \
+ $(use_enable opencl) \
+ $(use_enable scrypt) \
+ --with-system-libblkmaker \
+ $with_curses
+ $(use_with udev libudev) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+}
diff --git a/net-misc/bfgminer/metadata.xml b/net-misc/bfgminer/metadata.xml
index 6dce1b2784e6..8e46caf263f2 100644
--- a/net-misc/bfgminer/metadata.xml
+++ b/net-misc/bfgminer/metadata.xml
@@ -19,7 +19,9 @@
<flag name='modminer'>Enable support for mining with ModMiner FPGAs</flag>
<flag name='opencl'>Enable support for mining with OpenCL-capable devices (GPUs)</flag>
<flag name='padlock'>Enable support for mining with VIA Padlock CPUs</flag>
- <flag name='proxy'>Enable support for getwork proxy device (often used with Block Erupter Blades)</flag>
+ <flag name='proxy'>Enable support for virtual proxy device</flag>
+ <flag name='proxy_getwork'>Enable proxy support for getwork protocol (often used with Block Erupter Blades)</flag>
+ <flag name='proxy_stratum'>Enable proxy support for stratum protocol</flag>
<flag name='scrypt'>Enable support for scrypt mining algorithm</flag>
<flag name='sse2_4way'>Enable support for CPU SSE2 4way mining algorithm</flag>
<flag name='sse4'>Enable support for CPU SSE4 mining algorithm</flag>