summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-05-04 07:41:45 +0000
committerBrad Laue <brad@gentoo.org>2004-05-04 07:41:45 +0000
commite3abb3aa4813be2f3c5226d19078513b72d94d6f (patch)
tree65f07c95adbf2df82f2000641c3ba62026d3d811 /net-mail
parentnew GPL'ed version of scim-chinese (smart pinyin input). Ebuild submitted by ... (diff)
downloadgentoo-2-e3abb3aa4813be2f3c5226d19078513b72d94d6f.tar.gz
gentoo-2-e3abb3aa4813be2f3c5226d19078513b72d94d6f.tar.bz2
gentoo-2-e3abb3aa4813be2f3c5226d19078513b72d94d6f.zip
Version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mozilla-thunderbird/ChangeLog7
-rw-r--r--net-mail/mozilla-thunderbird/files/digest-mozilla-thunderbird-0.63
-rw-r--r--net-mail/mozilla-thunderbird/mozilla-thunderbird-0.6.ebuild219
3 files changed, 228 insertions, 1 deletions
diff --git a/net-mail/mozilla-thunderbird/ChangeLog b/net-mail/mozilla-thunderbird/ChangeLog
index 7a655dee80f6..52ece06575b0 100644
--- a/net-mail/mozilla-thunderbird/ChangeLog
+++ b/net-mail/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mozilla-thunderbird
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/ChangeLog,v 1.27 2004/04/27 20:59:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/ChangeLog,v 1.28 2004/05/04 07:41:45 brad Exp $
+
+*mozilla-thunderbird-0.6 (04 May 2004)
+
+ 04 May 2004; Brad Laue <brad@gentoo.org> +mozilla-thunderbird-0.6.ebuild:
+ Bump to 0.6. Clean up some dependency problems.
27 Apr 2004; Aron Griffis <agriffis@gentoo.org>
mozilla-thunderbird-0.4.ebuild, mozilla-thunderbird-0.5-r1.ebuild,
diff --git a/net-mail/mozilla-thunderbird/files/digest-mozilla-thunderbird-0.6 b/net-mail/mozilla-thunderbird/files/digest-mozilla-thunderbird-0.6
new file mode 100644
index 000000000000..fb2fb7c743e6
--- /dev/null
+++ b/net-mail/mozilla-thunderbird/files/digest-mozilla-thunderbird-0.6
@@ -0,0 +1,3 @@
+MD5 1096cea8373f94636a4b2fdeb7c13a4f thunderbird-source-0.6.tar.bz2 32442259
+MD5 fe851d3a95cb32a906a3e6cb6b4b5552 enigmail-0.83.6.tar.gz 281677
+MD5 457f8277b12f3e37defa71dc186f83b4 ipc-1.0.5.tar.gz 137083
diff --git a/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.6.ebuild b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.6.ebuild
new file mode 100644
index 000000000000..3e732acb1508
--- /dev/null
+++ b/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.6.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mozilla-thunderbird/mozilla-thunderbird-0.6.ebuild,v 1.1 2004/05/04 07:41:45 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins eutils
+
+S=${WORKDIR}/mozilla
+
+EMVER="0.83.6"
+IPCVER="1.0.5"
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird/"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/thunderbird-source-${PV}.tar.bz2
+ crypt? ( http://downloads.mozdev.org/enigmail/src/enigmail-${EMVER}.tar.gz
+ http://downloads.mozdev.org/enigmail/src/ipc-${IPCVER}.tar.gz )"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="gtk2 gnome ipv6 crypt xinerama"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ gtk2? ( >=x11-libs/gtk+-2.1.1 >=dev-libs/libIDL-0.8.0 )
+ !gtk2? ( =x11-libs/gtk+-1.2* >=gnome-base/ORBit-0.5.10-r1 )
+ crypt? ( >=app-crypt/gnupg-1.2.1 )"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-util/pkgconfig
+ dev-lang/perl"
+
+# needed by src_compile() and src_install()
+export MOZ_THUNDERBIRD=1
+export MOZ_ENABLE_XFT=1
+
+#pkg_setup() {
+# einfo "Please unmerge previous installs of Mozilla Thunderbird before"
+# einfo "merging this. Running emerge unmerge mozilla-thunderbird && rm -rf"
+# einfo "/usr/lib/MozillaThunderbird will ensure that all files are"
+# einfo "removed. If you need to do this, please press ctrl-c now and"
+# einfo "resume emerging once you're done."
+# sleep 5
+#}
+
+src_unpack() {
+
+ unpack thunderbird-source-${PV}.tar.bz2
+
+ # Unpack the enigmail plugin
+ if use crypt
+ then
+ unpack ipc-${IPCVER}.tar.gz
+ unpack enigmail-${EMVER}.tar.gz
+
+ mv -f ${WORKDIR}/ipc ${S}/extensions/
+ mv -f ${WORKDIR}/enigmail ${S}/extensions/
+ cp ${FILESDIR}/enigmail/Makefile-ipc ${S}/extensions/ipc/Makefile
+ cp ${FILESDIR}/enigmail/Makefile-enigmail ${S}/extensions/enigmail/Makefile
+ fi
+
+ use amd64 && epatch ${FILESDIR}/mozilla-thunderbird-amd64.patch
+}
+
+src_compile() {
+ local myconf="--with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-calendar \
+ --enable-xft \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird \
+ --with-user-appdir=.thunderbird \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-profilesharing \
+ --disable-necko-disk-cache \
+ --disable-activex-scripting \
+ --disable-installer \
+ --disable-activex \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-optimize="-O2" \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib \
+ --enable-extensions=wallet,spellcheck \
+ --enable-necko-protocols=http,file,jar,viewsource,res,data \
+ --enable-image-decoders=png,gif,jpeg"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Check for xinerama - closes #19369
+ if [ -n "`use xinerama`" ] ; then
+ myconf="${myconf} --enable-xinerama=yes"
+ else
+ myconf="${myconf} --enable-xinerama=no"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer -mpowerpc-gfxopt
+ filter-flags -ffast-math
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+ fi
+
+ # Added to get thunderbird to compile on sparc.
+ replace-sparc64-flags
+
+ if use ppc && [[ $(gcc-major-version) == 3 && $(gcc-minor-version) == 3 ]]
+ then
+ append-flags -fno-strict-aliasing
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_THUNDERBIRD=1 || die
+
+ # Build the enigmail plugin
+ if use crypt
+ then
+ einfo "Building Enigmail plugin..."
+ cd ${S}/extensions/ipc
+ make || die
+
+ cd ${S}/extensions/enigmail
+ make || die
+ fi
+}
+
+src_install() {
+ dodir /usr/lib
+ dodir /usr/lib/MozillaThunderbird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaThunderbird
+
+ #fix permissions
+ chown -R root:root ${D}/usr/lib/MozillaThunderbird
+
+ dobin ${FILESDIR}/thunderbird
+
+ # Install icon and .desktop for menu entry
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/thunderbird-icon.png
+
+ # Fix comment of menu entry
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/icon/mozillathunderbird.desktop
+ fi
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaThunderbird"
+
+ # Fix permissions on misc files
+ find ${MOZILLA_FIVE_HOME}/ -perm 0700 -exec chmod 0755 {} \; || :
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+ # Register Components and Chrome
+ einfo "Registering Components and Chrome..."
+ LD_LIBRARY_PATH=${ROOT}/usr/lib/MozillaThunderbird ${MOZILLA_FIVE_HOME}/regxpcom
+ LD_LIBRARY_PATH=${ROOT}/usr/lib/MozillaThunderbird ${MOZILLA_FIVE_HOME}/regchrome
+ # Fix permissions of component registry
+ chmod 0644 ${MOZILLA_FIVE_HOME}/components/compreg.dat
+ # Fix directory permissions
+ find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
+ # Fix permissions on chrome files
+ find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
+
+ einfo "Please note that the binary name has changed from MozillaThunderbird"
+ einfo "to simply 'thunderbird'."
+}