summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-10-22 18:24:58 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-10-22 18:24:58 +0000
commitbb216c6752347541423fde0e1fc271cddfbf010b (patch)
tree1aa63bedd9522222d2bbc0d729dd48b75a8fd527 /net-mail
parentVersion bump to 2.6.23.1 (diff)
downloadgentoo-2-bb216c6752347541423fde0e1fc271cddfbf010b.tar.gz
gentoo-2-bb216c6752347541423fde0e1fc271cddfbf010b.tar.bz2
gentoo-2-bb216c6752347541423fde0e1fc271cddfbf010b.zip
Version bump
(Portage version: 2.1.3.15)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailgraph/ChangeLog8
-rw-r--r--net-mail/mailgraph/files/digest-mailgraph-1.143
-rw-r--r--net-mail/mailgraph/mailgraph-1.14.ebuild149
3 files changed, 159 insertions, 1 deletions
diff --git a/net-mail/mailgraph/ChangeLog b/net-mail/mailgraph/ChangeLog
index b00142e74266..0072d9bfbafb 100644
--- a/net-mail/mailgraph/ChangeLog
+++ b/net-mail/mailgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailgraph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/ChangeLog,v 1.22 2007/10/15 14:44:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/ChangeLog,v 1.23 2007/10/22 18:24:57 dertobi123 Exp $
+
+*mailgraph-1.14 (22 Oct 2007)
+
+ 22 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
+ +mailgraph-1.14.ebuild:
+ Version bump
15 Oct 2007; Markus Rothe <corsair@gentoo.org> mailgraph-1.13.ebuild:
Stable on ppc64
diff --git a/net-mail/mailgraph/files/digest-mailgraph-1.14 b/net-mail/mailgraph/files/digest-mailgraph-1.14
new file mode 100644
index 000000000000..556efd67ea50
--- /dev/null
+++ b/net-mail/mailgraph/files/digest-mailgraph-1.14
@@ -0,0 +1,3 @@
+MD5 0f0ae91968ea7ae0c1d14985c560530b mailgraph-1.14.tar.gz 22014
+RMD160 928969a4bdc3b9ff39a7fe16b98789f07b02e5f8 mailgraph-1.14.tar.gz 22014
+SHA256 50ea6ea8a33f5015926edd8b70a4d954ac27df4863514bddc5e69c948a7aac81 mailgraph-1.14.tar.gz 22014
diff --git a/net-mail/mailgraph/mailgraph-1.14.ebuild b/net-mail/mailgraph/mailgraph-1.14.ebuild
new file mode 100644
index 000000000000..2d952b03801b
--- /dev/null
+++ b/net-mail/mailgraph/mailgraph-1.14.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailgraph/mailgraph-1.14.ebuild,v 1.1 2007/10/22 18:24:57 dertobi123 Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="A mail statistics RRDtool frontend for Postfix"
+HOMEPAGE="http://mailgraph.schweikert.ch/"
+SRC_URI="http://mailgraph.schweikert.ch//pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="logrotate"
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Tail
+ >=net-analyzer/rrdtool-1.2.2
+ logrotate? ( app-admin/logrotate )"
+DEPEND=">=sys-apps/sed-4"
+
+user_group_setup() {
+ # add user and group for mailgraph daemon
+ # also add mgraph to the group adm so it's able to
+ # read syslog logfile /var/log/messages (should be owned by
+ # root:adm with permission 0640)
+ enewgroup mgraph
+ enewuser mgraph -1 -1 /var/empty mgraph,adm
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use net-analyzer/rrdtool perl \
+ || die "net-analyzer/rrdtool must be built with USE=perl"
+ user_group_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s|\(my \$rrd = '\).*'|\1/var/lib/mailgraph/mailgraph.rrd'|" \
+ -e "s|\(my \$rrd_virus = '\).*'|\1/var/lib/mailgraph/mailgraph_virus.rrd'|" \
+ mailgraph.cgi || die "sed mailgraph.cgi failed"
+}
+
+pkg_preinst() {
+ user_group_setup
+}
+
+src_install() {
+ webapp_src_preinst
+ # be sure to run webapp_src_install *before* doing the directories below
+ # because it cripples all other permissions :-(
+ webapp_src_install
+
+ # for the RRDs
+ dodir /var/lib
+ diropts -omgraph -gmgraph -m0750
+ dodir /var/lib/mailgraph
+ keepdir /var/lib/mailgraph
+
+ # log and pid file
+ diropts ""
+ dodir /var/log
+ dodir /var/run
+ diropts -omgraph -gadm -m0750
+ dodir /var/log/mailgraph
+ keepdir /var/log/mailgraph
+ dodir /var/run/mailgraph
+ keepdir /var/run/mailgraph
+
+ if use logrotate ; then
+ # logrotate config for mailgraph log
+ diropts ""
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/mailgraph.logrotate-new mailgraph
+ fi
+
+ # mailgraph daemon
+ newbin mailgraph.pl mailgraph
+
+ # mailgraph CGI script
+ exeinto ${MY_CGIBINDIR}
+ doexe mailgraph.cgi
+
+ # init/conf files for mailgraph daemon
+ newinitd "${FILESDIR}"/mailgraph.initd-new mailgraph
+ newconfd "${FILESDIR}"/mailgraph.confd-new mailgraph
+
+ # docs
+ dodoc README CHANGES COPYING
+}
+
+pkg_postinst() {
+ # Fix ownerships - previous versions installed these with
+ # root as owner
+ if [[ has_version <=net-mail/mailgraph-1.12 ]] ; then
+ if [[ -d /var/lib/mailgraph ]] ; then
+ chown mgraph:mgraph /var/lib/mailgraph
+ fi
+ if [[ -d /var/log/mailgraph ]] ; then
+ chown mgraph:adm /var/log/mailgraph
+ fi
+ if [[ -d /var/run/mailgraph ]] ; then
+ chown mgraph:adm /var/run/mailgraph
+ fi
+ fi
+ elog
+ elog "Mailgraph will run as user mgraph with group adm by default."
+ elog "This can be changed in /etc/conf.d/mailgraph if it doesn't fit."
+ elog "Remember to adjust MG_DAEMON_LOG, MG_DAEMON_PID and MG_DAEMON_RRD"
+ elog "as well!"
+ elog
+ elog
+ ewarn
+ ewarn "Please make sure the MG_LOGFILE (default: /var/log/messages) is readable"
+ ewarn "by group adm or change MG_DAEMON_GID in /etc/conf.d/mailgraph accordingly!"
+ ewarn
+ ewarn "Please make sure *all* mail related logs (MTA, spamfilter, virus scanner)"
+ ewarn "go to the file /var/log/messages or change MG_LOGFILE in"
+ ewarn "/etc/conf.d/mailgraph accordingly! Otherwise mailgraph won't get to know"
+ ewarn "the corresponding events (virus/spam mail found etc.)."
+ ewarn
+ ewarn
+ elog
+ elog "Checking for user apache"
+ if egetent passwd apache >&/dev/null; then
+ elog
+ elog "Adding user apache to group mgraph so the included"
+ elog "CGI script is able to read the mailgraph RRD files"
+ elog
+ if ! gpasswd -a apache mgraph >&/dev/null; then
+ eerror "Failed to add user apache to group mgraph!"
+ eerror "Please check manually."
+ fi
+ else
+ elog
+ elog "User apache not found, maybe we will be running a"
+ elog "webserver with a different UID?"
+ elog "If that's the case, please add that user to the"
+ elog "group mgraph manually to enable the included"
+ elog "CGI script to read the mailgraph RRD files:"
+ elog
+ elog "\tgpasswd -a <user> mgraph"
+ elog
+ fi
+}