summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-29 23:40:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-29 23:40:14 +0000
commita2c6a97de7dd90279545413ea7fbfb685d6cc45a (patch)
tree915d31fe96a5db09d4fbd96353a9ddd9138d12e6 /net-mail
parent*** empty log message *** (diff)
downloadgentoo-2-a2c6a97de7dd90279545413ea7fbfb685d6cc45a.tar.gz
gentoo-2-a2c6a97de7dd90279545413ea7fbfb685d6cc45a.tar.bz2
gentoo-2-a2c6a97de7dd90279545413ea7fbfb685d6cc45a.zip
Update, glibc header fix
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/files/pine-4.33-gentoo.diff50
-rw-r--r--net-mail/pine/pine-4.33.ebuild57
2 files changed, 107 insertions, 0 deletions
diff --git a/net-mail/pine/files/pine-4.33-gentoo.diff b/net-mail/pine/files/pine-4.33-gentoo.diff
new file mode 100644
index 000000000000..11d2bb74260d
--- /dev/null
+++ b/net-mail/pine/files/pine-4.33-gentoo.diff
@@ -0,0 +1,50 @@
+--- pine4.33/imap/src/osdep/unix/os_lnx.c~ Fri Jan 19 03:29:33 2001
++++ pine4.33/imap/src/osdep/unix/os_lnx.c Sun Apr 29 23:06:50 2001
+@@ -22,6 +22,7 @@
+ #include "mail.h"
+ #include "osdep.h"
+ #include <stdio.h>
++#include <time.h>
+ #include <sys/time.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>
+--- pine4.33/imap/src/osdep/unix/news.c~ Fri Jan 19 03:28:33 2001
++++ pine4.33/imap/src/osdep/unix/news.c Sun Apr 29 23:17:55 2001
+@@ -26,6 +26,7 @@
+ #include "osdep.h"
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <time.h>
+ #include "news.h"
+ #include "misc.h"
+ #include "newsrc.h"
+--- pine4.33/imap/src/osdep/unix/phile.c~ Fri Jan 19 03:31:20 2001
++++ pine4.33/imap/src/osdep/unix/phile.c Sun Apr 29 23:27:13 2001
+@@ -28,6 +28,7 @@
+ #include <pwd.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <time.h>
+ #include "phile.h"
+ #include "rfc822.h"
+ #include "misc.h"
+--- pine4.33/imap/src/osdep/unix/mh.c~ Fri Jan 19 03:27:37 2001
++++ pine4.33/imap/src/osdep/unix/mh.c Sun Apr 29 23:32:25 2001
+@@ -27,6 +27,7 @@
+ #include <pwd.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <time.h>
+ #include "mh.h"
+ #include "misc.h"
+ #include "dummy.h"
+--- pine4.33/imap/src/osdep/unix/mx.c~ Fri Jan 19 03:28:09 2001
++++ pine4.33/imap/src/osdep/unix/mx.c Sun Apr 29 23:35:22 2001
+@@ -27,6 +27,7 @@
+ #include <pwd.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
++#include <time.h>
+ #include "mx.h"
+ #include "misc.h"
+ #include "dummy.h"
diff --git a/net-mail/pine/pine-4.33.ebuild b/net-mail/pine/pine-4.33.ebuild
new file mode 100644
index 000000000000..d4fb77facdbe
--- /dev/null
+++ b/net-mail/pine/pine-4.33.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.33.ebuild,v 1.1 2001/04/29 23:40:14 achim Exp $
+
+A=pine4.33.tar.gz
+S=${WORKDIR}/pine4.33
+DESCRIPTION="Pine, Pico, Pilot, imapd"
+SRC_URI="ftp://ftp.cac.washington.edu/pine/"${A}
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72"
+
+src_unpack() {
+ unpack ${A}
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+
+}
+
+src_compile() {
+ try ./build lnp
+}
+
+src_install() {
+ cd ${S}
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest
+ dosbin bin/imapd
+
+ doman doc/pico.1 doc/pine.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+
+
+