summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-18 18:25:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-18 18:25:21 +0000
commit6030921c0b3633f1fe1a7900862e37df27d0454e (patch)
treebc97f696949b1b17637c544d8aa0f62744ccd21e /net-mail
parentAdded the patch for the mremap/munmap vulnerability. Bug #42024. (Manifest re... (diff)
downloadgentoo-2-6030921c0b3633f1fe1a7900862e37df27d0454e.tar.gz
gentoo-2-6030921c0b3633f1fe1a7900862e37df27d0454e.tar.bz2
gentoo-2-6030921c0b3633f1fe1a7900862e37df27d0454e.zip
add CVS backported patch to deal with NZDT (UTC+13) (#41817)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog6
-rw-r--r--net-mail/evolution/evolution-1.4.5.ebuild8
-rw-r--r--net-mail/evolution/files/evolution-1.4.5-nztimezone.patch53
3 files changed, 64 insertions, 3 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index e8b6b4408a50..dc2be74f7d47 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/evolution
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.89 2004/02/07 07:15:28 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.90 2004/02/18 18:25:21 liquidx Exp $
+
+ 18 Feb 2004; Alastair Tse <liquidx@gentoo.org> evolution-1.4.5.ebuild,
+ files/evolution-1.4.5-nztimezone.patch:
+ add CVS backported patch to deal with NZDT (UTC+13) (#41817)
07 Feb 2004; Alastair Tse <liquidx@gentoo.org> evolution-1.4.3.ebuild,
evolution-1.4.4.ebuild, evolution-1.4.5.ebuild:
diff --git a/net-mail/evolution/evolution-1.4.5.ebuild b/net-mail/evolution/evolution-1.4.5.ebuild
index 1bc3fc7edfc9..a535753514ac 100644
--- a/net-mail/evolution/evolution-1.4.5.ebuild
+++ b/net-mail/evolution/evolution-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.4.5.ebuild,v 1.12 2004/02/07 07:15:28 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.4.5.ebuild,v 1.13 2004/02/18 18:25:21 liquidx Exp $
# kde before gnome2, otherwise kde_src_install will override gnome2_src_install
use kde && inherit kde
@@ -81,7 +81,11 @@ src_unpack() {
# Patch for 64-bit ... should be retired for 1.5 which contains
# the patch upstream
- epatch ${FILESDIR}/evolution-1.4.4-alpha.patch || die "epatch failed"
+ epatch ${FILESDIR}/evolution-1.4.4-alpha.patch
+ # Patch backported from CVS. Fixes NZDT (UTC+13) timezone on emails
+ # http://bugzilla.ximian.com/show_bug.cgi?id=49357
+ cd ${S}/camel; epatch ${FILESDIR}/${P}-nztimezone.patch
+
}
##### Compile evolution specific db3 for static linking #####
diff --git a/net-mail/evolution/files/evolution-1.4.5-nztimezone.patch b/net-mail/evolution/files/evolution-1.4.5-nztimezone.patch
new file mode 100644
index 000000000000..452f746ea3bc
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.4.5-nztimezone.patch
@@ -0,0 +1,53 @@
+Index: camel-mime-utils.c
+===================================================================
+RCS file: /cvs/gnome/evolution/camel/camel-mime-utils.c,v
+retrieving revision 1.183.4.4
+diff -u -r1.183.4.4 camel-mime-utils.c
+--- camel-mime-utils.c 26 Sep 2003 16:04:49 -0000 1.183.4.4
++++ camel-mime-utils.c 8 Oct 2003 16:40:41 -0000
+@@ -3530,12 +3530,12 @@
+ offset = (*inptr++)=='-'?-1:1;
+ offset = offset * header_decode_int(&inptr);
+ d(printf("abs signed offset = %d\n", offset));
+- if (offset < -1200 || offset > 1200)
++ if (offset < -1200 || offset > 1400)
+ offset = 0;
+ } else if (isdigit(*inptr)) {
+ offset = header_decode_int(&inptr);
+ d(printf("abs offset = %d\n", offset));
+- if (offset < -1200 || offset > 1200)
++ if (offset < -1200 || offset > 1400)
+ offset = 0;
+ } else {
+ char *tz = decode_token(&inptr);
+Index: camel-text-index.c
+===================================================================
+RCS file: /cvs/gnome/evolution/camel/camel-text-index.c,v
+retrieving revision 1.16
+diff -u -r1.16 camel-text-index.c
+--- camel-text-index.c 11 Jun 2003 19:38:33 -0000 1.16
++++ camel-text-index.c 8 Oct 2003 16:40:44 -0000
+@@ -55,6 +55,8 @@
+ /* cursor debug */
+ #define c(x)
+
++#define CAMEL_TEXT_INDEX_MAX_WORDLEN (60)
++
+ #ifdef ENABLE_THREADS
+ #define CAMEL_TEXT_INDEX_LOCK(kf, lock) (e_mutex_lock(((CamelTextIndex *)kf)->priv->lock))
+ #define CAMEL_TEXT_INDEX_UNLOCK(kf, lock) (e_mutex_unlock(((CamelTextIndex *)kf)->priv->lock))
+@@ -1478,11 +1480,12 @@
+ utf8[utf8len] = 0;
+ g_string_append(p->buffer, utf8);
+ } else {
+- if (p->buffer->len) {
++ if (p->buffer->len < CAMEL_TEXT_INDEX_MAX_WORDLEN) {
+ text_index_name_add_word(idn, p->buffer->str);
+ /*camel_index_name_add_word(idn, p->buffer->str);*/
+- g_string_truncate(p->buffer, 0);
+ }
++
++ g_string_truncate (p->buffer, 0);
+ }
+ }
+