summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-05-31 16:35:27 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-05-31 16:35:27 +0000
commit52665838d666ba9b1051d1609e1e7b24549e617c (patch)
treea26ad66972f5714a619174c81110928d6542b63f /net-mail
parentVersion bump for another batch of Ethereal vulnerabilities; bug #51022. (Mani... (diff)
downloadgentoo-2-52665838d666ba9b1051d1609e1e7b24549e617c.tar.gz
gentoo-2-52665838d666ba9b1051d1609e1e7b24549e617c.tar.bz2
gentoo-2-52665838d666ba9b1051d1609e1e7b24549e617c.zip
Version bump for a security vulnerability; closes bug #52043.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailman/ChangeLog9
-rw-r--r--net-mail/mailman/files/digest-mailman-2.1.51
-rw-r--r--net-mail/mailman/mailman-2.1.5.ebuild130
3 files changed, 138 insertions, 2 deletions
diff --git a/net-mail/mailman/ChangeLog b/net-mail/mailman/ChangeLog
index 7224ab06d75d..d98ee1cc0125 100644
--- a/net-mail/mailman/ChangeLog
+++ b/net-mail/mailman/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for net-mail/mailman
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.32 2004/05/14 14:18:33 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.33 2004/05/31 16:35:27 plasmaroo Exp $
+
+*mailman-2.1.5 (31 May 2004)
+
+ 31 May 2004; <plasmaroo@gentoo.org> +mailman-2.1.5.ebuild:
+ Version bump for a security vulnerability; closes bug #52043.
14 May 2004; Luca Barbato <lu_zero@gentoo.org> mailman-2.1.4.ebuild:
Marked ~ppc
12 Mar 2004; Martin Holzer <mholzer@gentoo.org> mailman-2.1.4.ebuild:
- correcting version in einfo. closes 44464.
+ Correcting version in einfo. Closes bug #44464.
23 Feb 2004; Sven Blumenstein <bazik@gentoo.org> mailman-2.1.4.ebuild:
Stable on sparc. Thanks to Josh Grebe <josh@brokedown.net> for testing!
diff --git a/net-mail/mailman/files/digest-mailman-2.1.5 b/net-mail/mailman/files/digest-mailman-2.1.5
new file mode 100644
index 000000000000..1e43ecb04e52
--- /dev/null
+++ b/net-mail/mailman/files/digest-mailman-2.1.5
@@ -0,0 +1 @@
+MD5 f5f56f04747cd4aff67427e7a45631af mailman-2.1.5.tgz 5745912
diff --git a/net-mail/mailman/mailman-2.1.5.ebuild b/net-mail/mailman/mailman-2.1.5.ebuild
new file mode 100644
index 000000000000..622e85d9ea70
--- /dev/null
+++ b/net-mail/mailman/mailman-2.1.5.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.5.ebuild,v 1.1 2004/05/31 16:35:27 plasmaroo Exp $
+
+IUSE="apache2"
+
+DESCRIPTION="A python-based mailing list server with an extensive web interface"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.list.org/"
+
+SLOT="O"
+LICENSE="GPL-2"
+KEYWORDS="-x86"
+
+DEPEND=">=dev-lang/python-2.3
+ virtual/mta
+ net-www/apache"
+
+INSTALLDIR="/usr/local/mailman"
+APACHEGID="81"
+MAILGID="280"
+
+pkg_setup() {
+ if ! grep -q ^mailman: /etc/group ; then
+ groupadd -g 280 mailman || die "problem adding group mailman"
+ fi
+ if ! grep -q ^mailman: /etc/passwd ; then
+ useradd -u 280 -g mailman -G cron -s /bin/bash \
+ -d ${INSTALLDIR} -c "mailman" mailman
+ fi
+ mkdir -p ${INSTALLDIR}
+ chown mailman:mailman ${INSTALLDIR}
+ chmod 2775 ${INSTALLDIR}
+}
+
+src_compile() {
+ econf \
+ --prefix=${INSTALLDIR} \
+ --with-mail-gid=${MAILGID} \
+ --with-cgi-gid=${APACHEGID} \
+ || die "configure failed"
+
+ make || die "make failed"
+ sed -i -e 's:import japanese:#import japanese:' \
+ -e 's:import korean:#import korean:' \
+ -e 's:import korean.aliases:#import korean.aliases:' misc/paths.py
+}
+
+src_install () {
+ ID=${D}${INSTALLDIR}
+
+ make prefix=${ID} var_prefix=${ID} doinstall || die
+
+ keepdir ${INSTALLDIR}/logs
+ keepdir ${INSTALLDIR}/locks
+ keepdir ${INSTALLDIR}/spam
+ keepdir ${INSTALLDIR}/archives/public
+
+ chown -R mailman:mailman ${ID}
+ chmod 2775 ${ID}
+
+ if [ "`use apache2`" ]; then
+ dodir /etc/apache2/conf/modules.d
+ insinto /etc/apache2/conf/modules.d
+ newins ${FILESDIR}/mailman.conf 50_mailman.conf
+ else
+ dodir /etc/apache/conf/addon-modules
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mailman.conf
+ fi
+
+ dodoc ${FILESDIR}/README.gentoo
+ dodoc ACK* BUGS FAQ NEWS README* TODO UPGRADING INSTALL
+ dodoc contrib/README.check_perms_grsecurity contrib/mm-handler.readme
+ dodoc contrib/virtusertable contrib/mailman.mc
+
+ cp contrib/*.py contrib/majordomo2mailman.pl contrib/auto \
+ contrib/mm-handler* ${D}/usr/local/mailman/bin
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ if [ -f ${ROOT}/var/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/var/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.dist"
+ fi
+ if [ -f ${ROOT}/home/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/home/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.py.dist"
+ fi
+ if [ -f ${ROOT}/usr/local/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/usr/local/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.py.dist"
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mailman.rc mailman
+ }
+
+pkg_postinst() {
+ cd ${INSTALLDIR}
+ bin/update
+ bin/check_perms -f
+ einfo ""
+ einfo "Please read /usr/share/doc/${PF}/README.gentoo.gz for additional"
+ einfo "Setup information, mailman will NOT run unless you follow"
+ einfo "those instructions!"
+ einfo ""
+ if [ ! "`use apache2`" ]; then
+ einfo "It appears that you aren't running apache2..."
+ einfo "ebuild /var/db/pkg/net-mail/${PN}/${PF}.ebuild config"
+ einfo "to add the mailman hooks to your config"
+ fi
+}
+
+pkg_config() {
+ if [ ! "`use apache2`" ]; then
+ einfo "Updating apache config"
+ einfo "added: \"Include conf/addon-modules/mailman.conf\""
+ einfo "to ${ROOT}etc/apache/conf/apache.conf"
+ echo "Include conf/addon-modules/mailman.conf" \
+ >> ${ROOT}etc/apache/conf/apache.conf
+ fi
+}