summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-28 10:03:32 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-28 10:03:32 +0000
commit3a1f9973e84f59d77a25c51bd24f69718290e77b (patch)
tree5ae56eeb4ff2f6e12a07257a1d6d831340a66126 /net-mail/vmailmgr/files
parentAdded ppc keyword to quanta-3.0_pre2.ebuild (diff)
downloadgentoo-2-3a1f9973e84f59d77a25c51bd24f69718290e77b.tar.gz
gentoo-2-3a1f9973e84f59d77a25c51bd24f69718290e77b.tar.bz2
gentoo-2-3a1f9973e84f59d77a25c51bd24f69718290e77b.zip
Updated diff from bug #8445. Added CXX="g++" to solve compile
problems with gcc3 and added -lsupc++ to LIBS so linked code will understand the new, delete, etc. operator functions. Changed to econf and einstall. Whew!
Diffstat (limited to 'net-mail/vmailmgr/files')
-rw-r--r--net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r1.diff109
1 files changed, 109 insertions, 0 deletions
diff --git a/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r1.diff b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r1.diff
new file mode 100644
index 000000000000..170491dff485
--- /dev/null
+++ b/net-mail/vmailmgr/files/vmailmgr-0.96.9-gentoo-r1.diff
@@ -0,0 +1,109 @@
+diff -ur vmailmgr-0.96.9.orig/authenticate/Makefile.am vmailmgr-0.96.9/authenticate/Makefile.am
+--- vmailmgr-0.96.9.orig/authenticate/Makefile.am Sat Sep 23 23:23:32 2000
++++ vmailmgr-0.96.9/authenticate/Makefile.am Sat Jul 16 20:26:57 2011
+@@ -1,6 +1,6 @@
+ bin_PROGRAMS = checkvpw vauthenticate
+ authlib_PROGRAMS = authvmailmgr
+-authlibdir = ${prefix}/lib/courier-imap/libexec/authlib/
++authlibdir = ${prefix}/lib/courier-imap/authlib/
+
+ noinst_PODS = checkvpw.pod vauthenticate.pod
+ noinst_HTMLS = $(noinst_PODS:.pod=.html)
+diff -ur vmailmgr-0.96.9.orig/authenticate/Makefile.in vmailmgr-0.96.9/authenticate/Makefile.in
+--- vmailmgr-0.96.9.orig/authenticate/Makefile.in Sun Oct 1 07:33:29 2000
++++ vmailmgr-0.96.9/authenticate/Makefile.in Sat Jul 16 20:26:57 2011
+@@ -83,7 +83,7 @@
+
+ bin_PROGRAMS = checkvpw vauthenticate
+ authlib_PROGRAMS = authvmailmgr
+-authlibdir = ${prefix}/lib/courier-imap/libexec/authlib/
++authlibdir = ${prefix}/lib/courier-imap/authlib/
+
+ noinst_PODS = checkvpw.pod vauthenticate.pod
+ noinst_HTMLS = $(noinst_PODS:.pod=.html)
+diff -ur vmailmgr-0.96.9.orig/authenticate/authvmailmgr.cc vmailmgr-0.96.9/authenticate/authvmailmgr.cc
+--- vmailmgr-0.96.9.orig/authenticate/authvmailmgr.cc Tue Aug 1 20:09:27 2000
++++ vmailmgr-0.96.9/authenticate/authvmailmgr.cc Sat Jul 16 20:31:09 2011
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "misc/exec.h"
+ #include "authvlib.h"
+ // Courier-IMAP includes
+diff -ur vmailmgr-0.96.9.orig/authenticate/checkvpw.cc vmailmgr-0.96.9/authenticate/checkvpw.cc
+--- vmailmgr-0.96.9.orig/authenticate/checkvpw.cc Fri Aug 11 01:39:27 2000
++++ vmailmgr-0.96.9/authenticate/checkvpw.cc Sat Jul 16 20:57:31 2011
+@@ -18,6 +18,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <sys/types.h>
++#include <stdlib.h>
+ #include "config/configrc.h"
+ #include "misc/exec.h"
+ #include "misc/stat_fns.h"
+diff -ur vmailmgr-0.96.9.orig/authenticate/vauthenticate.cc vmailmgr-0.96.9/authenticate/vauthenticate.cc
+--- vmailmgr-0.96.9.orig/authenticate/vauthenticate.cc Tue Aug 1 21:05:31 2000
++++ vmailmgr-0.96.9/authenticate/vauthenticate.cc Sat Jul 16 20:56:36 2011
+@@ -17,6 +17,7 @@
+ #include <config.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include "authvlib.h"
+ #include "fdbuf/fdbuf.h"
+
+diff -ur vmailmgr-0.96.9.orig/configure vmailmgr-0.96.9/configure
+--- vmailmgr-0.96.9.orig/configure Sun Oct 1 07:24:23 2000
++++ vmailmgr-0.96.9/configure Sat Jul 16 20:26:57 2011
+@@ -2682,7 +2682,7 @@
+ done
+
+
+-cgidir='${prefix}/cgi-bin'
++cgidir='/home/httpd/cgi-bin'
+
+
+ trap '' 1 2 15
+diff -ur vmailmgr-0.96.9.orig/lib/misc/exec.cc vmailmgr-0.96.9/lib/misc/exec.cc
+--- vmailmgr-0.96.9.orig/lib/misc/exec.cc Thu Aug 3 19:35:09 2000
++++ vmailmgr-0.96.9/lib/misc/exec.cc Sat Jul 16 20:28:08 2011
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
++#include <string.h>
+ #include "exec.h"
+ #include "config/configrc.h"
+
+diff -ur vmailmgr-0.96.9.orig/lib/misc/keystrlist.cc vmailmgr-0.96.9/lib/misc/keystrlist.cc
+--- vmailmgr-0.96.9.orig/lib/misc/keystrlist.cc Mon Apr 3 21:22:13 2000
++++ vmailmgr-0.96.9/lib/misc/keystrlist.cc Sat Jul 16 20:28:41 2011
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ void keystrlist::set(const mystring& var, const mystring& val)
+diff -ur vmailmgr-0.96.9.orig/lib/misc/strlist.cc vmailmgr-0.96.9/lib/misc/strlist.cc
+--- vmailmgr-0.96.9.orig/lib/misc/strlist.cc Mon Apr 3 21:22:14 2000
++++ vmailmgr-0.96.9/lib/misc/strlist.cc Sat Jul 16 20:29:20 2011
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+ #include <config.h>
++#include <string.h>
+ #include "strlist.h"
+
+ static const char* compare(const char* ptr, const char* end,
+diff -ur vmailmgr-0.96.9.orig/lib/mystring/append.cc vmailmgr-0.96.9/lib/mystring/append.cc
+--- vmailmgr-0.96.9.orig/lib/mystring/append.cc Sun Feb 13 07:16:03 2000
++++ vmailmgr-0.96.9/lib/mystring/append.cc Sat Jul 16 20:30:01 2011
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include "mystring.h"
+ #include "trace.h"
+