summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-05-06 21:00:09 +0000
committerEray Aslan <eras@gentoo.org>2011-05-06 21:00:09 +0000
commit2689bcc262005704eafb3feed513683f25335285 (patch)
treec944f1f60036310f88f51bfc2e5cdc77d5b3db96 /net-mail/uw-mailutils
parentversion bump (diff)
downloadgentoo-2-2689bcc262005704eafb3feed513683f25335285.tar.gz
gentoo-2-2689bcc262005704eafb3feed513683f25335285.tar.bz2
gentoo-2-2689bcc262005704eafb3feed513683f25335285.zip
add pam and ssl USE flags - bugs 129729 276401
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/uw-mailutils')
-rw-r--r--net-mail/uw-mailutils/ChangeLog10
-rw-r--r--net-mail/uw-mailutils/files/uw-mailutils-ssl.patch13
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild54
3 files changed, 75 insertions, 2 deletions
diff --git a/net-mail/uw-mailutils/ChangeLog b/net-mail/uw-mailutils/ChangeLog
index a6f0c82c24d6..c0c9ef45755f 100644
--- a/net-mail/uw-mailutils/ChangeLog
+++ b/net-mail/uw-mailutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/uw-mailutils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.30 2009/09/23 19:15:01 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.31 2011/05/06 21:00:09 eras Exp $
+
+*uw-mailutils-2007e-r1 (06 May 2011)
+
+ 06 May 2011; Eray Aslan <eras@gentoo.org> +uw-mailutils-2007e-r1.ebuild,
+ +files/uw-mailutils-ssl.patch:
+ add pam and ssl USE flags - bugs 129729 276401
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> uw-mailutils-2007b.ebuild,
uw-mailutils-2007e.ebuild:
diff --git a/net-mail/uw-mailutils/files/uw-mailutils-ssl.patch b/net-mail/uw-mailutils/files/uw-mailutils-ssl.patch
new file mode 100644
index 000000000000..0214030e3ffa
--- /dev/null
+++ b/net-mail/uw-mailutils/files/uw-mailutils-ssl.patch
@@ -0,0 +1,13 @@
+--- imap-2007e/src/osdep/unix/Makefile 2009-07-05 10:00:54.000000000 +0300
++++ imap-2007e/src/osdep/unix/Makefile 2009-07-05 10:04:42.000000000 +0300
+@@ -54,8 +54,8 @@
+
+ # Extended flags needed for SSL. You may need to modify.
+
+-SSLDIR=/usr/local/ssl
+-SSLCERTS=$(SSLDIR)/certs
++SSLDIR=/usr
++SSLCERTS=/etc/ssl/certs
+ SSLKEYS=$(SSLCERTS)
+ SSLINCLUDE=$(SSLDIR)/include
+ SSLLIB=$(SSLDIR)/lib
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild
new file mode 100644
index 000000000000..9976006ced2a
--- /dev/null
+++ b/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007e-r1.ebuild,v 1.1 2011/05/06 21:00:09 eras Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="imap-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Mail utilities from the UW"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam ssl"
+
+DEPEND="!<mail-client/pine-4.64-r1
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ !<net-mail/uw-imap-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ chmod -R ug+w "${S}"
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-2004g.patch" || die "epatch failed"
+ epatch "${FILESDIR}/${PN}-ssl.patch" || die "epatch failed"
+
+ sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
+ src/mailutil/Makefile \
+ src/mtest/Makefile || die "sed failed patching Makefile CFLAGS."
+
+ append-flags -fPIC
+}
+
+src_compile() {
+ local port=slx
+ use elibc_FreeBSD && port=bsf
+ use pam && port=lnp
+ local ssltype=none
+ use ssl && ssltype=nopwd
+ yes | make "${port}" EXTRACFLAGS="${CFLAGS}" SSLTYPE="${ssltype}" || die
+}
+
+src_install() {
+ into /usr
+ dobin mailutil/mailutil mtest/mtest
+ doman src/mailutil/mailutil.1
+}