summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-15 00:42:13 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-15 00:42:13 +0000
commit11cd4515dd2c9191cfea98187b331e5978b687cd (patch)
tree6851df4f54237cd23e91a36af945f8d9c0e70d3e /net-mail/up-imapproxy
parentStable for HPPA (bug #529126). (diff)
downloadgentoo-2-11cd4515dd2c9191cfea98187b331e5978b687cd.tar.gz
gentoo-2-11cd4515dd2c9191cfea98187b331e5978b687cd.tar.bz2
gentoo-2-11cd4515dd2c9191cfea98187b331e5978b687cd.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527570).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-mail/up-imapproxy')
-rw-r--r--net-mail/up-imapproxy/ChangeLog6
-rw-r--r--net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch20
-rw-r--r--net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild17
3 files changed, 37 insertions, 6 deletions
diff --git a/net-mail/up-imapproxy/ChangeLog b/net-mail/up-imapproxy/ChangeLog
index 4a4eef1612c7..d22218459216 100644
--- a/net-mail/up-imapproxy/ChangeLog
+++ b/net-mail/up-imapproxy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/up-imapproxy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/ChangeLog,v 1.30 2014/08/10 20:47:04 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/ChangeLog,v 1.31 2014/11/15 00:42:13 jer Exp $
+
+ 15 Nov 2014; Jeroen Roovers <jer@gentoo.org>
+ +files/up-imapproxy-1.2.7-tinfo.patch, up-imapproxy-1.2.7.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527570).
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> up-imapproxy-1.2.7.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
new file mode 100644
index 000000000000..cbe19e8c0eb7
--- /dev/null
+++ b/net-mail/up-imapproxy/files/up-imapproxy-1.2.7-tinfo.patch
@@ -0,0 +1,20 @@
+--- a/configure.in
++++ b/configure.in
+@@ -121,12 +121,16 @@
+ save_LIBS="$LIBS"
+ LIB_CURSES=""
+ AC_CHECK_LIB(curses, initscr, LIB_CURSES="-lcurses", [ curses_found=no ])
+-if test "$curses_found" == no; then
++if test "$curses_found" = no; then
+ AC_CHECK_LIB(ncurses, initscr, LIB_CURSES="-lncurses",
+ AC_ERROR([Can't compile without curses!!!]))
+ fi
+
+ LIBS="$save_LIBS"
++
++AC_SEARCH_LIBS(stdscr, tinfo curses ncurses, [LIB_CURSES="$LIB_CURSES $ac_cv_search_stdscr"],
++ AC_MSG_ERROR([Cannot find a library providing stdscr]))
++
+ AC_SUBST(LIB_CURSES)
+
+
diff --git a/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
index 08dca3e9f022..f60befc8b0a4 100644
--- a/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
+++ b/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild,v 1.4 2014/08/10 20:47:04 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/up-imapproxy/up-imapproxy-1.2.7.ebuild,v 1.5 2014/11/15 00:42:13 jer Exp $
-EAPI=4
+EAPI=5
-inherit eutils
+WANT_AUTOCONF="2.1"
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Proxy IMAP transactions between an IMAP client and an IMAP server"
HOMEPAGE="http://www.imapproxy.org/"
@@ -26,8 +27,11 @@ S=${WORKDIR}/squirrelmail-imap_proxy-${PV}
src_prepare() {
epatch "${FILESDIR}/${P}"-ldflags.patch
- sed -i -e 's:in\.imapproxyd:imapproxyd:g' \
- README Makefile.in include/imapproxy.h || die "sed failed"
+ epatch "${FILESDIR}/${P}"-tinfo.patch
+
+ sed -i \
+ -e 's:in\.imapproxyd:imapproxyd:g' \
+ README Makefile.in include/imapproxy.h || die
#buffer oveflow
#http://lists.andrew.cmu.edu/pipermail/imapproxy-info/2010-June/000874.html
@@ -35,9 +39,12 @@ src_prepare() {
-e "/define BUFSIZE/s/4096/8192/" \
-e "/define MAXPASSWDLEN/s/64/8192/" \
include/imapproxy.h
+
+ eautoreconf
}
src_configure() {
+ tc-export CC
econf \
$(use_with kerberos krb5) \
$(use_with ssl openssl) \