summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-23 21:11:03 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-23 21:11:03 +0000
commita0e9840839a64e97fbe9ff5bdb40c95eb69c7e80 (patch)
tree09d1705714c2dd906b44b2bb90522abe46d37eb0 /net-mail/pine
parentWhoops. Need /usr/lib/libc-client.a symlink to /usr/lib/c-client.a or (diff)
downloadgentoo-2-a0e9840839a64e97fbe9ff5bdb40c95eb69c7e80.tar.gz
gentoo-2-a0e9840839a64e97fbe9ff5bdb40c95eb69c7e80.tar.bz2
gentoo-2-a0e9840839a64e97fbe9ff5bdb40c95eb69c7e80.zip
Hmmm. Forgot to commit. Oops!
Diffstat (limited to 'net-mail/pine')
-rw-r--r--net-mail/pine/pine-4.44-r3.ebuild103
1 files changed, 103 insertions, 0 deletions
diff --git a/net-mail/pine/pine-4.44-r3.ebuild b/net-mail/pine/pine-4.44-r3.ebuild
new file mode 100644
index 000000000000..01027639634e
--- /dev/null
+++ b/net-mail/pine/pine-4.44-r3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.44-r3.ebuild,v 1.1 2002/02/23 21:11:03 g2boojum Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Pine 'a Program for Internet News & Email', email client"
+SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.washington.edu/pine/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )"
+
+if [ "`use imap`" ] ; then
+ PROVIDE="virtual/imapd"
+ PROVIDE="virtual/imapUW"
+fi
+
+src_unpack() {
+ unpack ${A}
+
+ # RH patches, although I've ignored the "RH" patch itself
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-fixhome.patch
+ patch -d ${S} -p0 < ${FILESDIR}/imap-4.7c2-flock.patch
+ cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.21-passwd.patch
+ if [ "`use ldap`" ] ; then
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.30-ldap.patch
+ mkdir ${S}/ldap
+ ln -s /usr/lib ${S}/ldap/libraries
+ ln -s /usr/include ${S}/ldap/include
+ fi
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-boguswarning.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.31-segfix.patch
+ patch -d ${S} -p0 < ${FILESDIR}/pine-4.40-lockfile-perm.patch
+ patch -d ${S} -p1 < ${FILESDIR}/imap-2000-time.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
+ patch -d ${S} -p1 < ${FILESDIR}/pine-4.44-multibyte.patch
+
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+}
+
+src_compile() {
+ BUILDOPTS=""
+ if [ "`use ssl`" ]
+ then
+ BUILDOPTS="${BUILDOPTS} SSLDIR=/usr/ssl SSLINCLUDE=/usr/include/openssl"
+ BUILDOPTS="${BUILDOPTS} SSLLIB=/usr/lib SSLTYPE=unix"
+ else
+ BUILDOPTS="${BUILDOPTS} NOSSL"
+ fi
+ if [ "`use ldap`" ]
+ then
+ ./contrib/ldap-setup lnp lnp
+ else
+ BUILDOPTS="${BUILDOPTS} NOLDAP"
+ fi
+
+ ./build ${BUILDOPTS} lnp || die
+}
+
+src_install() {
+ into /usr
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload
+ dosbin bin/imapd
+
+ if [ "`use imap`" ] ; then
+ insinto /usr/include
+ doins imap/c-client/{mail,imap4r1,rfc822,linkage}.h
+ dolib.a imap/c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+ fi
+
+ doman doc/pico.1 doc/pine.1 doc/pine.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+
+ insinto /etc
+ doins doc/mime.types
+ donewins doc/mailcap.unx mailcap
+
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/FAQ imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dodoc doc/tech-notes/*.html
+}
+
+
+
+