summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-23 16:45:18 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-23 16:45:18 +0000
commit2ade78aec03c1b91ed4280825e5899ce357e13cf (patch)
treeb712519abf221344a1fa916d9b63d7a1b3f96b2e /net-mail/libpst/libpst-0.5.2.ebuild
parentremoving the gtkmm-2.12 mask (diff)
downloadgentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.tar.gz
gentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.tar.bz2
gentoo-2-2ade78aec03c1b91ed4280825e5899ce357e13cf.zip
Version bump to 0.5.2. Fixes bug 180001.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-mail/libpst/libpst-0.5.2.ebuild')
-rw-r--r--net-mail/libpst/libpst-0.5.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/libpst/libpst-0.5.2.ebuild b/net-mail/libpst/libpst-0.5.2.ebuild
new file mode 100644
index 000000000000..1e31902117a0
--- /dev/null
+++ b/net-mail/libpst/libpst-0.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libpst/libpst-0.5.2.ebuild,v 1.1 2007/09/23 16:45:18 philantrop Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools and library for reading Outlook files (.pst format)"
+HOMEPAGE="http://alioth.debian.org/projects/libpst/"
+SRC_URI="http://alioth.debian.org/download.php/844/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-0.5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS CREDITS TODO FILE-FORMAT || die "dodoc failed"
+ dohtml FILE-FORMAT.html || die "dohtml failed"
+}