summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-06-09 10:37:55 +0000
committerTorsten Veller <tove@gentoo.org>2008-06-09 10:37:55 +0000
commitf5e0b8f7cc2c5cd616f011cb46bf156a480828d1 (patch)
treedaa7db1abe19e6d1bc74a20a5d59584cca432435 /net-mail/imapsync
parentSwitched virtual/tetex -> virtual/latex-base and added amd64 keyword (see bug... (diff)
downloadgentoo-2-f5e0b8f7cc2c5cd616f011cb46bf156a480828d1.tar.gz
gentoo-2-f5e0b8f7cc2c5cd616f011cb46bf156a480828d1.tar.bz2
gentoo-2-f5e0b8f7cc2c5cd616f011cb46bf156a480828d1.zip
Add Digest-HMAC to RDEPEND (#225089). Don't run imapsync during installation to minimize DEPEND
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-mail/imapsync')
-rw-r--r--net-mail/imapsync/ChangeLog8
-rw-r--r--net-mail/imapsync/imapsync-1.217.ebuild21
2 files changed, 22 insertions, 7 deletions
diff --git a/net-mail/imapsync/ChangeLog b/net-mail/imapsync/ChangeLog
index 98ce1f54c99e..a10feee21875 100644
--- a/net-mail/imapsync/ChangeLog
+++ b/net-mail/imapsync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/imapsync
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.17 2007/08/30 12:03:25 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.18 2008/06/09 10:37:55 tove Exp $
+
+ 09 Jun 2008; Torsten Veller <tove@gentoo.org> imapsync-1.217.ebuild:
+ Add Digest-HMAC to RDEPEND (#225089). Don't run imapsync during installation
+ to minimize DEPEND.
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing langthang from metadata due to his retirement (see #53239 for
diff --git a/net-mail/imapsync/imapsync-1.217.ebuild b/net-mail/imapsync/imapsync-1.217.ebuild
index 957e26582136..524f2d337910 100644
--- a/net-mail/imapsync/imapsync-1.217.ebuild
+++ b/net-mail/imapsync/imapsync-1.217.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.217.ebuild,v 1.1 2007/04/01 17:51:53 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.217.ebuild,v 1.2 2008/06/09 10:37:55 tove Exp $
inherit eutils
@@ -13,17 +13,28 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=dev-perl/Mail-IMAPClient-2.1.4"
-
+DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}
virtual/perl-Digest-MD5
dev-perl/Net-SSLeay
virtual/perl-MIME-Base64
dev-perl/TermReadKey
- dev-perl/IO-Socket-SSL"
+ dev-perl/IO-Socket-SSL
+ dev-perl/Digest-HMAC
+ >=dev-perl/Mail-IMAPClient-2.1.4"
RESTRICT="test"
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s/^install: testp/install:/" \
+ -e "s/^\(all: ChangeLog README\) VERSION/\1/" "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake all || die
+}
+
src_install() {
make DESTDIR="${D}" install || die "make failed"
dodoc CREDITS ChangeLog FAQ README TODO || die "dodoc failed"