summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-04-08 13:00:00 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-04-08 13:00:00 +0000
commita534f56b41624eeef99f31b67e264c7b0d469fec (patch)
treebf85f191ff1c6a6e22eec21c518de0ed7f137ec9 /net-mail/gnubiff
parentfixed. (diff)
downloadgentoo-2-a534f56b41624eeef99f31b67e264c7b0d469fec.tar.gz
gentoo-2-a534f56b41624eeef99f31b67e264c7b0d469fec.tar.bz2
gentoo-2-a534f56b41624eeef99f31b67e264c7b0d469fec.zip
version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-mail/gnubiff')
-rw-r--r--net-mail/gnubiff/ChangeLog7
-rw-r--r--net-mail/gnubiff/files/digest-gnubiff-2.1.31
-rw-r--r--net-mail/gnubiff/gnubiff-2.1.3.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/net-mail/gnubiff/ChangeLog b/net-mail/gnubiff/ChangeLog
index b7fa2c3292fe..4a6d639d150b 100644
--- a/net-mail/gnubiff/ChangeLog
+++ b/net-mail/gnubiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/gnubiff
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.4 2005/03/12 19:49:31 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/ChangeLog,v 1.5 2005/04/08 13:00:00 nakano Exp $
+
+*gnubiff-2.1.3 (08 Apr 2005)
+
+ 08 Apr 2005; Masatomo Nakano <nakano@gentoo.org> +gnubiff-2.1.3.ebuild:
+ Version bump.
12 Mar 2005; Masatomo Nakano <nakano@gentoo.org> gnubiff-2.1.1.ebuild:
Added libglade to DEPEND.
diff --git a/net-mail/gnubiff/files/digest-gnubiff-2.1.3 b/net-mail/gnubiff/files/digest-gnubiff-2.1.3
new file mode 100644
index 000000000000..486e4ee01959
--- /dev/null
+++ b/net-mail/gnubiff/files/digest-gnubiff-2.1.3
@@ -0,0 +1 @@
+MD5 4832f7d100b8f476082191a4c66a772f gnubiff-2.1.3.tar.gz 765654
diff --git a/net-mail/gnubiff/gnubiff-2.1.3.ebuild b/net-mail/gnubiff/gnubiff-2.1.3.ebuild
new file mode 100644
index 000000000000..b3be0cc00aa7
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.1.3.ebuild,v 1.1 2005/04/08 13:00:00 nakano Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnome password"
+
+RDEPEND="virtual/libc
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ gnome? ( >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )"
+
+DEPEND="${RDEPEND}
+ gnome? ( dev-util/pkgconfig )"
+
+src_compile() {
+ local myconf
+
+ if use gnome; then
+ myconf="${myconf} --prefix=`pkg-config libpanelapplet-2.0 --variable=prefix`"
+ else
+ myconf="${myconf} --disable-gnome"
+ fi
+
+ if use password; then
+ einfo "generating random password"
+ myconf="${myconf} --with-password --with-password-string=${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO
+}