summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-01 21:53:25 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-01 21:53:25 +0000
commitb9da9be0d2a0d433cd38ab5ff508be5c7c822cd7 (patch)
tree7363bad949e0296a5c486b6441d2114c78a04cbe /net-mail/courier-imap
parentNew version. (diff)
downloadgentoo-2-b9da9be0d2a0d433cd38ab5ff508be5c7c822cd7.tar.gz
gentoo-2-b9da9be0d2a0d433cd38ab5ff508be5c7c822cd7.tar.bz2
gentoo-2-b9da9be0d2a0d433cd38ab5ff508be5c7c822cd7.zip
Update to latest release. Beautify the .ebuild. Make it pam_stack aware.
Add buggy imap client support.
Diffstat (limited to 'net-mail/courier-imap')
-rw-r--r--net-mail/courier-imap/ChangeLog30
-rw-r--r--net-mail/courier-imap/courier-imap-1.4.3.ebuild137
-rw-r--r--net-mail/courier-imap/files/digest-courier-imap-1.4.31
3 files changed, 158 insertions, 10 deletions
diff --git a/net-mail/courier-imap/ChangeLog b/net-mail/courier-imap/ChangeLog
index 0b0a7fa091bc..df2b6be436ca 100644
--- a/net-mail/courier-imap/ChangeLog
+++ b/net-mail/courier-imap/ChangeLog
@@ -1,23 +1,33 @@
# ChangeLog for net-mail/courier-imap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/ChangeLog,v 1.3 2002/03/14 17:37:01 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/ChangeLog,v 1.4 2002/04/01 21:53:25 woodchip Exp $
+
+*courier-imap-1.4.3 (1 Apr 2002)
+
+ 1 Apr 2002; Donny Davies <woodchip@gentoo.org> :
+
+ Updated to latest release. Made some cosmetic/beautification fixes.
+ It's real purdy now :) Added --enable-workarounds-for-imap-client-bugs
+ to the ./configure flags, which helps some clients -- notable Netscape
+ Messenger. Commented out the pam.d/ stuff since it already comes with
+ pam_stack aware pam config files. Gentoo now has pam_stack.. Hooray!
*courier-imap-1.4.1-r4 (14 Mar 2002)
-14 Mar 2002; Grant Goodyear <g2boojum@gentoo.org> :
+ 14 Mar 2002; Grant Goodyear <g2boojum@gentoo.org> :
- Fixed bug where /etc/courier-imap/pop3d didn't have
- MAILDIR=.maildir set.
+ Fixed bug where /etc/courier-imap/pop3d didn't have MAILDIR=.maildir set.
*courier-imap-1.4.1-r2 (21 Feb 2002)
21 Feb 2002; Grant Goodyear <g2boojum@gentoo.org> :
- Modified the ebuild so that /usr/sbin/{imapd,pop3d} get renamed to
- /usr/sbin/{courier-imapd,courier-pop3d}. I also had to change hack
- the /usr/lib/courier-imap/*.rc files to call these newly-named functions.
- While I was at it I cleaned up the ebuilds and fixed the not-yet-caught
- bug that pop3d was still trying to use Maildir instead of ${MAILDIR}.
- Fixes bug #584.
+
+ Modified the ebuild so that /usr/sbin/{imapd,pop3d} get renamed to
+ /usr/sbin/{courier-imapd,courier-pop3d}. I also had to change hack
+ the /usr/lib/courier-imap/*.rc files to call these newly-named functions.
+ While I was at it I cleaned up the ebuilds and fixed the not-yet-caught
+ bug that pop3d was still trying to use Maildir instead of ${MAILDIR}.
+ Fixes bug #584.
*courier-imap-1.4.1-r1 (1 Feb 2002)
diff --git a/net-mail/courier-imap/courier-imap-1.4.3.ebuild b/net-mail/courier-imap/courier-imap-1.4.3.ebuild
new file mode 100644
index 000000000000..c20ea5296029
--- /dev/null
+++ b/net-mail/courier-imap/courier-imap-1.4.3.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.4.3.ebuild,v 1.1 2002/04/01 21:53:25 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An IMAP daemon designed specifically for maildirs"
+SRC_URI="http://ftp1.sourceforge.net/courier/${P}.tar.gz"
+HOMEPAGE="http://www.courier-mta.org/"
+
+PROVIDE="virtual/imapd"
+RDEPEND="virtual/glibc
+ >=dev-libs/openssl-0.9.6
+ pam? ( >=sys-libs/pam-0.75 )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/procps"
+
+# This package is complete if you just need basic IMAP functionality.
+# Here are some things that still need fixing:
+# o supervise support (of course)
+# o creation of imapd-ssl, pop3-ssl, pop3 init.d scripts
+# (I only converted the imapd.rc script)
+# o tweaking of config files
+# o My RC script is configured to look for maildirs in ~/.maildir
+# (my preference, and the official Gentoo Linux standard location)
+# instead of the more traditional and icky ~/Maildir.
+# o We need to add an /etc/mail.conf.
+
+src_compile() {
+ local myconf
+ use pam || myconf="${myconf} --without-authpam"
+ use ldap || myconf="${myconf} --without-authldap"
+ use mysql || myconf="${myconf} --without-authmysql"
+ use berkdb && myconf="${myconf} --with-db=db"
+ use berkdb || myconf="${myconf} --with-db=gdbm"
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --disable-root-check \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/courier-imap \
+ --libexecdir=/usr/lib/courier-imap \
+ --localstatedir=/var/lib/courier-imap \
+ --enable-workarounds-for-imap-client-bugs \
+ --with-authdaemonvar=/var/lib/courier-imap/authdaemon \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ # change the pem file location..
+ cp imap/imapd-ssl.dist imap/imapd-ssl.dist.old
+ sed -e "s:^\(TLS_CERTFILE=\).*:\1/etc/courier-imap/imapd.pem:" \
+ imap/imapd-ssl.dist.old > imap/imapd-ssl.dist
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /var/lib/courier-imap
+ mkdir -p ${D}/etc/pam.d
+ make install DESTDIR=${D}
+
+ # avoid name collisions in /usr/sbin wrt imapd and pop3d
+ cd ${D}/usr/sbin
+ for name in imapd pop3d
+ do
+ mv ${name} "courier-${name}"
+ done
+
+ # hack /usr/lib/courier-imap/foo.rc to use ${MAILDIR} instead of
+ # 'Maildir', and to use /usr/sbin/courier-foo names.
+ cd ${D}/usr/lib/courier-imap
+ local service
+ for service in imapd pop3d
+ do
+ local type
+ for type in "" "-ssl"
+ do
+ local file
+ file="${service}${type}.rc"
+ cp ${file} ${file}.orig
+ sed -e 's/Maildir/${MAILDIR}/' \
+ -e "s/\/usr\/sbin\/${service}/\/usr\/sbin\/courier-${service}/" \
+ ${file}.orig > ${file}
+ done
+ done
+
+ cd ${D}/etc/courier-imap
+ local x
+ for x in pop3d pop3d-ssl imapd imapd-ssl authdaemonrc
+ do
+ mv ${x}.dist ${x}
+ done
+
+ # add a value for ${MAILDIR} to /etc/courier-imap/imapd
+ for service in imapd pop3d
+ do
+ echo -e '\n#Hardwire a value for ${MAILDIR}' >> ${service}
+ echo 'MAILDIR=.maildir' >> ${service}
+ done
+
+ cd ${D}/usr/sbin
+ for x in *
+ do
+ if [ -L ${x} ]
+ then
+ rm ${x}
+ fi
+ done
+
+ cd ../share
+ mv * ../sbin
+ mv ../sbin/man .
+ cd ..
+
+ # we dont need to do this.. // woodchip
+ #cd ${D}/etc/pam.d
+ #for x in *
+ #do
+ # cp ${x} ${x}.orig
+ # sed -e 's#/lib/security/##g' ${x}.orig > ${x}
+ # rm ${x}.orig
+ #done
+
+ rm ${D}/usr/sbin/mkimapdcert
+ exeinto /usr/sbin ; doexe ${FILESDIR}/mkimapdcert
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/courier-imap-rc6 courier-imap
+ newexe ${FILESDIR}/courier-imap-ssl-rc6 courier-imap-ssl
+
+ # not neccesary, we now have pam_stack, and courier-imap
+ # comes with pam_stack aware pam.d/ files already :) // woodchip
+ #insinto /etc/pam.d ; doins ${FILEDIR}/pam.d-imap
+}
diff --git a/net-mail/courier-imap/files/digest-courier-imap-1.4.3 b/net-mail/courier-imap/files/digest-courier-imap-1.4.3
new file mode 100644
index 000000000000..ccb6670e3ddb
--- /dev/null
+++ b/net-mail/courier-imap/files/digest-courier-imap-1.4.3
@@ -0,0 +1 @@
+MD5 26aa7d71affa94fe9adcfb4f043ecd3d courier-imap-1.4.3.tar.gz 1191288